2 Replies Latest reply: Oct 4, 2012 4:55 PM by JesusFreak412
JesusFreak412 Level 1 Level 1 (0 points)

I need my iTunes 7 to work, but I have Mac OS X 10.5.8. and for iTunes 7, Mac OS X 10.6.8. or higher is required. What do I need to do to achieve this?

Thanks


Mac OS X (10.5.8)