5 Replies Latest reply: Oct 5, 2012 11:47 PM by PBook1400
merrill1989 Level 1 (0 points)

I have had my iPhone 5 for almost a week and I have had recurring problems with my connection to my Retina Macbook Pro.


I plug my iPhone into my RMBP, via lightning/USB cable, and more often then not my computer does not recognize that any device has been plugged in.


In the off chance that it makes a solid connection then everything works fine (syncing is a bit slower than my iPhone 4) until something happens and my computer loses connection with the iPhone.


I'm not moving anything once a sync begins, however it still drops the iPhone.


Everything is brand new.


Is this the cable, software, or the iPhone itself?

iPhone 5, iOS 6, All software is up to date
  • merrill1989 Level 1 (0 points)

    EDIT: Also the iPhone will charge via USB connection to my Macbook, but it does not show up in iTunes, nor can I sync it. This is the reason why I don't believe the cable is faulty and something else may be going on here.

  • PBook1400 Level 1 (0 points)

    I have this exact same problem.  Battery charges, but phone does not appear in iTunes, Image Capture or iTunes. 

  • sam.jage Level 1 (0 points)

    If your iPhone/iPod/iPad is connected and charging, its connected to the logic board as current is making it to the device.


    Go to system preferences, then to user account, and finally login items.


    Make sure that Itunes Helper is checked and running.


    A great widget to use is called Istat Pro.  This widget tells you processes that are running and a vast amount of other great information.




    Let me know if engaging Itunes Helper made a difference.


    If it's not that, I would recommend reinstalling iTunes, or checking for an update.


    Hope things work out!

  • PBook1400 Level 1 (0 points)

    @sam.jage  Thanks for the response.  Unfortunately, iTunes Helper was already on and it didn't help.  What else you got? 



  • PBook1400 Level 1 (0 points)

    Okay, so I went to the genius bar today and spoke to two Apple geniuses, each of whom had a possible solution. Neither one worked for me, but both are good ideas and they may work for someone reading this thread so I'll include them here.   I also tried one other thing which worked for me.  I'll list that below. 


    Genius 1's Idea - Do a complete uninstall of iTunes before reinstalling. SInce there is no uninstaller for iTunes, she suggested a program called AppZapper, which would remove iTunes and all associated files.  I tried this and AppZapper works fast as advertised.  Unfortunately, it fixed nothing. 


    Genius 2's Idea - He was convinced it was a system problem so he suggested a clean install of the operating system, which would require a backup of all files and downloaded apps.  SInce I wasn't prepared to go to such extreme measures just yet, I tried one more thing which I should have tried much earlier...


    My Idea - I launched Disk Utility and ran Verify Disk, followed by Repair Permissions.  It found and repaired many damaged resource files, most of them belonging to iTunes, Image Capture, and iPhoto, the exact programs that were unable to see my iPhone.  Anyway, this worked.  iTunes kicks in instantly upon plugging in the iPhone, and appears in the Devices list just as it should.  And it may be my imagination, but everything seems to run a little zippier now.


    So Genius 2 was half right.  It was the system that was broken.  But doing a clean install turned out to be unnecessary. 


    Hope this helps.