Previous 1 2 Next 15 Replies Latest reply: Apr 19, 2013 6:58 AM by Ty Ford1
bek76 Level 1 Level 1

can anybody help me with this. I find it extremely annoying that I have to restart the computer as the finder will not relaunch without doing so.  I am new to Mac and have just purchased one last month and am having a few issues with it I would like to resolve.


iMac, Mac OS X (10.7.5)
  • roam Level 6 Level 6

    Is your Finder feeezing that is causing you to Force Quit it?

     

    A freezing Finder is quite unusual, from my experience. I would focus on why it is freezing in the first place. Do you notice it happening when you use a particular application, or plug in a particular device. In other words, can you notice a pattern, or does it occur at any time?

  • bek76 Level 1 Level 1

    the only time I use force quit is when something has frozen in the finder like when im copying files and it hasn't worked and it continually saying copying but nothing is happening.  When I do force quit the finder and then try and relaunch the finder it says something like can't relaunch or not responding and the only way I can launch the finder to do anything again is by restarting the computer which is a real pain and just wondering if there is another way around that?

     

    THanks

  • roam Level 6 Level 6

    This problem exhibiting in Finder itself being fundamental, leads me to wonder if it might be hardware such a failing RAM module.

    You could run the Apple Hardware Test, by doing a restart and holding the D key.

    Intel-based Macs: Using Apple Hardware Test

     

    If it passes that, then on the software side, again, is it happening with any particular application, or involve very large files like video, or involves transfer to an external drive? For example with the latter possibility, the connection may fail at some point causing the process to stall.

     

    As you can see, it is such a vague condition, pinpointing it is difficult.

    Do you have suffiecient RAM?

    To see Under the  icon, click About This Mac, and the RAM will be shown as Memory.

  • bek76 Level 1 Level 1

    i restarted the computer and did a thorough hardware test which took over an hour and found no problems.  I definitely have enough ram - 16gb the max I think

     

    Im not sure if it is happening when copying from external to mac or not as its not happening often just sometimes and is a pain having to restart.

  • roam Level 6 Level 6

    I can understand your frustration, better than I can the cause.

    The next time it does this, just note down what you were copying (file or folder) from where to where and the time it froze.

    Then on restart, that time may locate some clues in the system.log (accessible in the console.app) if that problematic stalled process was being logged.

  • bek76 Level 1 Level 1

    ok so finder crashed on me again just before and I took a few screen shots to show you, I was copying files I had on my portable hdd into a folder on my portable hdd - I really don't think it makes a difference if im copying from my mac hdd or my portable hdd it still seems to do it sometimes

     

    Screen Shot 2012-10-06 at 2.26.16 PM.pngScreen Shot 2012-10-06 at 2.25.54 PM.png

  • roam Level 6 Level 6

    I think we can focus on the portable HDD. Your screen shows multiple transfers of media files, so there is a lot of data being moved there. Just out of interest how many GB of data in total from those 5 file transfers were you moving.

     

    If you click on the portable HDD and do a Get Info (Command +I), see what format it is.

    If it is a FAT32 format they have a limitation of 4GB maximum file size limit.

    That is something to check out.

     

    On another tack, if you tried to do that copy again, but this time just one file at a time instead of all five, and it was successfully completed without freezing, that would be a useful experiment.

  • bek76 Level 1 Level 1

    i have tried just doing one at a time and it makes no difference, if its not going to copy its not going to copy no matter the size or how many files as it has done it on just one file before.  Im not sure if its fat 32 or exfat as its only ever used on a mac and not from pc to mac anymore.  Also Im just double checking the format type on my hdd which is EX FAT which allows for much bigger files to be transferred.  I'm running out of other options as to what is going on! silly thing its very annoying and frutrating!

  • roam Level 6 Level 6

    I notice you have the latest update 10.7.5.

    Did this problem occur before you updated when still on 10.7.4?

  • roam Level 6 Level 6

    See if starting in safe mode straightens things out.

     

    To start up into Safe Mode (to Safe Boot), do this:

    1. Be sure your Mac is shut down.
    2. Press the power button.
    3. Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    4. Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

    To leave Safe Mode, restart the computer normally, without holding any keys during startup.

     

    from http://support.apple.com/kb/HT1455

  • bek76 Level 1 Level 1

    yes it occured before the update and after - do I still need to boot in safe mode?

  • roam Level 6 Level 6

    I don't know what is causing this problem, so I'll just be making random suggestions.

    Booting up in safemode is worth trying. Please do.

  • Cheese Man Level 1 Level 1

    I just experienced this issue. The only thing I seemingly could do was force a shut down. Instead, I physically unplugged the FireWire 800 drive that was connected. There is undoubtably an issue with FireWire 800 drives that causes strange freeze issues. I experienced it on my older MBP with snow leopard and now on my newer iMac with mt lion. Every time yanking the 800 cable corrected the freeze. For the record, I have had this happen with both WD and LaCie drives. I have reported this to Apple so hopefully a fix will happen eventually. Searching the net for "FireWire 800 freezes Mac" will show numerous similar reports.

  • Raymond F Level 1 Level 1

    I get the same problem sometimes. The way I was able to restart the finder without restarting the computer was to select mission control on the dock to get to the desktop. From the desktop I find the finder icon and select it. The finder restarts with all the windows I had when it quit. I am using OS 10.8

Previous 1 2 Next