3 Replies Latest reply: Nov 4, 2012 2:46 AM by Jordashton
Jordashton Level 1 Level 1 (0 points)

Sigh, I've had this problem for a while now and just about exhausted every avenue I can think of but have yet to come up with a solution.

 

Problem: Accross all apps that use the camera (Facetime / Skype / Photobooth etc). Camera works fine for a while after a restart (mostly - will explain further down) but after a day or so, give or take, I will receive the dreaded "There is no camera attached to this computer." message.

 

Once this message has appeared, it appears to be game-over until one of the following:-

     •Restart Computer (sometimes works)

     •PRAM reset (sometimes works - might just be down to the restart rarther than the actual resetting of the PRAM)

     •Holding power button on restart until 'beep' (Usually works)

Note that:-

     •Once I get this message, the camera no longer appears in the System Profiler.

     •Camera functions fine when it's on.

 

 

So far I have tried:-

     •using different apps: doesn't seem to matter which app I'm using, i.e. if I exclusively use Skype, the camera will still fail. The same is true of photobooth

     •doing the above restarts/resetting things: In all cases, the fix is temporary and the problem persists after (usually) a day or so.

     •Leaving the app running: I thought if I kept the camera "active" all the time, it might continue to work. Not the case, after a day or so I came back and just had a picture frozen on in and upon restarting facetime, you guessed it, "There is no camera attached to this computer".

     •Formatting disk and reinstalling OS: I thought that the issue might be to a conflict somewhere in the preferences etc so did a clean reinstall of the MacOS 10.8 however, note that this has occurred under 10.6, 10.7 & 10.8.

 

From the above I deduce that either:-

     •There is a fault/conflict in the software / OS though it would have to be something that only kicked in after a certain amount of time. Note that I've not yet timed how long until the camera fails as this is somewhat impractical.

     •There is a hardware fault that again, only surfaces after a given amount of time. I'm thinking this is more likely after having done the clean install and the problem persisting. I thought I would seek advice on here before "opening her up"!

I've tried to be as thorough as I possible in diagnosing the problem and though there seem to be a few threads discussing how to solve the problem, I've not come accross one where it repeatedly arises.

 

Thanks,
Jono.


iMac (24-inch Mid 2007), OS X Mountain Lion (10.8.2), Facetime
  • mjeddy Level 1 Level 1 (5 points)

    I have the exact same problem and have done the same troubleshooting steps with no luck.  Don't want to spend the money on opening up the camera as it seems more like a software issue.

  • Jordashton Level 1 Level 1 (0 points)

    Bit of an update...

     

    I've been working under windows on a bootcamp partition and notice that the camera works fine. I've been skyping on consecutive days and the camera never disappears like under osx so this suggests it is definitely not a hardware issue. What the heck is going on in OSX that is stopping the built in camera from function correctly?!!?!! Very disappointed.

  • Jordashton Level 1 Level 1 (0 points)

    Update 2:

     

    Since booting in and out of bootcamp, the facetime camera seems to be working a little better. I doesn't seem feasable but I wonder whether something on the windows partition was not relinquishing the camera when shutting down and changing back to MacOS...

     

    That's all I can really think of as I've not done anything much else different.

     

    Hope this helps someone and I'll try to update should the camera stop working again!