Previous 1 2 Next 19 Replies Latest reply: Oct 31, 2014 9:14 AM by Zargo
Bookham Measures Level 1 Level 1 (0 points)

I have been using iTunes/iPhone sync for years without any difficulty.  Calendars and contacts all going back and fore as expected.

 

Yesterday I added a new email account within Outlook - one for Office365, effectively a Microsoft Exchange account.

 

This seems to have done at least two things.

 

  • It deleted all of my mail rules.  This is documented online and I can deal with it.
  • Created a new outlook data file (this time an .ost versus a .pst).  It has made this file the "default".

 

So, now I have two outlook data files, one personal where I receive my POP mail and all my contacts and calendars are defined, and a new one, "ost" that is for my exchange email account.

 

The problem: when syncing, all my contacts and calendar entries have been removed from my iPhone.  It seems that iTunes is syncing from my new exchange account (which has no contacts or calendar entries).  I created one contact here and it went over to the phone.

 

Question: How can I tell iTunes that I want it to sync my Personal, old,  Data File, not the new one?

 

I have  tried to change the default data file back to my personal one, within outlook, but it says this:

 

The selected Outlook data file (.pst) format cannot be used.  Outlook data files (.pst) must use the same format as the offline Outlook data files (.ost).  Select a matching Outlook data file (.ost) or turn off cache mode in the Account Settings.

 

I do not really want to start messing around with Outlook settings, I simply want to tell iTunes _which_ Outlook data file to use for syncing.

 

Can anyone help me with this task?

 

Thanks and regards

 

David

  • Bookham Measures Level 1 Level 1 (0 points)

    Incidentally, I checked the Outlook Cache option.  If I deselect it I will not be able to access any of the mail from my Exchange account unless I'm connected to the Internet, so this is far from ideal.

     

    @Apple - how do I choose which Outlook data file to sync with? 

  • Bookham Measures Level 1 Level 1 (0 points)

    OK, a bit more searching and I've found this article.

     

    http://windowstipsandfixes.blogspot.co.uk/2009/11/use-itunes-to-sync-to-non-defa ult-data.html

     

     

    1. Quit Outlook. 
    2. Go to Control Panel \ Mail 32-Bit) and create a new profile (skip email set-up).
    3. Change the data file for this profile to be the data file with your calendars/contacts in.
    4. Set the new profile to be the one against "Always use this profile", OK.
    5. Sync
    6. Change the "Always use this profile" profile back to your main one, OK.
    7. Launch Outlook

     

    When syncing in the future, you'll need to repeat steps 4-6.

     

    I've not tried re-syncing or doing it with Outlook running, would suggest quiting to avoid any conflicts.

     

    @Apple - where can I set the "Profile" iTunes uses?  This would save me from having to switch before syncing manually.

  • reywalgoh Level 1 Level 1 (0 points)

    I had the same issue, and I found THE FIX!

     

    On your PC, go to Control Panel > Mail 32-Bit > Data Files:  then set the pst file as the default!

     

    Don't bother creating a second profile...you can do the above fix and then your Personal folder will be synced with your phone.  The iPhone can automatically sync the Exchange folders you want without using iTunes (On your phone: Settings > Mail, Contacts, Calendars > What you've named your Exchange e-mail account )

  • Bookham Measures Level 1 Level 1 (0 points)

    Thanks for posting that follow-up, but that is not true.

     

    If  It try to set my PST file as the default I get the following message:

     

    "The selected Outlook data file (.pst) format cannot be used.  Outlook data files (.pst) must use the same format as offline Outlook data files (.ost).  Select a matching Outlook data file (.pst) or turn off cache mode in the Account Settings."

    I suspect there fore that you're not fully integrated with exchange and are perhaps accessing in IMAP or some other mode.

     

    For example, is your Exchange data file PST or OST?

  • reywalgoh Level 1 Level 1 (0 points)

    I know how aggrivating this issue is, but I swear it's working for me.

     

    I have an .ost file for my Exchange and a .pst for Personal.  I checked the settings of each account (CP > Mail > Data Files > Settings (while highlighting the file). My .pst file just has a General tab: 2 options - Change Password and Compact Now.  The .ost file has 4 tabs: General, Advanced, Security, and Connection.

     

    My settings are:

    General: When starting: Automatically detect connection state

     

    Advanced: Cashed Exchange Mode Settings: Use Cached Exchange Mode (checked) > Download shared folders (checked)(Download Public Folder Favorites remains unchecked)

    Mailbox Mode: Outlook is running in Unicode mode against Microsoft Exchange

     

     

    Security > Encryption: Encrypt data between Microsoft Outlook and Microsoft Exchange

    Security > Logon network security: Negotiate Authentication

     

    Connection: LAN

    Outlook Anywhere: Connect to Microsoft Exchange using HTTP

     

    Are we identical so far?

  • Bookham Measures Level 1 Level 1 (0 points)

    Yes, we're the same although I have no "Download Public Folder Favorites" 

     

    I'm using Outlook 2010.  When I try to set my PST as the default it says no

  • tzbikowski Level 4 Level 4 (1,945 points)

    Bookham,

     

    iTunes will always use your default email account which is set in Outlook.

    The confusion above comes from trying to change the default data file not the account.

    Please do not try to change default data file for your email accounts as it will cause more issues.

    So the solution for you is to forget the Data file tab in account settings and go to Accounts tab.
    Please change the default account from Exchange to your POP.

    You do not have to make your pst default as it attached to your POP account so both are default now and i Tunes will read from them not the Exchange.

     

    Hope it makes sense but please do post if you have further problems with it.

  • reywalgoh Level 1 Level 1 (0 points)

    I'd like to know if that works for you, Bookham...my default e-mail account is set in Account Settings to my Exchange e-mail account; however, by changing the default in Data Files to my pst file, iTunes is syncing my personal contacts and calendar, not Exchange.

     

    Again, my default e-mail account is my Exchange e-mail, but iTunes is NOT syncing with the Exchange Account. It syncs with the .pst file I told it to.

  • Bookham Measures Level 1 Level 1 (0 points)

    Hi tzbikowski, welcome to the party.

     

    Bad news though.  My POP email account is the default.  This is only the default for "sending" email, nothing else, (not mail storage OR who/what iTunes syncs with).

     

    The solution I have is a pain in the backside, but it works, so it is all about the default data file, nothing to do with the default sending account.

     

    Ideally I'd like to be able to set my PST data file to be the default so that this is synced but that simply cannot be done due to the error listed above.

     

    Despite having the same settings as reywalgoh, who can set his PST to be the default data file, I cannot.

  • tzbikowski Level 4 Level 4 (1,945 points)

    Bookham,

    I can tell you how to make pst file default - but this will be very wrong think to do. You files from the Exchange will be downloaded to the pst and wiped from the Exchange. This is a reason for the Exchange ost file witch is just cache unlike pst which is email storage.

     

    So here you go.

    the reason why Exchange 2007 does not like your pst and will not use it for delivery as default is that it was created in older version of Outlook and has diffrenet encoding text ANSI with limit of 2GB.

    You will need to convert it to the newer pst unicode format.

    You can follow the seteps here:

     

    http://www.datanumen.com/aor/convert-ansi-to-unicode.htm

     

    PLEASE NOTE: This is not a good practice. Once your ost file becomes default. Exchange will deliver all future and past email items to it. This means they will be gone from the exchange and if youuse another computer or device which you use to connect to the Exchange server you will render them empty. It is like converting Exchange account into POP.

     

    So there you go.

     

    Coming back to the orginal question / issue you will be better of by creating second profile in your Outlook and move your Exchange account there.

     

    Let me know if there is anything else I can help with.

  • J .Stanworth Level 1 Level 1 (0 points)

    Hi, I have the same issue. My default outlook file is located on D:/... for ease of backing up all my data. So now I want to point iTunes to this location. I am assuming it goes to the default C:/ location. I am running Windows 7 professional 64bit.

     

    Please can you give me input about how to create a smooth sync between outlook and itunes?

     

    Thanks.

  • matthiasmax Level 1 Level 1 (0 points)

    Same problem then Mr. Standworth.

     

    Solution in sight without the "donation ware" thingy?

     

    I'm wasting my time with such annoying, stupid things. Who will pay us for this!?

  • jokejong Level 1 Level 1 (0 points)

    Ok people, I manage to do this fix.

     

    I am using the latest version of Itunes, 11.0.3, and Outlook 2010.

    Iphone 4s using iOS 6.1.3

    I have been using 2 POP accounts and 1 IMAP Account.

    Recently, I have migrated my IMAP account to Office 365.

    To avoid having to re-do all the customization, I decided to simply 'add' an exchange-office 365 profile into my current DEFAULT OUTLOOK PROFILE where all my POP and IMAP accounts are found.

     

    All is well, until I realized, my default Outlook data file is now switched to the Exchange 2013/2010 OST file side where Office 365 account resides. Now I don't have any calendar or Contacts in that OST file. Therefore when Itunes launched and perform a sync, all my contacts and calendar items were..zapped.

     

    I did some search and found this post, and I knew some of you encountered problems.

    Solution:

    1. Untick the sync in Itunes for Outlook. All my contacts and calendar on the phones will be deleted. Better that way since i don't want to end up with duplicates.Just proceed to REMOVE.
    2. Note that you need to manually record any new items you've just created on the phone ever since you realized that your contacts and calendars were missing on the phone.
    3. Do a sync and check the phone to see that all info are 'GONE'.
    4. Closed both outlook 2010 and itunes.
    5. Go to Control Panel > Mailbox (32-bit) > Click Show Profile
    6. I only had 1 profile, so choose the default profile (usually named OUTLOOK)
    7. Click Properties
    8. Click Data Files
    9. Make sure that the old PST file is ticked. Note that it should currently be the Exchange Office 365 OST file. When I choose my old PST file, it gave me a warning which i noted, and proceed.
    10. Note that emails for office 365 will still be delivered to the Office 365 OST file because in Accounts List, the default mail delivery folder (Properties > Accounts > Email Accounts > select the Office 365 acc > you'll see that the New messages will be delivered to the OST file.
    11. Proceed to apply, then close everything.
    12. IMPT: OPEN OUTLOOK FIRST, this will set the Outlook Data File configuration right with the PST file being the default instead of the Office 365 OST.
    13. After Outlook is opened, verify that Calendar and Contacts are there and well.
    14. Proceed to open Itunes right after that. It doesn't matter whether Outlook is opened or closed.
    15. Go to the Iphone - Info tab, then tick the sync with Outlook for both Calendar and Contacts...

     

    Now you can breathe and relax.

  • MarkRStephens Level 1 Level 1 (0 points)

    This advice was SO HELPFUL!!!  I had a very similar problem.  I added a new, second, Outlook account, then later deleted that account.  When you do this Outlook seems to arbitrarily change the default account data file.  So iTunes starts syncing to the new default Outlook data file.  Unfortunatey, this often appears like Sync is not working at all.  So you end up going down a blind alley trying to figure out why Sync is not working.  In this case, Sync was working, just with the wrong Outlook account/data file.

     

    After spending 3 hours with 3 different Apple support folks, I searched and found this advice and your solution worked perfectly!

     

     

    Thanks so much!

     

    Mark

     

    I had the same issue, and I found THE FIX!

     

    On your PC, go to Control Panel > Mail 32-Bit > Data Files: then set the pst file as the default!

     

    Don't bother creating a second profile...you can do the above fix and then your Personal folder will be synced with your phone. The iPhone can automatically sync the Exchange folders you want without using iTunes (On your phone: Settings > Mail, Contacts, Calendars > What you've named your Exchange e-mail account )

Previous 1 2 Next