7 Replies Latest reply: Oct 17, 2015 12:21 PM by NotoriousWebmaster
christinefromjurien bay Level 1 (0 points)

OSX Version 10.8.1....Since I have updated, I get "networksetup is trying to modify your system settings. Type your password to allow this" Sometimes there are ten of these boxes on top of each other, so I'm constantly typing in my password or clicking cancel..cancel...cancel... Sometimes it's very difficult to make it go away, and is extremely annoying. Any suggestions?

Thanks

Chris


iMac, Mac OS X (10.6.8)
  • sanjampet Level 5 (7,760 points)

    Your key chain probably needs some attention, reset it for the same password thru out. Go to utilities, keychain access, and you might be able to find the offender, also read the following.

     

    http://support.apple.com/kb/HT1274

     

    http://support.apple.com/kb/HT1631

     

    http://support.apple.com/kb/TS1544

     

    http://support.apple.com/kb/HT1631

     

    Hope there is some hlp for you here.

     

    ATB

  • Linc Davis Level 10 (192,330 points)

    Are you running an application called "Sidestep"?

  • Sigma2020 Level 1 (0 points)

    This was useful sanjampet, many thanks! While digging round in my keychain and 'uncovering' my passwords, I found that the pwd for my AppleID listed in "keychains - Passwords" is NOT my current AppleID pwd!!!

     

    I've changed this record (I guess it must be a record, not some sort of root file, otherwise I couldn't have accessed stuff protected by this pwd) to the right pwd; but I'd be interested if anyone online knows how this could have happened.

  • Thurstan Level 1 (0 points)

    Do you mind elaborating?  I think this may fix my issue as well.  Was it OS X 10.8 that you were using?

  • jimmy5f Level 1 (0 points)

    I went into the Keychain, and opened up the permissions so all applications could access everything. Two of the keys had no password, and would not allow a password ('identity-rsa-private-key', and 'identity-rsa-public-key'), and also 'Safari extensions list' had no password, and would not allow a password; meaning I could not make it show a password, or a password fill-in form would not come up. But, apparently this has not worked; I still get those annoying popups when my wifi jumps from LTE to 4G and back. This is on a Rogers wireless  internet account; there is no cable out here. What else could I do with Permissions?

  • SeamusMcShea Level 1 (0 points)

    I had the same problem when trying to plug an Android device into my MBP (Running 10.10.3, currently). All I wanted to do was run Android File Transfer to get some files off the device but, even though I tried Cmd+W Several Times and even Cmd+Shft+Opt+Esc, the "NetworkSetup" window *kept* popping up. Then I got an idea for how to stop it without modifying any settings, preferences, etc. and it works - Here's how to stop it:

    1. Open up a Terminal window (Macintosh HD [or otherwise] > Applications > Utilities > Terminal, Or just Cmd+Space, type terminal, hit Enter)
    2. When the Login process is complete, enter top and hit enter.
      • top is just a utility used to monitor system processes, their CPU consumption, etc. but in this situation, all you're looking for is the PID (Process ID Number) column because you're going to need to "kill" NetworkSetup.
    3. Once top is running, locate the command called NetworkSetup and it's respective PID.
      • In my case, I had another process running called "MotoHelper" which I had to kill first before I could kill Network Setup, but I digress.
    4. Now open up a new, separate window and enter the command: kill -9 [process id] but replace "process id" with the PID number (should be 4 digits) that you got from your top window next to NetworkSetup.
    5. Boom. Dead.

    Should work. If you have any questions, I'm happy to help if at all able

  • NotoriousWebmaster Level 1 (0 points)

    Hi Sheamus:

     

    Thanks for the idea to use top and kill. Sadly, my NetworkSetup keeps coming back, with a different PID each time. 

     

    I'm guessing there's some other process which keeps re-running it. Any idea how to find that?

     

    Thanks again,

    - AAA