2 Replies Latest reply: Oct 6, 2012 1:21 PM by BGreg
Glenn Haste Level 1 Level 1 (15 points)

For whatever reason, I can't use (mac) mail 3.6 on my mac G5 with Charter ISP.   I would like to try Thunderbird (TB) - I'm now using Firefox 3.6.28.  But I can't navigate through Mozilla to find older versions  of TB.  Can you suggest a URL for down loading older versions of TB, or, other alternative email programs?


Dual 2.5.GHz G5, Mac OS X (10.5.8)