3 Replies Latest reply: Oct 7, 2012 1:25 PM by bobjbkln
Dan Gribbin Level 1 Level 1 (0 points)

Can the Ipod touch 3rd Gen get IOS5 and above? I have been trying but itunes just says "Your softwear is up-to-date (4.2.1)" So I would like to get IOS5 or 6 but it wont let me. Can anyone help?


iPod touch, iOS 4.2