Previous 1 2 3 Next 36 Replies Latest reply: Jun 7, 2013 9:10 AM by Robby Berman
Bhags777 Level 1 (0 points)

i have a iphone 4s, ipad 2 and a MacPro using iPhoto.  Yesterday my devices stopped uploading NEW pictures to PhotoStream.  I've tested it by taking pictures with each device and waiting to see if it shows up in photostream.  Nothing works.  Is still have the old photostream pics, but new pictures are NOT uploading to photostream.

iPhone 4S, iOS 6
  • randers4 Level 9 (62,715 points)

    Photos are only uploaded when your are connected to wifi, the camera app is closed, and you have at least 20% battery life remaining.  If that's not the issue, you may need to try turning photo stream off, then back on.  Be aware that photo stream only keeps photos for 30 days.  After that they are deleted, although they will remain on any device that has already received them.  If you turn photo stream off and then back on, photos older than 30 days will not be streamed back to your device.  If you have photos old than that in your photo stream album you'll need to save these to your camera roll first if you want to keep them on your device.

  • Bhags777 Level 1 (0 points)

    I've done all of this... all devices have more than 20% battery. I've reset photo stream on icloud and turned it off on all devices.  I've then turned it back on after rebooting the devices.  Everything is on wifi.


    I've even taken a new picture on every device to see if they will each upload to photostream.  Nothing.


    I now have NO photo's in my photo stream and I took a bunch of pictures last night on my phone (before I reset everything) and I've taken these test shots today.


    I have a shared photo stream that I share with my wife... I tried uploading one of the test shots to it... no devices (mine or hers) can see the photo I added.


    please help.  Is there any issue with Photostream from apple today?


    FYI, i have iOS 6 on my 4S and iPad2.

  • Bhags777 Level 1 (0 points)



    If I manually add photos's to the PhotoStream via my MacPro in iPhoto... it updates PhotoStream to every device.  But taking new pictures on the iPhone 4S (Verizon) or iPad2, both connected to WiFi.... photo's do NOT upload to PhotoStream.


    Not sure if this helps but taking a picture on either of the the devices (4S or iPad2), the photo only shows up in that devices Camera Roll, it does NOT show up in PhotoStream on the device it was taken....



  • randers4 Level 9 (62,715 points)

    I'm away at the moment but will get back to you in about an hour.

  • An Average User Level 1 (0 points)

    Since a couple of days I have exactly the same issue.


    I had not tried to add photos from my MacBook Air, but after reading from Bhags777 I did try and it works, exactly as for Bhags777.


    I have iphone 5, New iPad and MacBook Air.


    Frustrated too...


    Thank you Randers4 for your help

  • randers4 Level 9 (62,715 points)

    Ok, back now.  At this point I suggest you try deleting the iCloud account from one of your devices and set it up again.  When you delete the account it only deletes it from the device, not from iCloud.  Your other devices will not be effected by this.  Deleting the account will also delete any data from the device that you may be syncing with iCloud such as contacts and calendars (but again, not from iCloud).  When you sign back into your account, this data will be synced back to your device.


    To do this, go to Settings>iCloud, scroll to the bottom and tap Delete Account.  Then set up the same account again with the same ID and turn your data syncing (contacts, etc.) back to On.  If prompted, choose Merge.  Then turn photo stream back on, take a photo and see if it appears on your other devices now.  If so, go through this same procedure with your other device.


    (I also just tested photo stream from my phone and it worked for me; and iCloud system status is not reporting any problems right now.)

  • Bhags777 Level 1 (0 points)

    Didn't work.


    I don't understand why when I take a picture on any deficit doesn't immediately show up in photostream on that device.  I think this is an iOS 6 problem. 

  • randers4 Level 9 (62,715 points)

    It doesn't show up immediately in the photo stream album on that device because the photo isn't being uploaded to photo stream.  The photos in the photo stream album are streamed back to your device from photo stream in iCloud;  if they were to appear in your photo stream album that indicates that they were successfully uploaded to photo stream and would also appear on any other device connected to your photo stream.


    Also, there are relatively few people reporting this issue after updating to iOS 6; if it were an iOS 6 problem there would be hundreds of people here with this problem. 


    Is your Mac connected to the internet using your wifi?  If it's using a wired connection, the next thing I would try is taking a photo on your phone while connected to a public wifi hotspot to see if this is related to your wireless network.  You'll know if it's successful if you see the photo appear in your photo stream album.

  • An Average User Level 1 (0 points)



    I tried too your suggestion and deleted, then re-signed in the account iCloud: same result as Bhags777.


    On iOS6: in my case, I updated last Tuesday and the issue did not start appearing till Thursday.


    On the wi-fi: your suggestion is worth trying for my case. I can say that the issue started when I came on Thursday to a different apartment, where I still am now. So, I cannot say that on a different wi-fi network (namely the one I was until Thursday) this would happen.


    I will have to try at a public wi-fi or wait till tomorrow when I will be back home.


    Thank you for your assistance.

  • randers4 Level 9 (62,715 points)

    You're welcome.  If it turns out to be your wifi some things to try include:


    1. Power-cycling your router (unplug for 15 seconds and plug back in) and go to Settings>General>Reset>Reset Network Settings, the rejoin your wifi and try photo stream again;
    2. Disable any firewall you may be using in your wireless router;
    3. Change the wireless router Primary & Secondar DNS settings to and (these are Google's public DNS servers and are generally more reliable than your ISP's.
  • An Average User Level 1 (0 points)

    UPDATE Randers4:


    I tried to "forget network" on the wi-fi where I am and activated the Personal Hotspot on my iPhone 5.


    Then I connected my iPad and my MacBook Air to my iPhone hotspot on the iPhone 5 instead of the "suspected" wi-fi network and bingo! On the iPad and on the MacBook the pictures I took with the iPad did appear (They are not appearing on the iPhone because I suspect they do not synch if not connected on a wi-fi, but the iPad and MacBook see it as a regular wi-fi so they do synch).


    So, I am optimistic that tomorrow, upon my retunr home, everything will be back to normal: the issue is probably the current wi-fi network at the house I am temporarely staying at.


    Thank you Randers4 and thank you Bhags77: I hope it will work out for you too.

  • randers4 Level 9 (62,715 points)

    You're welcome.

  • An Average User Level 1 (0 points)

    Extra piece of information:


    now I shut down the Personal Hotspot, bringing back the iPhone to the "suspected" wi-fi network and the photostream on the iPhone immediately showed the pics I took on the iPad (but not those I took on the iPhone, which are present in the Camera roll, but not on the Photostream). Those pics showed up on the Mac already earlier, thru the Personal Hotspot connection on the iPhone


    So it seems that this wi-fi network allows for very good download to the iOS6 devices but for some reasons does not allow the upload to the photostream of the new pics from the iOS6 devices.


    On the other hand, if the added pictures is on the Mac, then it is uploaded and immediately shows up on the iPad and iPhone.


    To make things even more complex, my girlfriend has iphone 4S and iPad 2 both on iOS6, and for her the photostream works perfect with this wi-fi network... really bizarre.


    I consider the issue closed: this network does not like me for some reason, I'll be back to my normal network tomorrow and things will be (hopefully) back to normal.


    Thank you again.

  • Bhags777 Level 1 (0 points)

    I tried connecting my ipad2 to my personal hotspot feature of my iPhone 4S... By passing the wifi router... Photostream worked.


    Now I need to figure out what happened with my wireless router/gateway from xfinity in the past 24 hrs.... Any ideas?  I tried rebooting and resetting.

Previous 1 2 3 Next