1 Reply Latest reply: Oct 7, 2012 1:02 PM by samafas
samafas Level 1 Level 1 (0 points)

Any photo taken by the native camera app in ios6 (after a restore from ios5.1 to ios6) no longer includes gpsinfo. The default camera never asked for permission, nor is it found in the location data list under privacy settings. Even resetting the privacy and location settings did not fix it.


iPhone 4S. iOS6.0. Clean install.


Anybody else with this same problem?

iPhone 4S, iOS 6
  • samafas Level 1 Level 1 (0 points)

    I just solved my problem!


    Since installing iOS6 I immediately installed and started to use a third-party camera app for most photos. Occasionally I would use the default camera app for photos - but only through the lock screen.


    So, it turns out that you need to open the default camera app through the icon at least once. This brings up the request to use location services, and also adds the Camera App to the Location Services list. Solved.


    For some reason, using the camera through the lock screen does not trigger this request for location services, and every photo taken is naturally taken without any gpsinfo included.


    A simple answer to what seemed like a complex problem. Glad to find the solution though. Hope this helps others.