1 Reply Latest reply: Oct 7, 2012 3:34 PM by planb77
memarcel Level 1 Level 1 (0 points)


I just downloaded ios6 onto my iphone 4s and now, my itunes 10.6.1 tells me it can't open my iphone because it needs a minimum of 10.6.3.

But when i want to update my itunes, it says "you're uptodate"...


Any clues??




iPhone 4S, iOS 6