Previous 1 7 8 9 10 11 Next 158 Replies Latest reply: Nov 20, 2014 6:39 PM by rickkko Go to original post
  • Ralph Johns (UK) Level 9 Level 9 (69,875 points)

    Hi ibrennan, albertboa and mk666,

     

    As Messages is built on the iChat engine I will suggest you report things here

    http://www.apple.com/feedback/ichat.html

     

    You will not get a direct response to anything you send them.

    You will notice that the OS Version and the iChat version drop down don't even cater for iChat 6 let alone Messages.

    However you can enter a fair amount in the free text area (I have never found a limit)

     

     

     

     

    3Sigcopy2.png
    8:33 pm      Tuesday; September 24, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • ibrennan Level 1 Level 1 (0 points)

    Ralph,

     

    I have been submitting this bug via that form at least once a week for the past 6 months.  I have also submitted it to the general OS X feedback page below many times as well.

     

    http://www.apple.com/feedback/macosx.html

  • Ralph Johns (UK) Level 9 Level 9 (69,875 points)

    Hi,

     

    Fair enough.

     

    I notice that this thread now has a "Related Articles" link that deals with "Using iChat with a  Firewall or NAT router".

     

    I see this article was updated last year (June 2012).

    However none of that info deals with contacting the iMessages Server.

     

    There is a separate FaceTime and iMessages article that was originally aimed at iOS devices only.

    The only real additions are the ones in the range 3478 through 3497 (UDP)

    Although port 80 and port 443 are not in the original set they are are open in most routers/modems as default ones.

     

    I don't think this has any relevance at all.

    Someone is bound to post that their Modem does not route and that their computer logs in directly to the ISP as their only device on the LAN side (Certainly no NAT and the Firewall allows set software).

     

     

    3Sigcopy2.png
    9:11 pm      Tuesday; September 24, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Berzerk Level 1 Level 1 (0 points)

    Who is willing to bet that this will NOT be fixed in Mavericks?

  • Burke102 Level 1 Level 1 (0 points)

    Who would take that bet? No way it'll be fixed. They can't put in order items that are date and time stamped, what makes anyone think a new OS will enable Apple to do the same sorting a second grader can do BY HAND???

  • Ralph Johns (UK) Level 9 Level 9 (69,875 points)

    Hi,

     

    Not all the iMessages are Date and Time Stamped in the way you think.

     

    Although displayed at the time they were sent, then can be sync versions.

     

    That is to say you may have been having a conversation on your iPhone and get home and turn the computer On and launch Messages.

    It then syncs the conversation you have been having.

    However they items are timed but they keep the original time not the new one as they arrive on the Mac.

     

    It seems that for some the Mac version of Messages seems unable to take any date or time info attached the the incoming syncs to create a correct and useful  representation of the chat.

     

    What remains unclear is why some people have this issues when others don't.

     

     

     

    3Sigcopy2.png
    8:41 pm      Wednesday; September 25, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • mdadk Level 1 Level 1 (0 points)

    This is still not fixed. My messages are always showing out of order and then I get messages popping up after I've already seen them before on the computer or phone when I wake my macbook pro out of sleep. Super annoying. Get with it Apple

  • quintus314 Level 1 Level 1 (0 points)

    This was fixed in the latest release of Mountain Lion, OS 10.8.4. Please see this article and be sure to keep up with software updates.

  • Ralph Johns (UK) Level 9 Level 9 (69,875 points)

    HI,

     

    The actual line reads from the Apple Document

     

    A fix for an issue that may cause iMessages to display out of order in Messages

     

    The implication is that it is one issue of possibly many or at least several issues that cause this.

     

    Also the App version number was not changed in the OS  X 10.8.4 update suggesting the change that apple made was to a support item and not to the App itself.

     

    Many people have updated to OS X 10.8.4 and later and are still having this issue.

     

    3Sigcopy2.png
    7:45 pm      Wednesday; October 9, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Daniel Harrington Level 1 Level 1 (50 points)

    Just to confirm Ralph's message: this issue was not resolved for me on 10.8.4, and remains unresolved on 10.8.5.  My currrent Message order for a chat that just chose to update itself:

     

    Today, 2:52 PM

    Today, 3:07 PM

    Yesterday, 11:17 AM

    Yesterday, 2:37 PM

    Yesterday, 3:05 PM

    Yesterday, 3:48 PM

    Yesterday, 5:56 PM

    Today, 1:50 PM

    Today 3:56 PM

     

    My MBP and Messages have been open and network-connected since ~1:30PM. Only just now (~4:00PM) did the full set of messages choose to sync, and they chose to sync in this un-sorted way.  Closing and re-opening Messages will sort them properly, but this is not a reasonable solution to the problem.

  • Ralph Johns (UK) Level 9 Level 9 (69,875 points)

    HI,

     

    What is clear is that Sync messages state the time sent but do not use this to order the iMessages as they arrive.

     

    It is also apparent that the iMessages servers do not send the sync items in a particular order or at least not a time and date one.

     

     

    3Sigcopy2.png
    10:25 pm      Saturday; October 12, 2013

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.4)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • stu0 Level 1 Level 1 (0 points)

    This might help somebody.

    I had an old redundant gmail address as my user ID as well as the me.com and icloud.com ones.

    I have signed out of everything ( de-authorised my MBA too) using the redundant ID and signed back in with the me.com address.

    That includes itunes and icloud, mail etc. I have also unchecked the old address in the imessage accounts tab so it is not active.

     

    So far, everything seems to be in sync with my phone which I have also done the above with.

  • Berzerk Level 1 Level 1 (0 points)

    Hi, I did some research again yesterday and thought that maybe it'll help to clean up the imessage accounts. I had various accounts connected to imessage on imac and iphone, like mail adress, mobile me, icloud, phone number...

     

    I deleted all unnecessary accounts, so on my phone, only the phone number and mail adress were left and on my mac only the mail adress.

     

    Than I read somewhere, that apple changed something aobut imessage on the mac, that it can receive messages to the phone number also, but I didn't find I way to add the phone number in imessage on the mac.

     

    So I completely signed off from imessage on the mac, and then signed on again with password etc.

     

    After that, magically, my phone number appeared in imessage on the mac.

     

    Now, I have one mail adress and one phone number on both imessages (mac and iphone) and since yesteday I had no scrambled conversations anymore.

     

    Since this is still no proof for a solution, I would like you to test this also. Check if your phone number is present in imessages for the mac. If not, follow the above steps.

     

    Thank you.

  • Berzerk Level 1 Level 1 (0 points)

    Just want to let you know that the bug is still fixed for me, since I added my phone number to imessages on the mac.

     

    You really should check if your phone number is listed under settings/accounts. If not, add it there like described in the message above.

  • ibrennan Level 1 Level 1 (0 points)

    Makes no difference, I have had my phone number on my Mac Messages for a long time.  I have also reassociated it many times while trying to troubleshoot this bug.