Previous 1 2 3 4 5 6 7 Next 103 Replies Latest reply: Jan 24, 2009 4:42 PM by anikolaev Go to original post
  • Dave Y. Level 1 Level 1 (0 points)
    OMG what horrible hardware, i can't believe this sh*t

    I tried everything (tooth picks, pointy things etc) and FINALLY got this to work after repeatedly plunging the largest/sturdiest 1/8th headphone jack i could find in and out of the hole.

    it finally took after 20 or so stabs in and out.

    i'm very annoyed with apple's poor system prefs that don't allow us to override this problem.... time for a "System update"


    LAME...

    MacBook Pro 15"   Mac OS X (10.4.8)  
  • Laca25 Level 1 Level 1 (0 points)
    The same problem here. The toothpick did the trick.
  • muiro Level 1 Level 1 (0 points)
    This just happened to me today. Is their a definitive "how to resolve yourself" answer to this or is it a definite need to take my MBP in for a service ?

    Headphone jack in and out approach not working.

    Had my MBP for 8 months now and this is first glitch albeit a very annoying one.

    Boo Hoo!
  • janedoessis Level 1 Level 1 (0 points)
    I've just experienced the problem today. I get the chimes when booting. I get NO red light in the jack and the thoothpick thing doesn't work. No sound either when booting to xp. Lots of sound when having phones plugged in. The chimes shows that the hardware works. Any suggestions?
  • jimbo2k Level 1 Level 1 (15 points)
    BREAKING NEWS....DIFFERENT (PERMANENT?) SOLUTION

    Well, possibly! Spent the last 3 hours setting up a new MBP and early on noticed this fault where the red light comes on and prevents use of your internal speakers, well documented above. I came to the conclusion that I would continue to set up anyway, and deal with the potential hardware fault another day with a trip to the Apple Store.

    Anyway, I decided after all the software updates that we come to expect with a new Mac, I would run my favourite little maintenence app "MacJanitor". During and after running the monthly, weekly and daily Unix maintenance scripts, the red light suddenly became intermittent. It now appears to have stopped coming on completely (for the last 10 minutes anyway...!) whereas before it would come on for 5 seconds or so, then go off for maybe 10-20 seconds, then back on again. Prior to running MacJanitor, the light was to the best of my knowledge solid red.

    Haven't restarted yet, will post again with update on that.

    Note When MBP started for first time, the OSX intro sequence DID have sound. It must have occurred within the first few minutes of operation.

    I don't have the expertise to break this down and find a potential link between Unix maintenance scripts and this fault, but perhaps somebody could? There is a chance of coincidence of course, but so far I'm confident that my timings are accurate and this has indeed had an effect.

    Regards all,
    Jimmy
  • jimbo2k Level 1 Level 1 (15 points)
    More Good News...

    I've restarted, played with the volume controls etc etc and (Yay!) the the Red Light of Death has not come on again.


    Forgot to mention....

    I also ran an Automator maintenance app called "Update Washer" before MacJanitor, advised for use after an OSX update. However, I first noticed the intermittent red light during MacJanitor. Could feasibly have been either. Try it!!
  • Orange_crisps Level 1 Level 1 (0 points)
    i had this problem arise on my newly purchased macbook, and after a quick read of this forum i had the problem fixed in minutes using the toothpick to push a button(noticed a distinct click, as if a button had been pressed) and my speakers became operarional and the red light turnt off.
  • tbirdparis Level 5 Level 5 (5,500 points)
    just to make it clear, the reason why some people are having the problem with OSX but not with windows is not to do with it being a software corruption or anything like that.. the digital optical cable sensor is still 'jammed', it's just that windows doesn't support the digital output anyway so it ignores what the sensor is telling it, whereas mac OSX does not.
  • dyranios Level 1 Level 1 (0 points)
    I just want to add my name to the list of people this problem effected, good going apple you really dropped the ball here the reason I don't mind being ripped off as a consumer is that I like to think I pay the premium for better hardware, shame this is not only not the case but such a feeble problem.
  • hearmusic Level 1 Level 1 (0 points)
    Just bought a new Mac Book Pro, and there is no sound. Everything looks fine in the preferences, but nothing works. Tried the toothpick, tried the headphone jack, both seem ridiculous on a new machine that cost a fortune. Sounds from these posts like I will have to waste time on calls and repairs. Very disappointing.
  • Alpesh Shukla Level 1 Level 1 (55 points)
    Seems like many people have this problem. I have the exact problem since yesterday. I hope there is a better method than sticking a toothpick inside! I will see what the mac geniuses say.
  • mjpassos Level 1 Level 1 (0 points)
    I have this problem and it seemed to have disappeared yesterday.
    It seems that the 1/8" jack ("iPod phone jack) has a switch, that switches when you plug/unplug the headphone (in my case a cable that connects to the stereo under my desk).
    I have a routine of plugging the cable (and the power one) as I come home in the evening and unplugging in the morning when I leave. I noticed that sometimes the LED was on, sometimes not. After reading this thread I plugged and unplugged the cable several times, and sometimes the jack switched back to "normal" (no LED) and most of the times it switched to "LED on", and the volume keys would not work, and the Mac would have no audio.
    If the jack is part of the logic board (what it, most probably, is), then it is a logic board replacement issue, and Apple should admit it.
  • reirracon Level 1 Level 1 (0 points)
    Hi,

    I have the exact same problem on my 17'' macbook pro.
    It is NOT a software/os related problem as the red light of death apears also in windows mode via bootcamp... i was playing counter-strike and then the sound disapeared... then came back ... i then realised the red light was intermitently going on and off.... the toothpick works for a while , but the problem WILL come back ..... it's been a month already ... i am trully ****** off.
  • christianyt Level 1 Level 1 (0 points)
    Wow! I took someone's advice and used a chopstick (in place of a toothpick) and was able to get that red light off. If you are looking into the headphone jack, poke around with a chopstick or whatever at about 12 o'clock (at least on my macbook it's 12), you'll actually see a little tab you can prod at. I usually don't post on these things, but I was so frustrated with not having sound that I thought if I can help one other person out, it'd be worth it!!! Take the toothpick and go to town.

    I was using my headphones with garageband and thought I had fried something with my shredding, turns out it was an easy fix. I highly advise trying this before taking it in for work!
  • RobTheMighty Level 1 Level 1 (0 points)
    exact same issue here, maybe 1 month old MBP 2.2ghz,

    cannot hear any audio out of parallels either

    super super frustrating on a brand new machine