Previous 1 3 4 5 6 7 Next 103 Replies Latest reply: Jan 24, 2009 4:42 PM by anikolaev Go to original post
  • herdiansah Level 1 (0 points)
    I've bought MBP 15" 2.16 C2D on last april and this problem come out on June for about a week and it's just silently fix. Now the problems is coming back again after installing iTunes 7.3.2 and new security update.

    and still plug in and out headphone jack a several time do the trick...

    I hope there will be a fix on next OS update
  • hunrya Level 1 (0 points)
    So, I'm really not sure if it's software or hardware. But either way apple needs a permanent fix. I did the toothpick thing twice, and that worked. But now I'm having a hard time
    getting it to "unstick" the 3rd time.
    It sticks 100% of the time every time I put a jack into it.

    I really don't know if
    it's a matter of it unsticking or if it's a matter of the machine responding to electrical signal which could be generated by activating the sensor several times with a tooth
    pic. People report hearing a click, which I also heard, but that doesn't mean it was stuck or unstuck. I made many clicking sounds with no success. Just because it clicks when there's success doesn't mean that's what's making it work.
  • ronmarkey Level 1 (0 points)
    I have had this problem off and on as well, but have never seen the red light. Is that because I don't use optical headphones? I have reset it a couple of times with a PRAM and SCM? reset...but it is getting tiring.
  • KevinOlson Level 1 (0 points)
    One more user without internal speakers.

    I do not have the red light shining and neither the 1/8" jack nor the toothpick are working.
  • addieco Level 1 (0 points)
    Well, I have the same problem, none of the suggested solutions is working.
    I think the ideal situation would be someone who can create a program which ignores the optical output and let's the internal speakers work.

    I've read reports about users who got the problem with bootcamp that and their headphones are working and their internal speakers, their problem could be our solution.
  • VBarney Level 1 (0 points)
    Hi, everybody

    I have the same problem with my Macbook: red light and no internal speakers. I wonder if anybody has an illustration of the inside of this combined jack-optical output connector. It might get stuck in due to some dirt, but where is that microswitch exactly? Someone talks about 5 oclock, others about 6 and 12 oclock... What is the truth? Is there anybody who has a particle number for this jack socket? I tried google, but in vain.

    On the other hand, I cannot really understand the logic of OS X. When there is a jack plugged in, the optical red light disappears. This means that the output notices a jack plugged in. But if we insert an optical cable, then it does not. Why is it so? Is it about the metal vs. plastic material of the plug, or is it the thickness? I do not have an optical cable. If someone knows, let us all know it! Thanks!

    I can also imagine that there are two sensors: one for the jack, which is present in all traditional jack sockets, and another for the optical cable... Any idea?

    And one more thing, about a software solution that someone mentioned: I have bootcamp installed with windows xp pro. I launched XP, opened control panel, and there you can disallow digital out. This switches off the red light, but still, the system behaves as if you had a jack plugged in. The volume controls begin working immediately, but XP still believes that a headphone is connected. This is what I cannot understand.

    I hope it was helpful for any of us and leads a step closer to a solution.

    Bye, and waiting forward to reading your replies!
  • WFTS2000 Level 1 (0 points)
    It seems there is a large population of macbook pro users out there that are experiencing the same problem. Why isnt apple living up to their name and fixing the problem? I dont want to poke around with a toothpick and possibly screw something eles up. how long will it take to fix this problem if I took it to a local apple store? can they fix it there or will they have to send it off? you would think by now, every apple store has this part "in stock". I'll keep checking. I did realize this problem right afer I updated my software.
  • bradpilot Level 1 (0 points)
    Wow. Big issue for such a small part. My 2 month old macbook lost sound in the middle of a video chat meeting tonight. Bummer. My virgin headphone jack should not be the issue at it had never been used. Found this post and plugged in a headset and my speakers worked. Great! The jack function is reversed. Headphones are sensed as speakers and no headphones in plug are listed as headphones. !!!?!?!

    My red sensor light is not flashing at any time but even if it were, jamming around in there for a switch will not make things better, at least not for a proper long term solution I sense. It is likely a hardware issue complicated by software design.

    One thing I saw is to reset the PSU:

    Also found another thread on same topic:

    Alas neither worked for me so I have to contact Mac support tomorrow. For tonight I finish my iChat meeting with headphones plugged in so the sound comes out of the speakers. I at least have a workaround and I do still love my Mac and the 3 other managers in my company have no problem with their identical MacBooks.

    Message was edited by: bradpilot
  • sspringall Level 1 (0 points)
    Ditto. I have the exact problem. Digital Out is present when the headphones are unplugged. The internal speaker option is missing. Plug in the headphones and it works. Pull out the headphones and the socket glows a steady red.

    I'm still running Tiger and hadn't installed anything new prior to it having a problem.
  • kdselly Level 1 (0 points)
    Frustrated, - computer only 2 months old, alas, the toothpick worked (actually one of those plastic swords, very technical the one cheese come on) anyhow, about 5 or 6 oclock, carefully, moved it around a bit, found the 'sweet spot' red led light came off and sound came oN! Thus avoiding the genius's, whom I'm sure would not have used such a hairbrained and QUICK fix. Guess I'll pack the 'dagger' when I travel.
  • petesam Level 1 (0 points)
    yep, me too. just to clarify, it's almost definitely a hardware issue - i.e. a fault with the sensor within the headphone output. the boot sound does play on the internal speakers: but this happens normally, regardless of whether anything is plugged into the output.

    for some it may be worth poking around to try and fix the faulty connection, but it risks scratching and damaging the optical output, and so if you do, definitely go with something softer like a cocktail stick as opposed to a paper-clip.

    for me personally, no luck, so away it goes most probably to get a whole new logic board...! it's a shame that this is such a common issue, with what should be a relatively simple component. anyway, never mind....
  • wkarraker Level 1 (0 points)
    My internal speakers problem was solved with a little guts and elbow grease. The only thing I had in my Control Panel>Sound>Output was 'Headphone" which were dead too. After trying the toothpick fix, plugging an audio plug repeatedly in and out, re-installation of the OS (even booted from an external FireWire device and a system disk, still no sound) my problem failed to fix itself. Since my 17" 1.0Ghz PowerBook G4 was way beyond it's warranty expiration I decided to crack the case and started nosing around inside.

    What I found was the primary ribbon cable that attaches the audio board to the motherboard had worked itself loose. Pressing it back down I felt a satisfying 'thunk' and so I reattached the upper half to test it. The startup sound came roaring through at full volume. After I shut it down and screwed it back together I tested it works perfectly with DVDs, CDs, movies, iTunes, you name it.

    I don't advise anyone with a new computer attempting this, take it to an Apple certified repair center and get your money's worth out of your warranty. It's a royal pain, but the only way Apple can see the severity of this problem is in how many units that have issues like these are reported.

    Message was edited by: wkarraker
  • Vagieray Level 1 (0 points)
    I had the exact same problem. Red light no audio. After reading this thread for a while I decided (out of frustration) to plug in my head phones over and over. Finally it just worked. Definitely must be caused by something sticking in the headphone jack. Hope this helps

    Message was edited by: Vagieray
  • gagasue Level 1 (0 points)
    This happened to me when trying to watch "PC and Mac," their "Give Up On Vista" video that appeared one day on the New York Times home page. I could view but did not have any sound. No internal speakers in Output pane of Sound system preferences. I booted to a firewire drive just to rule out any software issues, then called Apple. I called just to tell them I had a hardware issue. But the rep wanted me to go through all the troubleshooting steps. The rep I was talking to did not have a clue. By this time I was pretty frustrated so I got a case number and said I'd call them back when I had more time. That's when I noticed the red light inside when I looked through the audio line-in port, got a paper clip and poked. The light went out and all of a sudden the internal speakers worked. I heard that it was a faulty i/o board but the internal speakers are working now and I still have over 2 years left on AppleCare. I wrote it up on my blog, and at some point I would like to hear or read what Apple has to say about the problem. I mean, officially.
  • turboshot Level 1 (0 points)
    Unsatisfying as it is technologically, the plugging and unplugging of headphones in jack with system preferences open to sound actually worked for me. I have had this problem on and off (so to speak) ever since I got this MacBook Pro. I think it is just a glitch, but I didn't have to take it in or send it anywhere to fix it, even though it is probably temporary.
Previous 1 3 4 5 6 7 Next