Skip navigation
This discussion is archived

internal speaker output device missing

91653 Views 103 Replies Latest reply: Jan 24, 2009 4:42 PM by anikolaev RSS
  • portugepunk Calculating status...
    Currently Being Moderated
    Jan 21, 2008 6:31 PM (in response to Heather Loring)
    I had been having the same problem on my MacBook for weeks. Nobody could tell me how to figure this out -- after visiting this discussion, I decided to give the toothpick idea a try. I had my headphones plugged in and left them plugged in while I put my MacBook down to go get a toothpick. When I got back, I removed the headphones and spontaneously, my internal speakers worked again. I had tried plugging/unplugging them dozens of times, but maybe this time was just the magic trick -- or my MacBook really just didn't want a toothpick in one of its orifices. Good luck everybody else!
    MacBook 2GHz Intel Core Duo, Mac OS X (10.5.1), 2 GB RAM
  • Determinista Calculating status...
    Currently Being Moderated
    Jan 28, 2008 7:00 PM (in response to cfc)
    Same problem. Toothpick did the trick, at least for now. Thanks to all those that contributed to this thread.

    Apple, FIX THIS!
    MacBook Pro, Mac OS X (10.5.1)
  • taijidubh Calculating status...
    Currently Being Moderated
    Feb 4, 2008 7:15 AM (in response to Determinista)
    Me too. Same as everyone else. Problem started out of the blue about 2 weeks ago. Tried the headphone jack trick, but no success. Off to buy toothpicks.... It would be nice if Apple fixed this....especially while my warranty still stands...
    Macbook intel core duo, Mac OS X (10.4.11)
  • vollex Calculating status...
    Currently Being Moderated
    Feb 11, 2008 3:33 PM (in response to taijidubh)
    I am having the very same problem, Toothpick didn't work, plugging and unplugging the jack lead constantly or even plugging and unpluging in an optical lead instead.

    My Warranty Runs out in a week and they won't reply to my emails!!
    iMac G5, Mac OS X (10.4.11)
  • tingham@mac.com Calculating status...
    Currently Being Moderated
    Feb 18, 2008 6:19 PM (in response to vollex)
    Dear Apple Engineers,

    If you'd like I can send you my Macbook pro to debug this problem, as long as you promise to FIX IT.

    Thanks
    MacBook Pro 17", Mac OS X (10.4.8)
  • GrayFoxBh Calculating status...
    Currently Being Moderated
    Feb 23, 2008 6:41 AM (in response to tingham@mac.com)
    I've just bought the Macbook Black Edition and a week later it arrived I'm having this problem.
    Sincerelly, Apple've disapointting me. I had a white Macbook ( the cheapiest one) and it came with the Rj45 port broken. It took about TWO months to fix and i've sold it to buy this one ( one of the reasons is that it not came with a basic stuff today: a DVD burner) and now this.
    In my company we have 5 Macintosh divided by Macbooks Pro.. G4 Model and MacMini and they all.. yes.. I mean they ALL are having problems like Hard drives failing and dead pixels.
    Now this.
    I am really ****** of because here in Brazil ( you did notice the crap english but is not my main language) any Apple product is very expensive.
    Im really thinking in give up and buy a Pc.
    A just don't want to have a brand new product and have to stick a metal in it every time I want to listen to a music.
    MacBook Black Edition, Mac OS X (10.5.2)
  • motor206 Calculating status...
    Currently Being Moderated
    Mar 20, 2008 2:05 PM (in response to Robert Rutledge1)
    I just started having this problem on a six month old machine. Plugging and unplugging headphones several times did the trick...
    MacBook Pro 2.4 GHz 15", Mac OS X (10.5.2)
  • RichardIan Calculating status...
    Currently Being Moderated
    Apr 19, 2008 12:48 PM (in response to GrayFoxBh)
    I was having the exact same problem on a G5 iMac.

    The toothpick trick worked for me.
    iMac, Mac OS X (10.5)
  • crrush Calculating status...
    Currently Being Moderated
    Apr 21, 2008 11:27 AM (in response to cfc)
    Here's a new twist to this issue (and, yes, I've tried the toothpick and plugging/unplugging headphones into the jack). I have an iBook G4 (not a MBP), and my sound just stopped working about two weeks ago--not the internal speakers, and not headphones when I plug in.

    In Sound preferences, it shows "No output device found" and "No input device found" under Output/Input options (so I can't select internal speakers); this happens even if headphones are plugged in.

    I don't think this is a jack issue (the digital/optical whatsit seems to be related to MBP)...so...? Any suggestions?
    iBook G4, Mac OS X (10.5.2)
  • freemanfoserious Calculating status...
    Currently Being Moderated
    Apr 22, 2008 9:39 PM (in response to cfc)
    I've had the same problem for a few days and I just managed to fix it. My problem before this was that anything plugged into the output would work fine but when I tried using my internal speakers, the volume adjusting thing would be at max volume with the circle with a slash through it underneath. I had tried restarting my computer as well as unplugging/plugging in a set of headphones over and over. I didn't want to do any of that complicated-sounding PRAM stuff or talk to any of those "geniuses" at Apple. I don't know if everyone here has the same problem but you can give this a try I guess.

    A few people mentioned this problem after putting the computer to sleep and I figured maybe it was something to do with that. All I did was put my computer to sleep with a set of headphones plugged in. Then I unplugged the headphones while the computer was still asleep. Finally, I just woke the computer back up and the internal speakers worked again. I don't know.. maybe these things don't sense changes in audio devices while asleep?

    Well...don't know if this will help everyone but good luck I guess.
    MacBook, Mac OS X (10.5.2)
  • Katafrog Calculating status...
    Currently Being Moderated
    Jun 6, 2008 2:26 AM (in response to cfc)
    A SIMPLE SOLUTION

    As often with apple issues, a simple solution worked for me (no toothpick)

    I put away my Bose headphones and tried plugging in my Apple-branded iphone headphones. As I removed them from the headphone plug, my speakers came back to live.

    This is after I unsuccesfully tried most of the methods above, bar opening my MBP.
    I guess the shape of the headphone plug on the apple-headphones is slightly thicker than that of other headphones (My issued occured after using the new plug from Bose that includes an inline microphone).

    Hope it helps some of you out there
    MPB Pro 15", Mac OS X (10.5.3)
  • eKiTeL Calculating status...
    Currently Being Moderated
    Jun 11, 2008 5:27 AM (in response to cfc)
    I'm having the exact same problem (red light + no internal speakers), and all the jiggling and other fixes do nothing for me! I bought my MBP on June 6 last year so the warranty just barely ran out. This really stinks though at least I can still use headphones
    MacBook Pro 3,1, Mac OS X (10.5.3)
  • Kurt Jones1 Calculating status...
    Currently Being Moderated
    Jun 14, 2008 4:45 AM (in response to cfc)
    I'm having the same issue with my daughter's MacBook. I have tried all the suggestions, and no matter what, the red optical light comes back on. I will probably crack open the machine and take a look at the connection to the motherboard as a last resort. The machine has also had a reinstall of the OS by Apple, and their suggestion is to send the machine in for repair. We are out of warranty. In addition to this audio issue, the mouse pad is failing and intermittent.

    This Audio issue appears to be a fairly repeatable, and consistent error. I'm surprised and disappointed that Apple hasn't solved the underlying issue. This thread alone is over two years old. And I wouldn't be surprised if there were other similar threads.

    <Edited by Moderator>

    Kurt Jones
    multiple machines - G4/G5/Powerbook/iBooks/pods/etc., Mac OS X (10.5), Mac Book, Logic Xpress, Garageband, Audio Tools
  • eKiTeL Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 17, 2008 2:35 AM (in response to Kurt Jones1)
    Now I just noticed there was no red light coming out of the jack so turned on iTunes and voila! music out of the speakers again! I can't identify anything I did specifically that might have made it start working again besides plugging in the the headphones one time and putting it to sleep a couple times.
    MacBook Pro 3,1, Mac OS X (10.5.2)
  • Dan Diemer Calculating status...
    Currently Being Moderated
    Jul 19, 2008 7:34 AM (in response to cfc)
    Just had this problem crop up for the first time last night on my first gen MBP, and plugging and unplugging the head phones a few times seemed to do the trick.
    MacBook Pro 1.83 Core Duo, Mac OS X (10.5.4)
1 ... 3 4 5 6 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.