1 2 Previous Next 26 Replies Latest reply: Aug 6, 2013 3:20 PM by GoldNotSilver Go to original post
  • 15. Re: HELP MAC EXPERTS!
    EcoGreg Level 1 Level 1 (40 points)

    Forgot to mention that under Lion and ML, there are seperate volume controls for internal speakers and headphones. Your computer should automatically detect when you plug in headphones and in sound preferences you should be able to click on headphones and adjust volume slider.

    This is an improvement to OSX as you can now control each volume level.

  • 16. Re: HELP MAC EXPERTS!
    EcoGreg Level 1 Level 1 (40 points)

    Hdmi out is going to an external device, so yes you can configure through Audio/Midi Setup. In orginal posting, illbaz does not mention attempting to set up external device, only using headphones on Mac. Audio/Midi Setup is an seperate application to setup external devices and does not control sound for headphones directly plugged into the Mac. Should also mention that most external devices would need to have drivers installed before using Audio/Midi Setup.

  • 17. Re: HELP MAC EXPERTS!
    illbaz Level 1 Level 1 (0 points)

    My sound prefences are all selected correctly, headphones on output. Still i get no sound to my head phones, it DEFINITLY is NOT an issue with the set up of my Sound prefernces nor my Audio/Midi setup. This way i am so stuck on this issue. It is extremly bizarre and it seems to be that nobody knows a solution. Still crossing my fingers that one of you guys will be able to tell me something ive missed or have a clear solution for it.

     

    Thanks guys.

  • 18. Re: HELP MAC EXPERTS!
    EcoGreg Level 1 Level 1 (40 points)

    Illbaz,

    Relooking at your screen shot I noticed that BoomDevice with 2in/2out. I think this is your problem. This is an added app that does not play nice. You need to remove this app, and all extensions(kext) and associated files. If you use a good uninstaller program it should get rid of this app and all associated files. You might then need to remove some plist files for sound and audio/midi setup and then you should be good to go.

    Check out this discussion... https://discussions.apple.com/thread/2771686?start=0&tstart=0

    Let us know if this works as there are other possibilities.

    Luck Greg

  • 19. Re: HELP MAC EXPERTS!
    EcoGreg Level 1 Level 1 (40 points)

    Also just noticed in screen shot, that format is set to 2ch-32bit float. Try changing back to default 2ch-24bit integer

    If this doesn't cure the problem list out any other audio programs, if you have Windows installed, any midi or other external audio devices that are or have been hooked up. Also helpful to know when it first occurred, and did you install any new software, how did you update to 10.7.5. Software update or did you download combo update?

  • 20. Re: HELP MAC EXPERTS!
    illbaz Level 1 Level 1 (0 points)

    Hey EcoGregg,

     

    Thanks for the advice, had high hopes that removing boom would fix this issue after reading many forums about it messing with the audio. Unfortuantly i removed Boom and all files to do with it including .plist files. Tried a reboot and a couple different headphones. No luck, master is still greyed out in the audio/midi settings.

     

    Also tried changing it back to the original float settings. no luck. I don't believe it is was the new update as it was working fine with it. The problem occured when I was watching a movie on my MB & once the film ended I unplugged my headphones and shut the MB. Opened 30mins later to find that my headphones were not working.

     

    Any other ideas? Options seem to be very slim at this point

  • 21. Re: HELP MAC EXPERTS!
    EcoGreg Level 1 Level 1 (40 points)

    Illbaz,

    On a default system audio/midi setup is not used just for internal speakers, headphones.

    "No luck, master is still greyed out in the audio/midi settings."

    This is the default, master is greyed out, can't move it. This app gets activated when you use an external A/V device or 3rd party app! You can change the configurations.

    "The problem occured when I was watching a movie on my MB & once the film ended I unplugged my headphones and shut the MB."

    Always a good idea to make sure no sound is playing during inserting/removing audio plug. You can cause direct short on circuit. I have done A/V work professionally for a couple of decades. Had a salesperson blow up some active speakers while demonstrating different pairs. TRS plugs will short contacts as they insert. This may or may not be the problem. Need to isolate hardware (apple repair) from software issue.

    Here are some things to try before you cry... Backup your computer before restore/terminal work.

    Try cleaning the audio jack, old sound trick is to moisten the TRS plug and insert/remove a couple of times and then try playing sound.

    Have you tried using different user account?

    Tried safe boot? ....This will shut off extensions

    System restore? .....This rebuilds certain components

    Booting from a clean Lion OS from external drive? ....I always keep bootable drive with each system, USB flash drives very convenient now.  If this works then reinstalling OS or upgrading to ML, should be permanant fix.

    If booting from external drive doesn't produce sound, your chip is toast or possibly just the audio jack. I think the sound chip is integrated on MoBo for this computer, not sure if jack is replaceable, check iFixit for your exact model computer. If chip and jack on daughter board then $$ saved.

    If you can get sound from any of the above actions, then we can fix the issue.

    Relaunch core audio via terminal.

    Remove extensions, sound plists, etc...

    Let us know, best of luck

  • 22. Re: HELP MAC EXPERTS!
    illbaz Level 1 Level 1 (0 points)

    About to try out these steps. Hoping i havent blew any hardware. I plan to reinstall lion, only issue is that will i have to back all my data before doing so? Is there a way i can reinstall lion without doing a clean install?

     

    Thanks in advance.

  • 23. Re: HELP MAC EXPERTS!
    GoldNotSilver Level 1 Level 1 (0 points)

    I have the SAME PROBLEM on a Macbook Pro, upgraded to Mountain Lion. I used Skype with Snow Leopard and the built in mic.

     

    I have tried tweaking ALL the settings, but I have the 'grayed out' Master Level mentioned by Illbaz above.

     

    Need Skype for work. Suggestions?

  • 24. Re: HELP MAC EXPERTS!
    EcoGreg Level 1 Level 1 (40 points)

    Hi Gold,

    Are you trying to use external headphones but internal microphone to use Skype? Or external Mic? Both?

    Do you have any 3rd party audio software installed, i.e. soundflower…?

    Is the master Level you are talking about under Audio MIDI Setup?

    Have you tried selecting the input/output device you wish to use under the Audio MIDI Setup and then select the gear icon, then click on "Use this device for sound (imput/output)"?

    Does this help?

    Make sure you have not accidently muted the speakers. Clicking on the speaker icon in the menu should show volume. Holding down option key while clicking on speaker icon will show what is connedted in sound chain inclucing 3rd party software. If you press the volume keys you should hear a sound level go up or down in your speakers or headphones. Do you?

    Hope this helps, Greg

  • 25. Re: HELP MAC EXPERTS!
    EcoGreg Level 1 Level 1 (40 points)

    Gold,

    This is a pretty old thread, you may want to start a new discussion.

    Also the OP never said if issue was resolved or not, and if it was resolved, what steps resolved the problem.

    Finally, what version of MBP do you have and what version of OS are you running, 10.8.?

    Greg

  • 26. Re: HELP MAC EXPERTS!
    GoldNotSilver Level 1 Level 1 (0 points)

    Thanks for replying. I reset the SMC, and presto! All better. The whole system is running faster, too.

1 2 Previous Next