13 Replies Latest reply: Jan 3, 2013 12:34 PM by Jan Wessel
Jan Wessel Level 1 Level 1 (0 points)

Using Aperture 3.4.1

 

I have about 10.000 images (each is a 125MB TIFF file) in Aperture.

As the AP library became very large (about 1,3 TB), I decided to go from Managed to Referenced.

So I used the "Relocate Original for Project" from the File Menu.

This worked fine, but..., unforunately Aperture crashed a couple of times.

So now I have  about 200 images of which Aperture thinks they are Managed, although they have been moved to where I told Aperture to Relocate them as Referenced.

 

What I suspect that happened is:

- Aperture relocated the Original file to outside Aperture, then crashed before it had time to store the new File Status and the link to the Referenced file in thedatabase.

 

I have tried to Repair and Rebuild the database but to no avail.

 

If I try to Relocate Original -> Unavailable original files cannot be relocated.

I I try to Locate Referenced Files -> No Referenced Files

I cannot use Show in Finder, as Aperture thinks the image is Managed.

 

Anyone an idea how to solve this?

 

Would be greatly appriciated.

 

Jan


iMac, Mac OS X (10.7.5)
  • 1. Re: referenced files show up as managed
    Jan Wessel Level 1 Level 1 (0 points)

    Well, one way of solving this, although it will be a tedious job:

    1. move (not Copy) the image from the referenced location to, for instance, the Desktop

    2. using the Lift Metadata & Adjustments Tool (the preview still is in the Aperture database), lift adjustments

    3. delete the image from Aperture

    4. import the image from the Desktop into the project

    5. stamp the image again.

     

    This works.

    And for 10 images I can do it by hand.

    But Aperture has crashed some more time now, so I have some of these images.

    Maybe I can use Automator to do this. Hmmm, now I have to learn how to use Automator.. :-)

     

    Jan

  • 2. Re: referenced files show up as managed
    léonie Level 9 Level 9 (51,665 points)

    Jan,

    I really think, before you invest more time into fixing the library, you need to find the reason for the crashes and get to run reliably.

     

    What is the error message that you get when Aperture is crashing? Is it always the same message? Do you have a crashlog? Then you could post the first 60 lines, so we can get an idea what might be going on.

     

    What kind of images do you have in your library? Raw, jpeg? And where is your library? On an external volume? Directly connected or network volume?

     

    Regards

    Léonie

  • 3. Re: referenced files show up as managed
    Jan Wessel Level 1 Level 1 (0 points)

    Léonie,

     

    I do not get any error message.

    Aperture just dissappears from the screen.

     

    I have different Libary's.

    1 filled with TIFF files that came from Nikon scanner (approx 10.000 images)

    1 filled with a mix of RAW (from different camera's) and JPG's. (approx 20.000 images)

    1 filled with JPG's (approx 3.000 images)

     

    I had the crash with all Library's.

     

    I am trying to go from managed to referenced.

    The TIFF files are stored on external disk, connected through USB.

    The other 2 library's store their referenced files on the local hard disk

    All Library's are alson on the local hard disk.

     

    But this morning I noticed that while the "Relocate Original for Project" was running, also Time Machine was running it's back-up job. Maybe that that has something to do with it.

     

    From the logfile the entry's around the crash, and the first lines of the crashlog itself:

     

    10/13/12 10:29:08.625 AM com.apple.security.pboxd: kCGErrorIllegalArgument: CGSGetWindowTags: Invalid window 0x1e0

    10/13/12 10:29:08.625 AM com.apple.security.pboxd: kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged.

    10/13/12 10:29:08.625 AM com.apple.security.pboxd: kCGErrorIllegalArgument: CGSSetHideOnDeact: error getting window tags

    10/13/12 10:29:09.037 AM com.apple.security.pboxd: kCGErrorIllegalArgument: CGSCopyWindowColorSpace: Invalid window 0x1e0

    10/13/12 10:29:33.785 AM Aperture: kCGErrorIllegalArgument: CGSRemoveWindowFromWindowMovementGroup: Invalid window

    10/13/12 10:29:58.905 AM com.apple.launchd.peruser.502: ([0x0-0x65065].com.apple.Aperture[1011]) Job appears to have crashed: Segmentation fault: 11

    10/13/12 10:30:00.708 AM ReportCrash: Saved crash report for Aperture[1011] version 3.4.1 (3.4.1) to /Users/imacjan/Library/Logs/DiagnosticReports/Aperture_2012-10-13-103000_iMac-B eheerders-iMac.crash

    10/13/12 10:30:24.097 AM com.apple.backupd: Copied 1798 files (5.4 MB) from volume Macintosh HD.

    10/13/12 10:30:27.080 AM com.apple.backupd: 3.88 GB required (including padding), 310.11 GB available

    10/13/12 10:30:28.768 AM mdworker: (Error) ImportPluginLoading: Couldn't load plugin 'file://localhost/Library/Spotlight/VMware%20Virtual%20Machine.mdimporter/'

     

     

    Process:         Aperture [1011]

    Path:            /Applications/Aperture.app/Contents/MacOS/Aperture

    Identifier:      com.apple.Aperture

    Version:         3.4.1 (3.4.1)

    Build Info:      Aperture-301039000000000~2

    App Item ID:     408981426

    App External ID: 11130653

    Code Type:       X86-64 (Native)

    Parent Process:  launchd [168]

     

     

    Date/Time:       2012-10-13 10:29:53.834 +0200

    OS Version:      Mac OS X 10.7.5 (11G63)

    Report Version:  9

     

     

    Interval Since Last Report:          203614 sec

    Crashes Since Last Report:           2

    Per-App Interval Since Last Report:  104689 sec

    Per-App Crashes Since Last Report:   1

    Anonymous UUID:                      B540CD5B-922C-41AB-B033-2BE4DAECBD38

     

     

    Crashed Thread:  13  Dispatch queue: com.apple.security.pboxd.xpcq

     

     

    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000018

     

     

    VM Regions Near 0x18:

    -->

        __TEXT                 000000010ec66000-000000010f3b8000 [ 7496K] r-x/rwx SM=COW  /Applications/Aperture.app/Contents/MacOS/Aperture

     

     

    Application Specific Information:

    objc_msgSend() selector name: retain

    objc[1011]: garbage collection is OFF

     

     

    Thread 0:: Dispatch queue: com.apple.main-thread

    0   libsystem_kernel.dylib                  0x00007fff8751367a mach_msg_trap + 10

    1   libsystem_kernel.dylib                  0x00007fff87512d71 mach_msg + 73

    2   com.apple.CoreFoundation                0x00007fff8fc2350c __CFRunLoopServiceMachPort + 188

    3   com.apple.CoreFoundation                0x00007fff8fc2bc74 __CFRunLoopRun + 1204

    4   com.apple.CoreFoundation                0x00007fff8fc2b486 CFRunLoopRunSpecific + 230

    5   com.apple.Foundation                    0x00007fff8afcef7b -[NSRunLoop(NSRunLoop) runMode:beforeDate:] + 267

    6   com.apple.Foundation                    0x00007fff8b052b56 -[NSRunLoop(NSRunLoop) runUntilDate:] + 66

    7   com.apple.Aperture                      0x000000010ede782b 0x10ec66000 + 1579051

    8   com.apple.RemoteViewServices            0x00007fff8ed1823c __111-[NSRemoteSavePanel beginSheetForDirectory:file:types:modalForWindow:modalDelegate:didEndSelector:c ontextInfo:]_block_invoke_0 + 38

    9   com.apple.RemoteViewServices            0x00007fff8ed1386a -[NSRemoteSavePanel sheetDidEnd:returnCode:contextInfo:] + 223

    10  com.apple.AppKit                        0x00007fff91d6f047 -[NSApplication endSheet:returnCode:] + 275

    11  com.apple.Aperture                      0x000000010f0db320 0x10ec66000 + 4674336

    12  com.apple.RemoteViewServices            0x00007fff8ed169d5 -[NSRemoteSavePanel _handlePanelComplete:] + 386

    13  com.apple.RemoteViewServices            0x00007fff8ed111c3 __45-[NSRemoteServiceConnection _setupConnection]_block_invoke_0141 + 69

    14  com.apple.CoreFoundation                0x00007fff8fc4bdfc __CFRUNLOOP_IS_CALLING_OUT_TO_A_BLOCK__ + 12

    15  com.apple.CoreFoundation                0x00007fff8fc03f02 __CFRunLoopDoBlocks + 322

    16  com.apple.CoreFoundation                0x00007fff8fc2bfa7 __CFRunLoopRun + 2023

    17  com.apple.CoreFoundation                0x00007fff8fc2b486 CFRunLoopRunSpecific + 230

    18  com.apple.HIToolbox                     0x00007fff87f6c2bf RunCurrentEventLoopInMode + 277

    19  com.apple.HIToolbox                     0x00007fff87f7356d ReceiveNextEventCommon + 355

    20  com.apple.HIToolbox                     0x00007fff87f733fa BlockUntilNextEventMatchingListInMode + 62

    21  com.apple.AppKit                        0x00007fff91abb779 _DPSNextEvent + 659

    22  com.apple.AppKit                        0x00007fff91abb07d -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135

    23  com.apple.Aperture                      0x000000010f0da00d 0x10ec66000 + 4669453

    24  com.apple.AppKit                        0x00007fff91ab79b9 -[NSApplication run] + 470

    25  com.apple.prokit                        0x0000000110176be1 NSProApplicationMain + 387

    26  com.apple.Aperture                      0x000000010ec759c2 0x10ec66000 + 63938

    27  com.apple.Aperture                      0x000000010ec75314 0x10ec66000 + 62228

     

     

    Thread 1:: Dispatch queue: com.apple.libdispatch-manager

    0   libsystem_kernel.dylib                  0x00007fff875157e6 kevent + 10

    1   libdispatch.dylib                       0x00007fff903ef786 _dispatch_mgr_invoke + 923

    2   libdispatch.dylib                       0x00007fff903ee316 _dispatch_mgr_thread + 54

     

     

     

    I hope this is readable.

    Regards,

     

    Jan

     



  • 4. Re: referenced files show up as managed
    Jan Wessel Level 1 Level 1 (0 points)

    Ah, I notice thread 13 crashed:

     

    Thread 13 Crashed:: Dispatch queue: com.apple.security.pboxd.xpcq

    0   libobjc.A.dylib                         0x00007fff8aea4350 objc_msgSend_vtable13 + 16

    1   com.apple.RemoteViewServices            0x00007fff8ed10dee __45-[NSRemoteServiceConnection _setupConnection]_block_invoke_0 + 61

    2   libxpc.dylib                            0x00007fff8acd7573 do_mach_notify_port_destroyed + 217

    3   libxpc.dylib                            0x00007fff8acd02f9 _Xmach_notify_port_destroyed + 142

    4   libxpc.dylib                            0x00007fff8acd01b8 notify_server + 144

    5   libxpc.dylib                            0x00007fff8acd693b _xpc_connection_recv_message + 1084

    6   libxpc.dylib                            0x00007fff8acd7283 _xpc_connection_wakeup_recv + 179

    7   libxpc.dylib                            0x00007fff8acd7153 _xpc_connection_wakeup2 + 1580

    8   libxpc.dylib                            0x00007fff8acd7367 _xpc_connection_wakeup + 116

    9   libdispatch.dylib                       0x00007fff903f2497 _dispatch_source_invoke + 649

    10  libdispatch.dylib                       0x00007fff903ef13f _dispatch_queue_invoke + 71

    11  libdispatch.dylib                       0x00007fff903ef29c _dispatch_queue_drain + 210

    12  libdispatch.dylib                       0x00007fff903ef12e _dispatch_queue_invoke + 54

    13  libdispatch.dylib                       0x00007fff903ef29c _dispatch_queue_drain + 210

    14  libdispatch.dylib                       0x00007fff903ef12e _dispatch_queue_invoke + 54

    15  libdispatch.dylib                       0x00007fff903ee928 _dispatch_worker_thread2 + 198

    16  libsystem_c.dylib                       0x00007fff8fa7b3da _pthread_wqthread + 316

    17  libsystem_c.dylib                       0x00007fff8fa7cb85 start_wqthread + 13

     

    Hope this helps?

  • 5. Re: referenced files show up as managed
    léonie Level 9 Level 9 (51,665 points)

    Jan,

    as far as I can see you have a crash because of an incompatible or missing virtual machine plug-in. Are you using a virtual machine - Parallels, VMware? Then you might check, if an upgrade is available. This looks like a conflict with the new sandboxing in MacOS X 10.7.5 and Mountain Lion. Your current version might be incompatible.

     

    I have not used a virtual machine for a long time, so I cannot help with that problem. Hopefully other frequent posters drop in, or you could search the Lion forum for similar posts.

     

    Once your system is stable again, post back to tackle your library.

     

    Regards

    Léonie

  • 6. Re: referenced files show up as managed
    Jan Wessel Level 1 Level 1 (0 points)

    Léonie,

     

    I do have VMWare Fusion 4.1.3. There seems to be a new version 5.

    But I rarely use it.

    And it certainly was not running while I was working with Aperture.

    I have seen that entry in the log, and I checked the file it was complaining about about 14 days ago.

    It's a zero-byte file, which explains why it cannot be loaded.

    I keeps popping up in the log, I Google'd it, but could not find any harm coming from it.

     

    I am running 10.7.5 indeed.

     

    I am hesitant to blame the mdworker error for crashing Aperture.

     

    I will try to find some earlier logs and see if around the crashing time mdworker was also reporting that error.

     

    Thanks so far,

     

    Jan

  • 7. Re: referenced files show up as managed
    stuartfromtwickenham Level 1 Level 1 (0 points)

    I have the same problem. Unfortunately I did not keep the crash information. I will next time. Is it stored anywhere?

     

    As the files in error exist in the relocated location, and are not in the managed files location, do you think it would be safe to just copy them back?

  • 8. Re: referenced files show up as managed
    Jan Wessel Level 1 Level 1 (0 points)

    Hi,

     

    The crashlogs are stored (in my case anyway).

    You can access them by opening up the Console in the Utilities folder.

    There they show up in the "User Diagnostic Reports".

     

     

    What I did:

    Move the files in error to another place (i.e. Desktop)

    Then Import them again into Aperture.

    This way the files are back in the relocated location as you intended in the first place.

    The Aperture database is in synch again with where the images are.

    If you have heavily implied changes to the images, you would loose those.

    But if you go 1 by 1, you can use the Stamp tool to each time apply the changes to each image again.

  • 9. Re: referenced files show up as managed
    Jan Wessel Level 1 Level 1 (0 points)

    After moving them to the Desktop, delete them from Aperture and then import them again.

     

    By the way, since than I turn of Time Machine back-ups during importing and the crahs has not occurred again.

    Maybe, this will work for you too as a work-around.

  • 10. Re: referenced files show up as managed
    stuartfromtwickenham Level 1 Level 1 (0 points)

    Jan, Thanks for the help.

     

    I'll try turning TM off when I relocate the rest of the files. Thanks for the tip.

  • 11. Re: referenced files show up as managed
    prepare4landing Level 1 Level 1 (0 points)

    Jan Jan Jan!!!!

     

    Thank you so much for posting this.  I was having the EXACT same issues while attempting to relocate my files to a hard disk.  Apeture would crash and the last 4-5 photo's it was working on relocating would come up as the file was "offline" but was unable to reconnect.  Exact same issues you were having and I searched and searched and couldn't find a solution.  Then I finally came across this thread and I turned off "Time Machine" and now everything works as it should with no crashes from Aperture.  For some reason there is a bug in Aperture that causes it to crash when time machine does it's automatic back ups and causes the files that it was working on relocating at the time to be corrupted.  I'm also running 10.7.5 and Aperture 3.4.3.  Is there a good way to report this to apple so they can work on a solution??  Thanks again for your post!

     

    LJR

  • 12. Re: referenced files show up as managed
    Jan Wessel Level 1 Level 1 (0 points)

    LJR,

     

    I am glad it works for you too.

    It saves a lot of headache....

     

    As I was not sure if it was coincedence, a bug in Aperture, a bug in TM, or a bug somewhere deep down in the file handling itself, I wouldn't know under which to post a bug.

    I did send most of the crash reports to Apple.

     

    Actually I was hoping the guys from Apple were kind off reading these forum's.

     

    In the mean time I am running 10.8.2 but still try to turn of TM when importing lots of images, just to make sure.

     

    Jan

  • 13. Re: referenced files show up as managed
    Jan Wessel Level 1 Level 1 (0 points)

    Hello Leonie,

     

    Just to let you know, the VM error disappeared after I did a Safe Boot.

     

    Unfortunately it seems that was a one tme solution, because when I try to do another Safe Boot the system seems to hang. But that is another issue all together.

     

    Jan