Previous 1 2 Next 17 Replies Latest reply: Oct 29, 2012 12:58 PM by lisainia
perspectiveffect Level 1 Level 1

Mail is in the Applications folder, not in any subfolder; it's never been anywhere else. There is only Mail application on my computer, and it still won't open! Help!

I have downloaded the MacOSXUpdCombo10.6.8.dmg and SecUpd2012-004.dmg updates and restarted my computer.  I've done this process 3 times.  Before the first time, I deleted the non-working Mail from my computer.  After each set of updates, I checked the mail application and it still did not work. 


All I did was update when it prompted, just like normal, just like every update - and now my Mail application seems lost forever.  Why would this happen on a non-related update?!


I have searched a few threads, and many say the same thing about the 2 updates above.  Does anyone else have any other solutions?  Can I re-download the Mail application from somewhere without having to pay for it?

MacBook Pro, iOS 6, Mac OS X 10.6.8
  • CMCSK Level 6 Level 6

    perspectiveffect wrote:


      Can I re-download the Mail application from somewhere without having to pay for it?


    Yes, you can custom install Mail directly from the Snow Leopard disc by following the on screen directions.













  • WZZZ Level 6 Level 6
    Mac OS X

    Trash all Mail.apps (but don't empty the Trash just yet; wait until Mail is working again.) Reinstall Mail from the install DVD, found in Optional Installs. That will give you Mail 4.2. Run the Combo update, which will give you Mail 4.5 and then run the Security update again. Run the updates booted in Safe Boot (Shift key down at startup. Give it much longer to boot than a "normal" boot.) Then restart normally.

  • perspectiveffect Level 1 Level 1

    I chose to purchase and download Snow Leopard, not get the disc.  How can I redownload Mail without a Snow Leopard disc?

  • perspectiveffect Level 1 Level 1

    I trashed the (without emptying it), but I do not have a Snow Leopard DVD because I purchased it online and downloaded it instead of opting for the mailed DVD.


    I have not tried running the updates in Safe Boot, so I will try that to see if mail decides to work then. 



  • WZZZ Level 6 Level 6
    Mac OS X

    This is complete news to me. I'd like to know more. AFAIK, Snow Leopard has never been available as a download, even from the App Store. You purchased it as a DL? Where was that from? You may have been able to get a pirated copy off a torrent, but I wouldn't trust that not to include malware.


    You can get the real thing by calling Apple. It's $20 in the US.


    Message was edited by: WZZZ

  • perspectiveffect Level 1 Level 1

    I appreciate your information - I had a temporary brain ****! (f a r t is a word worth censoring?!) - it's Mountain Lion that my husband just downloaded to his laptop from the App Store.  I DO have the receipt here for Snow Leopard - and for the record, I don't download torrents, or have any pirated software or operating systems...  So we must have the disc somewhere.


    I guess I'll have to be without Mail until I find it. 


    Message was edited by: perspectiveffect

  • WZZZ Level 6 Level 6
    Mac OS X

    One other idea, which might explain what happened. Are you sure Mail wasn't originally in your Home Folder Applications folder? Not everyone has one of those, but you might. The update would have missed it there.


    If you have an Applications folder in your Home Folder, can you take it out of the Trash and move it to Applications in the "root folder," the Macintosh HD folder, then run the Security update again.


    Yes, the language censoring software here is extremely puritanical.

  • perspectiveffect Level 1 Level 1

    Well, I've never moved Mail anywhere - it's always been in the same spot.  According to my computer, it's under "ppn/ > Applications > Mail".  (in a Finder window, I click the hard drive [oddly named ppn/] on the upper left under "Devices", I click Applications, I scroll down and see Mail there.)


    The only time it stopped working was after the latest software update.  So, I'm completely thrown through a loop here, but apparently I'm not the only one experiencing this issue.  I just seem to be the only one who can't get it to solve based on the proposed steps. I will try Safe Boot, though.  And THEN I will try to find the DVD and reinstall the Mail application, then re-apply the updates.

  • andruxgi Level 1 Level 1

    I am running 10.6.8. I also had the problem described in TS4424. I had moved so it sounded perfect. I had both mail 4.5 and 4.6 on my disk in different places.


    I tried the steps described several times. (Put mail 4.6 in applictions folder, then reinstall the two updates.) Mail still would not work.


    Then I tried putting mail 4.5 into the applications folder, and running the two reinstalls. This worked. Go figger.

  • kevinkendall Level 1 Level 1

    It worked because prior to running the Security Update in question (and apparently at ALL TIMES this should be so, in the eyes of some of the Apple software engineers/authors, namely those who authored this particular Update), Mail v4.5 is *supposed* to be in the Applications folder. AND NO WHERE ELSE. That's what aliases are for yaknow (yeah. now I know, for real. lol) - getting your Mail, or at least Mail lookalike icons that point to your *real*, wherever you want it to be accessible via icon clicking anywhere in your folder structures.

    So for whomever around the globe didn't have the actual v4.5 in the root of the Applications folder, & when those people around the globe then ran the Security Update, all of their Apple Mails didn't work after running the Update.  That's a looooooot of people, probably.


    For what it's worth, here is a link to a post I made recently to a woman having this problem. The fixit steps I laid out covered ALL the bases, and between my rather long series of steps & one other helpful poster, she got her Mail working again. And, she said, learned some things, too. Here it is if you'd like to understand what exactly needed to be done, and why, to fix that DOA Mail snafu:


    Happy Mac'in



  • SpaceOwl Level 1 Level 1

    Same problems here folks, though I NEVER had moved the MAIL APP from the designated Application Folder. All I did (like the other users hit by this nasty problem) is to run the recommended *Security Update 2012_004*. Before that EVERYTHING was just perfect on my MacOS 10.6.8 (on a MacBook Pro).


    Am getting kind of pi**ed of, because all the tricks, tips & workarounds I found here didn't help me to solve the glitch yet, just wasted a heck of a lot of time. What in the world did Apple do here to us with a regular Security Update????


    I hate the idea of having to return all the way to a clean install of the MacOS 10.x and then working my way up through all the sequential Updates since then and HOPING that this will do the job.


    Doesn't anyone have some more good ideas that might be useful?
    The Apple's Phone Support seems to be left out the woods, too, from what I experienced ... 



    Please respond again to this issue, even if the idea might sound a bit bizarre ... the PROBLEM is just as weird!!


    Best regards


    Bildschirmfoto 2012-10-18 um 03.25.04.png

    This is the GERMAN version of the same ERROR-prompt.

  • brianmiranda Level 1 Level 1

    I am having exactly the same problem.  For some reason our mail app was on the desktop - don't ask me why.  So, when I ran the software update (and presumably security update) today, the mail app won't work. 

    I have done all the steps suggested on this thread.

    However, still not working.

    What I don't understand is that I have re-installed mail from the snow leopard install disk and so now have version 4.2.  However, when I then run the Combo update, it doesn't seem to change it to 4.5 but still says it is a 4.2 version.  I have rebooted and re-run security update and it still won't open and still says it is 4.2 version.  Originally, the dialogue box was saying it was a 4.5 version that could not be opened.

    I have done the combo/ security steps at least 4 times now and am just getting more and more frustrated. 

    I cannot find any other versions of mail sitting anywhere in the computer.



  • lisainia Level 1 Level 1

    Same thing happened to me-got same message box. I am totally not computer savy! I tried lots of fixes that I read on here but nothing helped me except one (link below).I had problem about 6 months ago after update and restored mail in my time machine. So I had more than one "mail" listed in my application folder. I wasnt sure which one I could delete or if I could back then so I just left it-so there were several MAILs with different names. Apparently that's where the problem began with the new security update. I read on link below that you need to get rid of all other mails except the original so it be the original MAIL and should just say "MAIL" not "MAIL(original)" like mine did. I went into my Time Machine all the way back to when I first got computer -searched under applications for mail- found it (the one with little stamp symbol icon) highlighted it and hit restore. Threw all the other "present" versions in trash.(Not sure if they were left on desktop if it would work??-just had to be careful not to empty trash just in case this didnt  work because I was really not sure if it was gonna work and I would lose previous MAIL applications and all my past emails) I threw all the weird little new pencil icon application versions of MAIL  away too(the ones I couldn't open). Searched in my present application so only one original MAIL that I pulled from TM was on there. Before that-in all my troubleshooting- I had downloaded the latest security update and the latest Java for mac update (my OS is snow leopard so it was the first one and security update was on the next page-but make sure you get regular one not server one-it's confusing -there are two for snow leopard) I dont think it matters that you have to keep downloading the upodates because I did several times. I think it just matters when you run it each time you switch things around and remember to restart your computer. And not ouch anything before you restart. So I threw out all the old MAILS except for one I pulled of TM. Then I reran the security update that I downlaoded and restarted the computer. It was the first time that-when I restarted-my mail icon didnt turn into a litle pencil and paper icon. It remained a stamp. So I clicked on it (the one in applications folder-I deleted the one on the bbar at the bottom previuosly) and IT WORKED. Others have said their MAIL application was not in the applications folder and missing somewhere else on their computer -that's all they needed to do to fix it-move it to the applications folder. Mine was more complicated. Hope you get it working. I've spent the last 4 hrs working on a fix for mine. Ugh. Good luck!



  • SpaceOwl Level 1 Level 1

    Hi brianmiranda,


    here's an UPDATE on my efforts to get MAIL working again that might help you, too.


    I finally (after going thru the described process above several times) was successful in getting things back in shape. However it DID NOT work the first 2 times with me either.


    What might have done the trick is that I not only followed the reinstall/update/delete steps, I additionally did a FULL PERMISSIONS REPAIR on the HD first and checked, if there might be any "broken preferences" left in the folder that relates to MAIL of ANY version (4.2/4.5/4.6).


    Then I ran the whole restore process given above a third time. NOW it worked as proposed and even the Security Patch didn't kill the whole work again.


    So let's hope this might be helpful to others that still face the same glitches.


    Good luck!

Previous 1 2 Next