9 Replies Latest reply: Oct 26, 2013 6:31 PM by Usermuser
voodoostrat Level 1 Level 1 (0 points)

Ever since the iOS6 upgrade I have been unable to get my "main" Home Shared iTunes library to load on my mobile devices, iPhone, iPod, and iPad. They all get to the halfway point and then just hang. My main library is on my MBP, it is close to 600 GB and is located on a external drive. I am able to share between my two iMacs and my MBP with no problems, Also the mobile devices are able to connect to the iMac running Lion (which has a scant amount of content). One of my iMacs and my MBP are running Snow Leopard, and the other iMac is on Lion. My apple TV is working fine, no issues.

  • tim2002 Level 1 Level 1 (25 points)

    I have the exact same issue here. Home sharing not working on my ip4 (ios 6) but works perfect on my two AppleTVs.

    But: On my ipad 3 it works fine too, also running ios6.

    ...On my ip4 i see the loading circle goes to half way and than it hangs forever, its not going through to load my library.

    Really annoying.

    Apple screwed up with iOS 6 (IMO)...

    BTW: on my second ipad (1st gen) with iOS 5, it works fine as well. To me this is definitely an issue in ios 6.

  • cleggy1966 Level 1 Level 1 (0 points)

    I am getting the exact same problem. My iPhone 4s gets halfway through and then just sits there. Have been searching for ages to try and find an answer, but to no avail. If you sort it, please let me know.

  • voodoostrat Level 1 Level 1 (0 points)

    What I find frustrating is that my devices will complete the loading if I try to access the iTunes library on my iMac that is running Lion, just not my Macs with Snow Leopard, this leads my to point to a iOS6/Snow Leopard conflict. Very annoying, I hope this gets resolved ASAP!!!! Screw Mapplegate, I want access to my music!!!

     

    In the meantime, I'm putting a dupe copy of my iTunes on my iMac running Lion, I'm not waiting for this to get fixed to enjoy my music out in my woodshop. I will just hook up another external to my iMac, and copy the files to it, you can never have to many copies of your files.

     

    If I come up with the solution to this I will gladly share!

     

    Good Luck to us all!

  • voodoostrat Level 1 Level 1 (0 points)

    I completed the move of adding my iTunes library to my Mac running Lion. I got the library to load on my iPhone and iPod, went to select a track, the track came up as selected, I tapped the start button and the track disappeared and track after track appeared randomly and none of them would play.  I even tried my wife's iPod that is still on iOS 5 with the same results, very frustrated.

  • tim2002 Level 1 Level 1 (25 points)

    ok, it works for me with my devices running iOS 5. I saw on various forums in the net, that users having different kind of issues with home sharing. And it seems that Apple TV is not affected, but any of the mobile devices. And it does not seem to expose a pattern that would useful in finding a temporary solution. Perhaps this is also related to iTunes 10.7 and they broke something there in relation to HS.

    But I did not re-test with any previous version now.

    So far, there is no cure for that, waiting on Apple to provide a fix. :-/

    But I will open a support ticket now, the more from us that officially complain, the more likely the cure comes fast (and at all!!)

  • Jim D K Level 2 Level 2 (195 points)

    I had the same problem. It would get half way to loading and then stop. Also got the message about no permisson for this resource. I checked my itunes account and noticed i had 7 authorized devices. For homesharing you can only have 5. I deleted two now everything works! I have an iphone and ipad both ios6.

    I'm not sure why this worked and may just be a coincidence.

  • tim2002 Level 1 Level 1 (25 points)

    @Jim. I checked, and also had 7 devices authorized to my apple ID. So I removed 2 to get down to 5, but still does not work (And it did work before, also with the 7 devices....) The message with no permisson for the resource I did not see in my case.

    Hope they come up with a prober fix soon!

  • tim2002 Level 1 Level 1 (25 points)

    I could resolve my home sharing issue. Here my steps:

     

    First, upgrade to iTunes 11 on the PC/Mac where the library sits

    Then, on the iOS device having the issue do the following:

     

    - open the settings-app and go to the videos section

    - logout from your home sharing

    - close the settings-app completely (close also from background)

    - open the Apple video app just one

    - close the Apple video app again (also completely)

    - force-boot the iOS device (hold shutdown&home until the device switches off, keep holding until Apple Logo appears AND disappears again

    - switch the device on again

    - open settings-app

    - reset the network settings back to factory settings (warning!! By doing this, you have to connect again to your wifi like you would start with a freshly installed iOS!!)

    -  open the settings app again

    - move to the video section and re-enter your credentials into the home sharing account

     

    After doing this, I solved my problem!!

    Perhaps it works also for others.

    Good luck!!

     

    Timo

  • Usermuser Level 1 Level 1 (0 points)

    wow! just did this with my ipod touch on ios 6 and my mac mini on osx 10.9 and it worked!