1 Reply Latest reply: Oct 8, 2012 2:53 PM by bhazel
sydneyzarsadias Level 1 Level 1 (0 points)

Recently my ipod had frozen so i reset it.  After i finished i re downloaded the main apps that i use.  How ever when i tried to download the apps skype and kik a notification came up saying that this app requires ios 4.3.  I have been browsing the web and it says that 2nd g ipods cannot download ios 4.3 or higher.  When I try to download it it says that it is up to date (4.2.1).  This is making me really upset because i had purchased some other apps, (the apps requiew ios 4.3 also).  Since i cannot download these apps i have wasted around $50 on apps i can no longer use.  Any suggestions would be appreciated:)  Thanks


iPod touch, iOS 4.2, Ipod 2nd generation 8gb