4 Replies Latest reply: Oct 11, 2012 7:39 AM by J.Patrick
J.Patrick Level 1 Level 1 (45 points)

OK. This is a tricky one. Mostly doing iMessage on my iPad during the week, and I delete them after the days converstations. When I go onto my iMac on Saturdays at home, iMessage pops up and starts to load all the iMessages from the week. When I delete them from my iPad, doesn't Apple delete them from their servers? This is scary. I have iMessage prefernces set to always be online so I dont have to open the app while on iMac.

 

Also another side question, when on iMac, new message comes in and it does not get linked to my contacts? Like it says new message from +1 (555)555-5555 and not the Person who is associtated with that number.

  • cbs20 Level 4 Level 4 (2,775 points)

    That is the way messages works in its current status. You have to delete the messages from each individual device. Apple may add a feature to delete from all devices, but at this time it is not possible.

     

     

     

    Also another side question, when on iMac, new message comes in and it does not get linked to my contacts? Like it says new message from +1 (555)555-5555 and not the Person who is associtated with that number.

    You have to make sure you have that exact number linked to your contacts on the imac. Do you use iCloud contacts?

  • J.Patrick Level 1 Level 1 (45 points)

     

    You have to make sure you have that exact number linked to your contacts on the imac. Do you use iCloud contacts?

    Not sure what you mean. iMessage from my wifes iPhone to my iPad come with her name and pix in iMessage. Her iPhone to my iMac come over has her phone number and no pix. Contacts are all under one master Apple ID linked to iCloud.

  • cbs20 Level 4 Level 4 (2,775 points)

    The messages app searches your contacts on the local device to link the message with name, number, and photo. This means your iMac doesn't have your wifes number linked to her name and photo. I'm guessing you don't have iCloud contacts turned on for your iMac. Go to System Preferences>iCloud and make sure you have Contacts turned on. Then open your Contacts app to make sure your contacts are loaded in the app.

  • J.Patrick Level 1 Level 1 (45 points)

    I've tried that and more, must be a bug. I did not want to change the phone number in Contacts to have the +1 (AreaCode) in front of it. I guess I can live with it.