2 Replies Latest reply: Oct 9, 2012 2:39 PM by BGreg
kcoakley40 Level 1 Level 1 (0 points)

Currently my farthers mini is running OS X 10.4.11 and operates well enough.  I want to upgrade his mini for his birthday to at least OS X Leopard so he can use a new printer.  I bought a Leopard disk but it will not install on system saying I need "Intel based Mac" I have no idea what this means.  What can I do?


Mac mini, Mac OS X (10.4.11)