6 Replies Latest reply: Oct 11, 2012 10:11 AM by Zebulun
Thomas O'Carroll Level 2 Level 2 (300 points)

I am trying to find the best way to convert footage from my gopro camera to prores. I seem to have stumbled across  nastiness.

Gopro footage : 1080p 25fps

Using Prores 1080p 25fps (not proxy, LT etc)

 

I have tried converting my in compressor. I have also tried rendering the mp4 in fcp 7 and exporting a self contained version prores version for fcp 7. I have tried using compressor 4 (also installed) and moeg streamclip. When I look at the resulting prores video using scopes in either fcp or color it looks like the footage has been clamped to the broadcast safe values. Where pointy peaks should be, there are flat dense lines at the broadcast safe values. Pulling back the highs in a three way color correction revels a reduction in detail, particularly notable in the highlight areas

 

Through much trial and error, I have discovered that if I convert to prores using the ancient QuickTime 7 app there is no "clamping" and there is significant detail retained in the highlight areas (and darks too). This allows me room to color correct to better result.

 

It seems qt7 is only thing that will do the conversion accurately.

 

I have double checked as much as I can. In color for example I do not have "broadcast safe" switched on. It has made me doubt my process and I feel I have gone through fcp and compressor (and mpeg stream clip) as much as I can looking for some sort of similar "broadcast safe" switch.

 

I obviously don't want to loose highlight info at such an early stage of the workflow.

 

As far as I can tell, it does not happen when converting to gopro's CineForm codec and highlight detail beyond the legal broadcast level  is retained.

 

I would love to hear that I am missing something about this or doing something wrong!

 

MacPro 4x dual core

Mountain lion (latest updates)

Note: I have fcp x installed but I am not using this for this job.

  • Jim Cookman Level 7 Level 7 (23,435 points)

    I'm not at my machine right now, but maybe this will give you a clue.  Open up compressor, load up your footage select apple prores LT conversion and copy the preset.  Once copied, you can edit it.  What you want to look for is how it treats white.  It'll probably say white =100, but superwhite is 110,  Change that and you might be good to go.

     

    Experiment with a short clip.

  • Thomas O'Carroll Level 2 Level 2 (300 points)

    I've had a good look through compressor but I can't find anything like you suggest. There is the filter section that allows you to reduce the max white and black values but this i switched off by default.

     

    Interestingly, I have just tried the mp4 in FCP X (MP4 is much easier in X than FCP 7 or course). full range of luminance is shown in the scopes and converting the clip to prores (or rather switching to optimised media) has not detrimental effect. In other words, everything working as expected.

     

    I am seriously wondering if this is a result of running FCP 7 on MacOS 10.8.2 and having FCP X installed.

     

    Thanks for the response Jim

  • Thomas O'Carroll Level 2 Level 2 (300 points)

    I have done one further test.

     

    I have replaced my MountainLion startup disk in my macpro with an older instal of 10.6.8. This disk was used prior to my upgrading to mountain lion and FCPX.

     

    I get same results. Using Compressor or Final Cut 7 to process the MP4 from my GoPro camera the extreme whites and blacks get clamped to broadcast safe 0 and 100%.

     

    Using Quicktime 7 to transcode the MP4 to prores results in a more accurate transcode with whites unclamped, reaching >100% and preserving fine details in bright areas.

     

    Using FCP X in mountain lion to create a prores file from the MP4 creates an identical picture to the QT7 method.

     

    I have found that Compressor 3, Compressor 4, Mpeg StreamClip in OS 10.6.8 and 10.8.2 are incapable of creating a prores video file that is not clamped to broadcast safe values. Color correcting and grading prores files from these apps is less satisfactory.

     

    very odd.

  • Zebulun Level 5 Level 5 (6,745 points)

    I don't use my GoPro much due to abject frustration with their mounting products, but that's a different rant.

     

    I think you've come across yet another reason to throw the GoPro into the trash heap.  I just did a short test with 720p60 and 1080p30 mp4 files with conversion done in MPEG Streamclip.

     

    720p shows full range super black through super white in mp4 and ProRes LT in Premiere Pro 5.5 and ProRes LT in FCP 7, via built-in software scopes.

     

    1080p appears as clamped  IN CAMERA in both file formats in both editors. 

     

    Perhaps do a file format test and hopefully you'll prove me wrong, that I'm again a victim of user error.

     

    Cheers.

  • Thomas O'Carroll Level 2 Level 2 (300 points)

    Interesting stuff Zebulun.

     

    Something is not right.

     

     

     

    Using FCP X to view gopro mp4 at either 720p and 1080p at 25fps shows there is no clamping. FCP X seems to be the boss at handling these files. Ive tested this with the new Go Pro Protune codec (which makes a huge quality difference by the way) as well.

     

    Mpeg Streamclip does indeed seem to do a decent job with 720p. I see no difference between the pro res file from this app and the raw mp4 in FCP X - or a prores converted in FCP X.

     

    Its not quite the case for 1080p though. The version from MPeg stream clip is not exactly clamped but the range seems reduced compared to the efforts made by FCP X.

     

    I don't know what is at the root of all this. I don't think the gopro is clamping anything as it all seems as expected in FCP X. I guess it might be writing dodgy files that confuse other software.

     

    What I feel confident about is that FCP X handles the raw camera footage very well indeed. Even if I end up sticking to FCP 7 for some time I shall be converting Gopro in FCP X.

  • Zebulun Level 5 Level 5 (6,745 points)

    Weird.  As I mentioned, I imported the native 1080p GoPro mp4 into Premiere Pro and it was displayed clamped at 100% on the PPro waveform.  720p was not.  I haven't had a chance to test since in upgraded the camera firmware yesterday.  Perhaps I can do that today.