0 Replies Latest reply: Oct 9, 2012 6:16 PM by whoosh52
whoosh52 Level 1 (0 points)

After allowing updates to be download on my computer yesterday I can not use/open my mail file.  The following message appears when I try:


" You can not use this version of Mail with this version of Mac OS X.


You have Mail version 4.5 (10.84/1085). It can not be used on Mac

OS X version 10.6.8 (Build 10K549).  For more information click the

help button.   "


Was working perfectly well before download.  Can anyone help me

get my Mail back????

iMac, Mac OS X (10.6.8)