6 Replies Latest reply: Oct 12, 2012 8:56 AM by Master of the Universe
Master of the Universe Level 1 Level 1 (0 points)

OS refuses to mount external USB flash drive. Says a piece of OS software is missing. The flash drive (thumb drive) usually lights up but does not go through the flashing on/off that was tyjpical when first inserting it.

I tried an external hard drive and got the same results; that is, no result, as if it wasn't connected. No icon appears on the desktop and no device shows up in the sidebar. It (10.6.8, Mac Pro Duo) had worked perfectly before this, of course.


Mac Pro, Mac OS X (10.6.8)
  • 1. Re: OS refuses to mount external USB flash drive. Says a piece of OS software is missing.
    roam Level 6 Level 6 (13,545 points)

    Some troubleshooting steps are detaled here.

    USB and FireWire Quick Assist

  • 2. Re: OS refuses to mount external USB flash drive. Says a piece of OS software is missing.
    Master of the Universe Level 1 Level 1 (0 points)

    Thanks for your input, but it didn't address the problem. I had tried all obvious things listed. The device (and all other USB devices) have worked in the various USB slots on the machine many, mkany times. Now suddenly they don't.

     

    The first time the flash drive failed to mount a box told me I was missing the software element that was needed to make it work/mount/be recognized. I clicked OK (without writing down the name of the piece of software which, I think, was in the box).

     

    Nothing else has changed, and I had tried the other USB slots, other USB devices, other cables, and the like.

    The OS is up to date as well, and the failure did not occur in association with any update.

     

    Do you know the name of the software in the OS that facilitates recognition of an external USB device? P)erhaps I could do an OS reinstall of only that element?

  • 3. Re: OS refuses to mount external USB flash drive. Says a piece of OS software is missing.
    roam Level 6 Level 6 (13,545 points)

    Do you know the name of the software in the OS that facilitates recognition of an external USB device?

    On OS 10.6.8, I think it is

    com.apple.iokit.IOUSBHIDDriver

     

    found in

    /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/IOUSBHIDDriver.kext

     

    for a full list of all USB drivers, in the Terminal command use,

    kextstat | grep USB

     

    output from my machine lists 12.

    com.apple.iokit.IOUSBFamily

    com.apple.driver.AppleUSBUHCI

    com.apple.driver.AppleUSBEHCI

    com.apple.iokit.IOUSBUserClient

    com.apple.driver.AppleUSBHub

    com.apple.driver.AppleUSBComposite

    com.apple.driver.AppleUSBMergeNub

    com.apple.iokit.IOUSBHIDDriver

    com.apple.driver.AppleUSBBluetoothHCIController

    com.apple.driver.BroadcomUSBBluetoothHCIController

    com.apple.driver.AppleUSBHIDKeyboard

    com.apple.driver.AppleUSBOpticalMouse

    ----------------------

  • 4. Re: OS refuses to mount external USB flash drive. Says a piece of OS software is missing.
    Master of the Universe Level 1 Level 1 (0 points)

    Well, it may be worse than I thought.

     

    I turned on the Power Mac to implement your suggestions and it wouldn't boot. Got as far as the gray Apple logo being replaced with the international "No go" sign (circle with a diagonal cross bar inside), and the spinner spun for ten minutes before I hit the power button. Second and 3rd tries produced the same thing.

    That was lunch. When I get back home I'll try starting fron disk.

     

    This could be a coincidence, but why do I think it's not........

  • 5. Re: OS refuses to mount external USB flash drive. Says a piece of OS software is missing.
    roam Level 6 Level 6 (13,545 points)

    Perhaps now it also cannot find the internal hard drive. I'd say you have a hardware problem, like a failing logic board though I can't be sure from this distance. Run the Apple Hardware test CD and see what it reports.

  • 6. Re: OS refuses to mount external USB flash drive. Says a piece of OS software is missing.
    Master of the Universe Level 1 Level 1 (0 points)

    Hmmmmm,,,,

     

    Disconnected all peripherals. Did a Safe Mode startup and that worked fine. Very limited features, of course.

     

    Started up with the Snow Leopart (10.6.3) disk. Used disk utility to verify permissions and ran disk repair on all three internal HDs. No repairs needed.

     

    Ran Drive Genius and did the same things, as a double-check.

     

    Plugged in the flash drive (thumb drive) and it came up fine (still operating the OS from the Sno-Leop disk). 

     

    I wanted to re-start with the disk and bring up the Apple Hardware Test as you suggested. I had lots of kernal panics on a previous machine, a G4 desktop, and has used that at that time (with a 10.2 or 10.4 disk). thought I remembered that you hold the D key down when starting up from the disk and it would open the hardware test, but either I remember wrong or it works different in 10.6 because it was just a normal startup.

     

    How do I get to the Hardware Test on the 10.6 Snow Leopard disk?

     

    Restarted without the disk and the Mac Pro desktop still showed the gray screen with what Apple calls the "prohibitory" sign, the circle with the diagonal line in it.

     

    I decided to load the OS disk onto HD 3 and designate that as the startup disk, which I did and it works fine. The USB flash drive loads properly, opens, etc. just as it should. I haven't yet plugged in the peripherals (scanner, printer, second DVD/CD recorder, tablet, an external drive, or connected to ethernet yet. Will do those one at a time and see if any of them casued a problem.)

     

    Am I right in thinking:

    A) HD One might have bad sections. I didn't defrag with Drive Genius (26% fragged) or look for bad blocks, which I'll probably do tonight.

    or B) the OS has been slightly corrupted and may need reloading

    or C) I have a virus or conflict (though I haven't added anything new lately). I do have the ButtonManager loading problem for Mac. which is talked about on MacRumors site, etc. but the timing of its appearance and this problem don't match.

     

    Apologies for being so wordy; want to get all information that may be helpful. I appreciate your interest.