1 Reply Latest reply: Oct 10, 2012 3:35 PM by Kappy
Redbeard55 Level 1 Level 1 (0 points)

I have an Imac with OS x .5 when I tried to down load moutain I got a message that my hardware is incompatable with moutain lion can I upgrade my hardware so mountain lion will work?


iMac, Mac OS X (10.5.6)