Previous 1 2 3 4 Next 54 Replies Latest reply: Jul 19, 2015 8:38 AM by DCS Apple Newbie
tz4p99 Level 1 Level 1 (0 points)

Will not set Date and Time (just keeps trying).

AppleTV 2
  • Retaf99 Level 1 Level 1 (0 points)

    Same here, if I go to menu and try to log onto wifi it says no go even though the password is good

  • starbase7 Level 1 Level 1 (0 points)

    Same problem. Apple TV will not connect to the internet even though connected to network and other devices accessing the internet no problem. Now stuck on setting date and time.... All seemed to start after i updated the apple tv software.

  • JohannPotgieter Level 1 Level 1 (0 points)

    It seem to me like everyone is having this issue...wish 'ol apple would do something about it...mine worked fine up till last week boom nothing!!!like it just died....and I'm pretty sure its just out of my apple care plan as well...

  • cwlown Level 1 Level 1 (0 points)

    I've tried resetting my router, connecting the Apple TV via ethernet cable to my router, and restoring the Apple TV to factory settings with iTunes. Nothing has worked. In my case, this started after running the latest software update and after the Apple TV had been unplugged for a few days.

  • jpromano Level 1 Level 1 (0 points)

    Yes, I have enjoyed my ATV for months, using every day, then yesterday it failed when I tried to log on to Netflix, then after rebooting, got stuck on "setting date and time".  I have tried all the stuff in these and other posts, to no avail!!!! My ATV uses wired connection and nothing in my network changed lately, when ATV got stuck!!!!


    APPLE, WHAT IS GOING ON????  After googling, this seems to be a very common problem!!!!!!!!!!!!!!!!!!

  • manyfire Level 1 Level 1 (0 points)

    same here, my daughter updated the software this morning and i lost connection, hooked up to my wifi, i can see my computer, i can airplay, but cant access internet, wont set date and time, and wont let me restore or log into my apple account

  • cwlown Level 1 Level 1 (0 points)

    I was able to get my Apple TV working again by downgrading the firmware following the instructions in this message:



    In case that message disappears, here's my translation:


    1. Connect your Apple TV to your computer via USB. Don't plug in the power cable.

    2. Download the older 5.0.2 firmware from Apple here:


    5.0.2 (Apple TV 2): AppleTV2,1_5.0.2_9B830_Restore.ipsw

    5.0.2 (Apple TV 3): AppleTV3,1_5.0.2_9B830_Restore.ipsw


    3. Open iTunes and select the Apple TV. Hold down the option key and press the restore button at the same time.

    4. In the dialog that opens select the firmware that you downloaded.

    5. The restore process will take a few minutes. Once it's done plug your Apple TV back into your TV. If the date and time message persists just press the menu button to skip it. This got mine working again.

  • manyfire Level 1 Level 1 (0 points)

    I got mine to work, I unplugged the router and plugged it directly into the modem, and it started working, so I reset my router to factory settings put everything back, hooked up to the wifi and it worked, then just had to reset my router security, I have the e2000 router and dd-wrt firmware latest build.

  • starbase7 Level 1 Level 1 (0 points)

    I contacted apple support and they are replacing the unit (it's still in guarantee period). Will let you know if that works!


  • jpromano Level 1 Level 1 (0 points)

    After trying all but the downgrade of firmware, I tried disconnecting the wired ethernet.  Connected to my WiFi and it worked... then I re-connected to wired ethernet, while ATV still on and seems to work.  We'll see when I try and watch NetFlix tonight!

  • Bearded Dog Level 1 Level 1 (0 points)

    This work around worked for me, disconnected the ethernet cable, rebooted and connected with wifi, re-connected the ethernet cable, leaving the ATV on.  Haven't tried to restart the ATV with the ethernet cable plugged in, but my guess its it will fail until Apple provides the next firmware update.

  • Leeperone1 Level 1 Level 1 (0 points)

    Thank you CW that worked perfectly for me!

  • CEB20816 Level 1 Level 1 (80 points)

    I had same problem. Unit had an IP address but couldn't set date and time. As a last gasp I unplugged the Ethernet cable at the appletv and plugged it back in. That solved the problem.

  • Paula1968 Level 1 Level 1 (0 points)

    I came home a week ago to find both of my ATV devices dead...and after of scouring the discussion threads and restarting, resetting and restoring the devices to no avail and much frustration I finally came across your suggestion of "downgrading" the software....thank you thank you thank you!!!!

Previous 1 2 3 4 Next