Previous 1 2 3 4 Next 53 Replies Latest reply: May 30, 2015 8:15 AM by crugee Go to original post
  • CEB20816 Level 1 Level 1 (80 points)

    I spoke too soon. Worked for a few hours and then failed again. Apple store swapped it out for me as I was still under warranty

  • bgray123 Level 1 Level 1 (0 points)

    Same thing just started happening to me.   I can turn on Apple TV, but I cannot do anything because it cannot set the network date/time.   Because of that, I cannot use it anymore.  Tried resetting, restarting, resetting router, etc. Nothing worked.   Went to Apple support and they want $19.95 to initiate a fix.   If so many people are having the same issue, seems like the right thing to do would be to give us a fix.

  • CEB20816 Level 1 Level 1 (80 points)

    I ended up taking mine to the apple store and they swapped it under warranty. After I got it running by pulling the Ethernet cable it even had trouble making an hdmi handshake.

     

    CB

  • Sutjipto Level 1 Level 1 (0 points)

    After trying many suggested workarounds, and they didn't work, I've downgraded the firmware to 5.02, then setup everything once again just like before, IT WORKED!!

    Thanks so much for the idea and firmware links. Still alive today Nov 11, 2012.

  • minueind Level 1 Level 1 (0 points)

    Thank you so much for the tip! I had similar problem and now..it's healed!

  • dirtboy66 Level 1 Level 1 (0 points)

    Hey cwlown.

    Thanks for your post I was able to get my ATV3 to work again with a few slight modifications to your instructions due to the fact I was using a PC to facilitate this process.

     

    cwlown wrote:

     

    I was able to get my Apple TV working again by downgrading the firmware following the instructions in this message:

     

    https://discussions.apple.com/message/20008613#20008613

     

    In case that message disappears, here's my translation:

     

    1. Connect your Apple TV to your computer via USB. Don't plug in the power cable.

    2. Download the older 5.0.2 firmware from Apple here:

     

    5.0.2 (Apple TV 2): AppleTV2,1_5.0.2_9B830_Restore.ipsw

    5.0.2 (Apple TV 3): AppleTV3,1_5.0.2_9B830_Restore.ipsw

     

    3. Open iTunes and select the Apple TV. Hold down the option key and press the restore button at the same time.

    4. In the dialog that opens select the firmware that you downloaded.

    5. The restore process will take a few minutes. Once it's done plug your Apple TV back into your TV. If the date and time message persists just press the menu button to skip it. This got mine working again.

    1. If you have a ATV2 then you only need the usb cable. However, if you have an ATV3 you will need to plug your AC power supply as well.

    2. I am using a PC to run ITunes and found (after many frustrating hours) you dont need to download the files from the links in cwlowns post to your computer.

    3. Open ITunes for ATV3 plug in usb cable to device then into PC. Next plug in AC power supply to ATV3. Next when the ATV3 is detected by ITunes the restore ATV window opens in ITunes. The next steps are the PC variance's on cwlown's instructions.

        

         Modifications to steps for using a PC to perform the ATV firmware regression.

     

    1PC- right click on whichever link you need from cwlown's post (ATV2 or ATV3). In the Right-Click menu that opens select "Add to favorites" then go back to ITunes where the ATV restore window is waiting.

     

    2PC- PC's do not have an option key, contrary to the web and it's many pages of misinformation the Alt key is not the same as the option key. I am using a Samsung laptop with Windows7 and the SHIFT key is the PC equivelant to the MAC option key! hold down the SHIFT key and left click on the restore button in the ATV restore window. This should open up a search window. Go to your favorites folder (mine path was C:/users/favorites) there you will see the link from step 1PC. select the link and click open. The computer will start restoring the ATV. My computer acted like it froze up when I selected open and I didn't see any hint at a progress bar or notification that the firmware was updating. I just left the PC and ATV hooked up under this condition for about an hour. When I checked on it the search window was gone and a message window was there telling me that my ATV was succesfully restored and to plug it in to my TV.

     

    Step 5 of cwlowns post was also spot on. My ATV wanted to get stuck activating/set date and time I simply pressed the menu button on the ATV remote and ATV started working again.

     

    Hope this helps!

  • Apple-MTC-Consultant Level 1 Level 1 (0 points)

    Okay....  it looks like many people have this issue with setting the network time on the Apple TV after upgrading to version 5.1 of the software.

     

    An alternative to downgrading the software via USB is to setup your router / modem so the Apple TV is in a DMZ (demilitarized zone) off of the router/firewall.

     

    Most modern routers have this capability and you can simply select the device or the IP Address of the device to be added to the DMZ.

     

    This only needs to be done temporarily so the Apple TV can have the network time pass through the firewall.   Once you make this change to your router and RESTART (Settings - General - Restart) the Apple TV, your Apple TV device will have the Network Time set and you will be back in business.

     

    If you are uncomfortable keeping the Apple TV in the DMZ zone of your firewall, you can remove it after the network time has been set.

     

    FYI - if you are doing this on an Actiontec firewall (PK5000) follow these steps:

    1.  Log into the actiontec via internal IP Address

    2.  Select Advanced Security - DMZ hosting -

    3.  Enable DMZ - Select Device and/or enter internal IP Address of Apple TV  (look in DHCP of firewall or on Apple TV, SETTINGS - GENERAL - NETWORK) for the IP Address currently assigned to the Apple TV.

    4.  Click the "Apply" button on the action tech Advanced Setting page to save your changes.

    5.  Your router will reboot

    6.  Once your router has rebooted - restart your Apple TV and your network time setting will pass through the firewall and you will once again be able to log into iTunes from the Apple TV.

     

    7.  Go back into the ActionTec firewall and remove the Apple TV as a DMZ host (Advanced Security - DMZ hosting - Click the "REMOVE" button next to your Apple TV DMZ host.

     

     

    The Apple TV can lose its time setting if it is left uplugged, so you can do this again at any time if you need to reset the network time.

  • Budhiss Level 1 Level 1 (0 points)

    Thanks Apple MTC Consultant!

     

    There is no need to downgrade.

     

    The problem is in the setting of the router which doesn't allow network time info to pass through router's firewall. The easiest method is to try connecting ATV to a different network (i use my iphone personal hotspot which are connected to 3g cellular data network), then restart the ATV. Once the network time are set you may reconnect back to your router.

     

    Mine works flawlessly now.

  • Leeperone1 Level 1 Level 1 (0 points)

    Budhiss, It worked flawlessly without having to resort to anything prior to this upgarde. The upgrade broke the process, not the router and we should'nt have to resort to extraordinary measures, either downgrading or router changes to get something we paid for to work as advertised. IMHO

  • ProxSee Level 1 Level 1 (0 points)

    What confused me is, why we didn't have this router firewall problem before the upgrade?

    If the older firmware had no problem setting the date passing the same router, why the new firmware did ?

    In my case, no filter of some sorts is being activated in the router, it's simply doing a standard Source-NAT from the internal IP private addreses to the given public IP address given/assigned by the ISP (router is a Mikrotik).

    I'll wait until the next firmware upgrade to give another try, for the time being, am happy with the 5.0.x and will stay there for a while.

  • suchamiro Level 1 Level 1 (0 points)

    Very frustrating.  Apple MTC Consultant's suggested DMZ fix did not work for me.  cwlown's suggested downgrade fix did work -- thanks, cwlown. 

     

    Seems like something Apple should fix.

  • Basilbro Level 1 Level 1 (0 points)

    My problem was not exactly the same as people above but thought I would post my issue and solution in case someone has the same and I can save them a few hours.

     

    My service provider is Bell and after sending me a new modem to replace one that was acting up Apple TV did not work. Called in two different times and both tech's told me it was an Apple issue. Connected old moden (exactly the same as new) and Apple TV worked again. Called Bell back and they reset my account access password which is modem specific and it works fine now.

     

    I was told that In some cases they may have to set a static IP address for your modem instead of havinng a dynamic one. This sometimes creates issues with AppleTV.

     

    Also, if your a Bell customer they won't support devices they don't sell. I was lucky enough to speak to a very good tech who was willing to help regardless of Bell policies. Funny that they'll be happy to upgrade me to a Fibe25 service with 200GB of allowable monthly data to accomodate AppleTV but won't help troubleshoot a conflict with that device and their modem in most cases.

  • mgoitein Level 1 Level 1 (0 points)

    Just restarting the wireless router and then restarting the Apple TV immediately fixed this issue for me.

  • lindsay201 Level 1 Level 1 (5 points)

    Thanks Budhiss, your solution worked perfectly for me!

  • Italoman Level 1 Level 1 (0 points)

    You can always buy a ROKU box - it works very well and does not have the limitations that AppleTV has on it.

    Maybe if enough people stop purchasing ATV they might wake up and fix something.