Skip navigation

HT1595: Apple TV (1st generation): Troubleshooting wireless connections

Learn about Apple TV (1st generation): Troubleshooting wireless connections

HT1595 Stuck on Setting Date and Time

44684 Views 48 Replies Latest reply: Dec 11, 2013 5:13 PM by kludge RSS
  • VRod007 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 21, 2013 6:50 AM (in response to tz4p99)

    Had similar issues with my ATV2 not being able to set the date and time. I tried resetting, restoring, restarting and all would seem to get stuck at the setting date and time. I finally uplugged it and plugged it straight into my MacBook Pro with the micro usb cable (didn't even need the power cord). Through iTunes I clicked on Restore. iTunes took over and did a complete restore including a firmware update. Then when it finished it said to plug it back into the TV. When I did it asked me to set the language, set the wifi network and password (the usual startup stuff) and voilà! It works again.

     

    I know that one solution doesn't always fit all so I'm sharing mine. Hope this helps.


  • Mrphilleo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 22, 2013 5:14 AM (in response to VRod007)

    Had the sale issue. Went To the router config menu and released DHCP. Restarted the ATV3 and it works.

  • Holiq Hudairi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 14, 2013 7:06 AM (in response to tz4p99)

    I was able to get my Apple TV working again by downgrading the firmware following the instructions in this message:

     

    https://discussions.apple.com/message/20008613#20008613

     

    In case that message disappears, here's my translation:

     

    1. Connect your Apple TV to your computer via USB. Don't plug in the power cable.

    2. Download the older 5.0.2 firmware from Apple here:

     

    5.0.2 (Apple TV 2): AppleTV2,1_5.0.2_9B830_Restore.ipsw

    5.0.2 (Apple TV 3): AppleTV3,1_5.0.2_9B830_Restore.ipsw

     

    3. Open iTunes and select the Apple TV. Hold down the option key and press the restore button at the same time.

    4. In the dialog that opens select the firmware that you downloaded.

    5. The restore process will take a few minutes. Once it's done plug your Apple TV back into your TV. If the date and time message persists just press the menu button to skip it. This got mine working again.

     

     

    Good Luck !!!

  • appleko Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 23, 2013 12:21 AM (in response to cwlown)

    Hi Cwlon, or any that can help

     

    I downlaoded the software, but comes down in ZIP. Also the files unzipped dont have IPSW extention.

     

    any tips how to gt it done, becasue when I try to restore using I-tunes it will not pick the software up

  • cwlown Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 23, 2013 6:05 AM (in response to appleko)

    Two things to try.

     

    1. Don't unzip the file. Just change the file extension to .ipsw and see if iTunes will recognize it.

    2. Use a different browser to download the file.

  • cjs77 Calculating status...
    Currently Being Moderated
    Mar 1, 2013 7:53 PM (in response to tz4p99)

    The problem is still the 5.1 or 5.2 firmware. There are 2 workarounds (I use firmware 5.2 and 1st described below):

     

    1.- Switching to a smartphone's hotspot internet access and then switching back to home wifi:

     

    example with iPhone 4S iOS6

         a. Turn off WIFI and turn ON General>Cellular>"Cellular Data"

         b. Turn on Settings>Personal Hotspot (then assign an apple tv-friendly password...if you look at the apple tv password input menu, that means letters/symbols next to each other, for example)

     

    Now do the following to the Apple TV:

         a. make sure ethernet cable is unplugged

         b. press remote "Menu" key until youre in the menu with only Computers and Settings icons

         b. Go to Settings>General>Network>Wifi> Select "Other" and wait for the list to appear, then select your phone's name and enter the password (you'll see what I meant on step 1-b)

     

    Return to the main menu and wait a few seconds, then it should load all the ATV icons...but that's not it...you want to use home wifi, not cellular data...

     

    Now go back to ATV Settings>General>Network>Wifi and select your router's wifi under Other's list...it will now connect to the internet as always.

     

    2.- The other option is to downgrade to 5.0.2 firmware. You can find this solution in the answers above and that-s a permanent solution as long as you don-t upgrade by mistake later. I posted it step by step with some important details people don-t mention to make it work: https://discussions.apple.com/thread/4035175?start=0&tstart=0

  • Thomas_Jefferson Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 6, 2013 11:16 AM (in response to cjs77)

    I resolved my issue by providing a static ip address for my apple tv 2.

  • alumni.usc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 8, 2013 4:32 PM (in response to tz4p99)

    I first started having this problem with two different AppleTVs (one at home and one at work) back at the end of 2012 immedialtery after a software update. I tested everything at home and in the office with another AppleTV that had not been upgraded and it worked fine on both networks so I was more than convinced it was the software upgrade that turned two of my AppleTVs into bricks. I tried everything to fix my AppleTVs and went into an Apple store and they would not even acknowledge this problem. So I put the two AppleTVs in a closet and forget about it the last few months. Last night I decided to to plug the AppleTV back in and see if pehaps a new software upgrade had been released that would fix this problem. There was a new software upgrade and it fixed the problem.  So for now, problem solved.

  • markdavies Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 11, 2013 11:09 AM (in response to tz4p99)

    This vexed me for a long time. Now we finally have a fix!

     

    All credit goes to Ed Gainer, our Network Admin.

     

    :::

     

    Version update 5.2.1 (6025) seems to have changed the way its searches for time. According to the Apple website’s list of ports used by Apple, the time protocol NTP would normally communicate via TCP or UDP. This was the case in previous versions, but when the update for 5.2.1 was introduced, the Apple TV displayed a “Searching for Time and Date” indicator upon restart. The only remedy was to select “Menu” on the Apple Remote. At that point, the main menu now only displayed “Computers” and “Settings” options. All the icons for other online content options such as YouTube, HuluPlus, Vimeo, etc. were missing.

     

    After running a packet trace the ports, NTP (123), DNS (53) and ports 49152 – 65535 were used in booting the Apple TV. After some trial and error it appears that the Apple TV is searching for the time via the NTP protocol through UDP. When port 123 was opened in the firewall over TCP/UDP it still did not communicate. The solution was to specifically indicate the NTP protocol over UDP. Keeping the NTP protocol specified via TCP is also recommended.

     

    The resolution to this problem was to create a service group for Apple including the following services.

     

    Name

    Protocol

    Source Ports

    Destination Ports

    NTP

    UDP

    Default (0-65535)

    123

    http

    TCP

    49152-65535

    80

    https

    TCP

    49152-65535

    443

     

    Additionally, it is recommended to include these services in the group to encompass all of the Apple products in your environment.

     

    Name

    Protocol

    Source Ports

    Destination Ports

    NTP

    TCP

    Default (0-65535)

    123

    3689 (iTunes Library)

    TCP

    Default (0-65535)

    3689

    5353 (Apple TV iTunes)

    UDP

    Default (0-65535)

    5353

    Domain (DNS)

    TCP

    Default (0-65535)

    53

  • mylesfromgreenbrier Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 14, 2013 7:17 PM (in response to markdavies)

    Awesome markdavies!!

    the network infor was just what i needed. I opened up the correct ports and presto it worked!!

  • Donald & Gillian McDonald Calculating status...
    Currently Being Moderated
    Apr 15, 2013 11:56 PM (in response to Holiq Hudairi)

    Sadly none of this worked for me, all I get are messages saying "this device is not eligibler for the requested build:" or "this device cannot be restored as the firmware is not compatible"

  • pg888 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 25, 2013 5:54 PM (in response to tz4p99)

    A very helpful chap at Apple just helped me figure this out.  My network seemed to be out by a couple of minutes (not sure why).

     

    We connected the Apple TV to a differrent wireless network (my iphone hotspot) and that fixed it.

     

    Restarted the Apple TV, this time connecting to my regular wireless network and all good.

  • gwilanne Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 7, 2013 3:20 PM (in response to tz4p99)

    Hello

     

    I am not exactly sure how I fixed my apple tv 3. But I called my internet supplier (Rogers in Canada) and they couldn't help me. Although I rent my router from them, they told me they don't change the ports and are in fact not trained on anything of the sorts. They advised they would have to transfer me to some other department but most likely they would have to charge for the help.  So I tried to fix the ports on my router but no luck, it kept telling me illegal ports.  So I was playing around with the apple settings and I disconnected from my network and selected another network in the area. I left it on this network for a couple of minutes.  I then removed from that network and selected my own network. I had to reenter my password and then I manually changed my DNS (so I can get american netflix). Then went back to menu and all my apps were back.

     

    I don't know if this will help anyone else but I thought I would share.

  • Nestom1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 22, 2013 6:38 AM (in response to tz4p99)

    Connect to another wi-fii and switch back. My area has constant power outages and each time power comes back on, I have to "set date time." Connecting to another network always work...easy.

  • ffr2822 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 18, 2013 10:39 AM (in response to tz4p99)

    Ok, I just went thru this. I brought my AppleTV along on a trip. I normally use an airport express on such trips, and had never had a problem with just keeping my network local. Until this trip. The "Setting Date And Time" and even hitting menu would not get me out of  it. I tried restore - to no avail, as it would display "authorizing". I suspect this was in part due to the way the hotel does its networking, as if there is no brower, there is no way to authenticate on their network. In any case, I finally got things to work by:

    1) Enable the hotspot on my iPad

    2) Restore the appleTV to factory settings.

    3) Configure the AppleTV to use the iPad network.

    4) Finish normal setup.

    5) Switch the network to my AirportExpress

    6) Switch my laptop to the AirportExpress

    7) All is good.

    I suspect if I power cycle the beast, I'll have to switch back to the iPad network to get the time set, then back to the local.

    Editorial Comment:

    Kind of sad that we can no longer use tools unless they have a global network connection - even if it was already authorized. I wonder what happens to those that cannot bypass blocks on NTP?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.