Previous 1 2 Next 17 Replies Latest reply: Jan 10, 2013 1:35 PM by jhwitt
akmerican Level 1 (0 points)

I have the iphone 5. My carrier is Sprint. I can get email only when connected to wi-fi. When no wi-fi is available I get a pop up message that says: cannot get mail. no internet connection available.

 

I am sure I am just missing a setting or something to correct this. Any ideas?

 

Thank you!


iPhone 5
  • xyzzyva Level 1 (0 points)

    I have the exact same problem.  Are you using Gmail?  Note also that while Mail cannot access Gmail on cellular data, the Gmail app works just fine.

  • xyzzyva Level 1 (0 points)

    I've finally fixed it:

     

    Many of the reports I've found while trying to fix this problem mention the iPhone having problems with two-step verification on your Google account.  Since I didn't use two-step verification, I had been ignoring fixes for it.  In desperation, I finally tried turning two-step on on my Google account, then using it to generate a device-specific password for my iPhone.  I entered that in the Mail settings and voilà!

     

    Links that may help:

    https://accounts.google.com/SMSAuthConfig

    http://support.google.com/accounts/bin/answer.py?hl=en&answer=185833

  • tall_pete Level 1 (10 points)

    I had this same problem. I had my account setup via Exchange so I could get push email. It worked fine over wifi, but over 3G I'd get the "cannot get mail. no internet connection available" message (meanwhile the internet was just fine in all other apps).

     

    I just changed the account from being setup through Exchange to the GMail option. It seems to be working fine over 3G now, but no more push . Anyone have a solution?

     

    My carrier is also Sprint.

  • bsb150 Level 1 (0 points)

    I had this problem.  iPhone 4s with Sprint.  I had just added my gmail account to Mail.  After a couple days, I felt like it wasn't necessary, so deleted that account.  All the sudden I started getting "cannot get mail. no internet connection available.

    I found a solution here:

    http://www.apple.com/support/iphone/assistant/mail/#section_4

    Click on 'check SMTP settings'

     

    The problem was, that when I deleted my gmail account, it left the gmail server setup, on my phone and it had been turned OFF. 

    Go to Settings > Mail, Contacts, Calendars. Under Accounts do you see one for iCloud and another for gmail? If so, tap the gmail and look to see if it is turned OFF.  I was able to just delete that server from my phone, and it fixed the problem.

  • tall_pete Level 1 (10 points)

    I rebooted my phone, which seems to have fixed it.

     

    To reboot: hold down the power and home buttons at the same time until the phone turns off. Then turn it back on.

  • tall_pete Level 1 (10 points)

    Reboot fixed it for me too. Thanks!

  • tall_pete Level 1 (10 points)

    The issue has come back for me. Rebooting seems to only temporarily fix it. Anyone else find a solution?

  • tall_pete Level 1 (10 points)

    I think bsb150 might have the answer.  I had SMTP turned on for my icloud account (Mail Contacts Calendars -> iCloud -> Account -> Mail -> SMTP) and for GMail. I turned off the icloud SMTP, and turned the phone off/on. It seems to be working for now. Hopefully this fix lasts.

  • Smurfzilla Level 1 (0 points)

    Reboot fixed it temporarily for me.  On Sprint, the following fixed it for good.

     

    On the phone, dial ##873283# and hit call.  You should see something about "Starting service update" and after a few moments "Update complete".  It failed for me at my office.  I had to go outside and have strong signal for it to complete.

     

    Once this completed, I have had zero issues with regards to gmail sync and the "Cannot get mail." error.

  • Kobe-ko Level 1 (0 points)

    I had Sprint + iPhone 5 + Gmail problem but BIG thank you so much for Smurfzilla's post !

    It surely worked. No trouble getting / sending email all day today made my life so much easier.

     

    Thank you Smurfzilla !

  • tall_pete Level 1 (10 points)

    Everything suggested so far, including what I posted and the PRL update Smurfzilla posted, only temporarily fixed the issue. This continues to be a problem for me.

  • teaflow Level 1 (0 points)

    Same here. The solution presented only works for a short period of time and then must be implemented again.

  • Smurfzilla Level 1 (0 points)

    Sorry to hear.

     

    The issue has not popped back up for me since my post.  I wish you luck in fixing your troubles.

  • skoot Level 1 (0 points)

    I experienced this problem firsthand with a Sprint iPhone 5 about a month ago, telling me it had no internet connection and could not check my email (which was Gmail, set up through the native Mail app, using default settings). I can confirm that restarting the phone (holding home + power buttons until restart) temporarily fixed the problem but it quickly returned. Toggling Airplane mode did nothing. The problem did return within the same day after a period of time. I have since switched back to AT&T.

     

    Interstingly, my sister had the same issue with her brand new Sprint iPhone 5 this week. She called Sprint and the customer service representative confirmed that this is a problem that only affects Sprint iPhone 5 users who use Gmail. The rep told her that it affects Gmail both in the native Mail app and also in the Gmail app, but web use still works (I haven't confirmed this). The rep also said that Sprint is aware of the problem and working on a fix that would be delivered in the form of a "software update" but there was no clarification if that was an iOS update or a Sprint carrier update.

     

    That's all the info I have now, but if you're a Sprint iPhone user and experiencing this problem, please do call Sprint and let us know what you find out.

Previous 1 2 Next