4 Replies Latest reply: Oct 11, 2012 5:57 PM by Allan Jones
MMoore1993@unii Level 1 (0 points)

i have just brought a mac 17" and runs on: lepord 10.5.8


Model Name:          iMac G5

  Model Identifier:          PowerMac12,1

  Processor Name:          PowerPC G5 (3.0)

  Processor Speed:          1.9 GHz

  Number Of CPUs:          1

  L2 Cache (per CPU):          512 KB

  Memory:          512 MB

  Bus Speed:          633 MHz

  Boot ROM Version:          5.2.6f1

  Serial Number (system):          W8*****TAQ

  Hardware UUID:         ****


i am trying to download the new itunes for my iphone running on IOS 6: trying to update the itunes which is currently running on an older version, when i try and update it it tells me its not supported by the arcihtecture, this is the same for things like skype, spotify and other software.


can anyone help me fix it :/


<Edited By Host>

iMac, Mac OS X (10.5.8)