14 Replies Latest reply: Sep 9, 2015 5:32 PM by HeliMurf
dementad Level 1 Level 1 (0 points)

I have a book stuck permanently on "downloading." I have power cycled my iPad, signed off and back onto iTunes, and removed and re-installed iBooks, all to no avail.


Thanks for any ideas on how to fix this...

iPad (3rd gen) Wi-Fi, iOS 6
  • JohnS85 Level 1 Level 1 (0 points)

    Yeah, this is bull ****.  My apps have been hanging and wont update either.  Thought books would be different, bought one yesterday from my Mac, and it just keeps saying downloading.  I too tried signing out of my account on my new iPad, power cycling, pluging into iTunes, deleting apps then redownload. 


    Im going into an Apple store to do some solid yelling/complaining.

  • Aqpetersen Level 1 Level 1 (0 points)

    I had this problem and fixed it by deleting the iBooks app from my iPad. When I reinstalled it all my previous purchases downloaded, including the two 'stuck' books. Just make sure to backup any PDFs or non-iBooks that you have so you can reinstall them from your backup location.

  • rcancill Level 1 Level 1 (10 points)

    I tried deleting the app also.  It cleaned up a few other glitches, but the book that is stuck in a permanent download still says "downloading".  Nothing I can seem to do to get rid of it.  There real killer is it s an Apple book... about the iPad.  I'll probably get a reply that tells me to read the book :-)

  • ljjbill Level 1 Level 1 (0 points)

    Reinstalling ibooks won't help me at all. The book is still downloading when I lauch the app. It seems like deleting the app won't delete any books downloaded either.

  • rcancill Level 1 Level 1 (10 points)

    I too reinstalled iBooks and no help.  I have book stuck in the "installing" status with an empty black status bar.

  • mvasilakis13 Level 1 Level 1 (0 points)

    Add me to the list. Cycled power, deleted/installed iBook app. No joy.

  • Richard Tamesis Level 1 Level 1 (25 points)

    I just encountered the same problem. I bought a book from the iBookstore and now have it stuck "downloading". I can't delete it from iBooks on my iPad and when I delete then redownload the iBooks app, the stuck book shows up again. I tried unchecking it on iTunes and resyncing, but that did not work either.

  • mvasilakis13 Level 1 Level 1 (0 points)

    I found a solution that worked for me.

    I connected my device to iTunes. Removed the book & reinstalled it via iTunes. (IIRC)


    (Others have had success by downloading a free book.)

  • Mer-aps Level 1 Level 1 (0 points)

    I am having the same problem. I have deleted iBooks and  reinstalled it via iPhone and also by my computer. But no matter what I do, when iBooks is re-installed the book shows that it's downloading but the status bar is empty. I even turned off my iPhone for day and still nothing. Help. 

  • apple-user2014 Level 1 Level 1 (0 points)

    Ok, so we are into year 2014 and Apple still doesn't care to fix this for once and all!


    Reinstalling iBooks doesn't help. iTunes doesn't list the book so I can't delete it. But, iBooks show the book and download is stuck! Reboot doesn't help either!


    Any magic to fix this??

  • ChrisLP Level 1 Level 1 (0 points)

    I had the same problem on my iPhone  I had two books that were permanently stuck downloading.  Like the other users on here, I tried everything and nothing worked - it drove me crazy for months.




    Based on the comment from mvasilakis13 (thank you!) I connected my iPhone to my computer and opened iTunes.  Like some of you who have already tired this, the two books that were stuck in download did not appear in iTunes.  However, when I opened iBook on my iPhone, I noticed the icons next to the two stuck books (I was using list view) changed from the circle with the square in the center to the cloud with the arrow pointing down.  With my iPhone still connected to iTunes, I tried downloading the books again from by iPhone and this time it worked.  I have no idea why this worked, but it did.


    I agree with comments on here, Apple really needs to fix this.  But in the meantime, maybe the above solution will work for some of you.


    Good Luck!

  • l3rainzone Level 1 Level 1 (0 points)

    Happened to me. 


    This process creates a clean files system.  It appears that iBooks file area is cluttered with unfinished business.  With iBooks excluded from the backup, the problem goes away.


    1) Backup your iPad to iCloud

        -- Turn on iCloud Backup if it is not already on.

        -- Under "Backup Options" deselect iBooks (make sure everything else is selected)

        -- Delete the iBook App

        -- Tap "Backup Now" and wait for the back up to complete.

    2) Reset your iPad

       -- make note of your AppleID and Password in iCloud

       -- turn off "Find My iPad"

       -- goto Settings-->General-->Reset

       -- choose "Erase All Content and Settings"

    3) When the iPad starts, choose "Restore From iCloud Backup"

    4) Reinstall iBooks

    5) Download your iBooks from "Purchased Books" collection.


    Hope this helps.

  • lancevan Level 1 Level 1 (5 points)

    Go back into the bookstore and search for the book you were trying to purchase. Then select "read" (or whatever option it gives you instead of the price). You might also have to switch to list view in your book collection in order to stop or delete your previous attempt to download the book (but I doubt it). Worked for me. Good luck!

  • HeliMurf Level 1 Level 1 (0 points)

    Brilliant ! Thanks very much ! That worked just fine for me !