Previous 1 2 3 4 Next 57 Replies Latest reply: Jan 31, 2016 11:13 AM by Frugal Freddie
mrmatthewnk Level 1 (0 points)

I have an iphone 4s. After the most recent update I've been unable to back up to my computer. I get a message saying "iTunes could not back up the iPhone because not enough free space is available on this computer. Removing files and emptying the Trash will free up additional space." But I currently have over 150gb free space. I followed the instructions anyway, but it had no effect.

iPhone 4S, iOS 6
  • razmee209 Level 7 (30,234 points)
  • mrmatthewnk Level 1 (0 points)

    Thank you for your help. Unfortunately solution 1 and solution 2 had no effect. The problem with restoring is that I'll lose any data that I've add to my phone since the last backup, right? Kinda defeats the pourpose of backing up...

  • smachaje Level 1 (0 points)

    I have the same problem, and I have not seen a solution on any of the threads yet.


    I have 250GB HD, and 115GB empty.  iTune says it cannot backup my 64GB phone (the backup is actually only 26GB, since it is likely compressed.  So, I delete data and now have 135GB free.  Now iTunes backs up my iPhone.  Why?  Why do I need so much free space before the 26G backup is completed?


    And the kicker is, that I linked an external HD with 2T free for the Backup directory.


    So the issue is in the way iTunes calculates free space.  Maybe it requires twice the size of the device just to get started on the backup?  And it only checks the root device, not even the MobileSync directory.


    There is a major glitch in iTunes.


    My favorite solutions for this issue is to "delete backup".  I'm running backups to prevent data loss on the first place!  Some of the posts say that backups are corrupted.  No they are not!  It's just when you remove backup, you free up space and iTunes will do another backup.


    When iPhone was 8G it made sense to make sure there was at least 16G free on the device.  But with 64G, give me a break!

  • smachaje Level 1 (0 points)

    Well, I'm back to square 1.  I now have 200GB free and still cannot backup the phone.


    I can backup my phone to another iMac, so at least it is not the data on the phone.

  • smachaje Level 1 (0 points)

    Ok, I'm making some progress.  The issue for me seems to be in USB device conflict.  When I disconnect my USB external drive, then rename backups in MobileSync/Backup ( or you could chose to delete them ) my backup of iPhone 4S is successful.


    If I unmount the drive, the backup works.  If I connect the phone, then reconnect the USB drive, the backup works.  Possibly other USB devices may interfere for others too.


    Since I got the external drive to deal with large backups, this makes for a silly problem.

  • flyingarmour Level 1 (0 points)

    I've tried all of these things, and I have a 2TB internal drive, and none of them have helped. 

  • smachaje Level 1 (0 points)



    I think there is some vodoo going on with the backup process.  I upgraded to the latest iTunes and I deleted some data from my 64GB iphone (30% free diskspace) and now the backup is working.  I can't tell you that I know specifically what has changed.

  • Mark Mcshane Level 1 (5 points)

    I have the same problem, with all of the same symptoms. The only thing that's consistent about this is the unpredictability of it...sometimes the backup works, sometimes it does not. Sometimes disconnecting the USB devices helps, usually not. I have more HD free space than makes any sense. Apple Support people have walked me through it and it makes no odds.


    Apple...are you listening? this is a royal pain in the backside. Kindly address this issue sooner rather than later.

  • lodcomm Level 1 (5 points)

    Hello Folks,


    I was receiving this error randomly on my macbook 13, OSX 10.6.8  and with various versions of itunes.  I'm pretty sure the problem was an excessive number of file entries (Inode exhaustion) in the directory where Itunes stores it's iphone backups:


    ~/Library/Application Support/MobileSync/Backup/


    A typical backup consists of well over 3000 individual file entries.. I had 8-9 different top level backup directories, each with several sub levels.. Bottom line is that I had tens of thousands of individual files in the /Backup/ directory. I believe this was exceeding the available Inodes (data structures that the OSX (Unix)  filesystem Uses to hold information about an individual file. When the disk is initially formatted and structured, there is a set ammount of these Inodes allocated).  When the available inodes are all used up, Unix sees this as the disk being full (even though there may be hundreds of Gigs available) Since the filesystem has no remaining Inode's to store the relevant information of a new file entry it errors out claiming  disk is full. Essentially there are "too many individual files"   -   A good way of understanding it would be:  a 1 GB HDD would hold a single 1 GB file, however it would be unable to hold say a million one byte files. 


    Anyways, enough of the Unix filesystem theory.. The way I was able to correct my "Itunes could not backup iphone because not enough free space error" was to simply go into:


    ~/Library/Application Support/MobileSync/Backup/


    and delete all of the backup directories in it.   From the shell/Terminal I did the following


    Open terminal


    $ cd ~/Library/Application Support/MobileSync/Backup/

    $ tar cvfz all_backups.tar.gz ./*        ( this will make a tar archive of the existing backups, may take a while)

    $ mv all_backups.tar.gz /some/backup/volume  (move your tar archive to some safe place)

    $ rm -rf  ./*                                  ( remove all existing backup files & directories in the current dir)


    once this completes, youe should have an empty: ~/Library/Application Support/MobileSync/Backup/


    At this point it may not hurt to go fire up disk utility and repair permissions on the drive that holds your iphone backups.


    Fire up itunes, and click on backup.  Hopefully all will be well for you.



  • the-design-guy Level 1 (0 points)

    For what it's worth, I couldn't get the terminal commands to work (by cutting and pasting from your post), but I went to the folder you mentioned (~/Library/Applications Support/MobileSync/Backups) and dragged the contents to trash. Now my iPad is backing up.


    Note that I had 340 GB of available space and a 16 GB iPad. Plus, since I had just installed a new hard disk in my iMac, there was only one device backup up to the computer, my 16 GB iPhone. So somehow, I doubt that I had the lnodes filled. I'm guessing a corruption problem for me.


    Thanks for all your contributions!

  • RajinCajun Level 1 (5 points)

    This is what I did that worked: Empty the trash can.


    Yes, that is all I did, and I have an iphone4 and a hard drive that has over 150GB free. After emptying the trash, it synced no problem. No unix commands, no mumbo jumbo, just right click on the trash can and click "empty trash"

  • smachaje Level 1 (0 points)

    I've made a bit of progress on this issue.  I don't think it has anything to do with diskspace.  What helps in my backup are these:


    1. Close all apps on the iPhone

    2. Restart the iPhone

    3. Press Backup again, even after you get the message


    My backup runs occasionally successful.

  • Bezza4 Level 1 (0 points)

    I am having this same problem. I bought a secondhand MacBook at the weekend, which appears to have been cleared of all files, as it says that the majority of the hard drive is free, still over 100GB free, yet I cannot backup my 32GB 4S.


    I have tried clearing the files from the backup folder as above, but there weren't any files there to delete. I was doing this manually as the commands didn't work for me. I even renamed the original Backup folder and created a new one to see if that would make any difference.


    Reading a couple of other posts, I have created a new account. Made no difference. And I have just done a 'Repair Disk Permissions' under Disk Utility, but again that has made no difference.


    Can anyone help or suggest anything else that I can try?

  • AnaMusic Level 9 (57,110 points)

    Bezza4 wrote:


    ...I bought a secondhand MacBook at the weekend,...


    You have posted to an iPhone Thread in the iPhone Forum.


    Suggest you start your own New Thread in the MacBook forum.


Previous 1 2 3 4 Next