2 Replies Latest reply: Oct 11, 2012 9:47 PM by yvrmitch
yvrmitch Level 1 (0 points)

My system wont let me update as simply selecting updates.  It continually says the version i have, which is OS X 10.5.8 is the most current version.  And that is obviosly incorrect.  Any suggestions?

MacBook Pro, Mac OS X (10.5.8)