9 Replies Latest reply: Oct 28, 2012 9:30 AM by Hamper
Hamper Level 1 Level 1 (0 points)

I tried dropping a PDF onto Aperture's Dock icon so that the imported file could be configured to import each page in TIFF for example, but since having performed this operation once I find now that every subsequent time I import a PDF this way the options do not appear.

 

How do I get those import options back?

 

Thanks.


MacBook (13-inch Late 2007), Mac OS X (10.7.3), 4GB 667 MHz DDR2 SDRAM
  • 1. Re: Import PDF files via Dock icon drop method
    Frank Caggiano Level 7 Level 7 (23,830 points)

    What happens when you do the drop now?

     

    I've done this in the past, going back to SL, and its always worked for me. I'm now on ML. What version of Aperture are you using?

  • 2. Re: Import PDF files via Dock icon drop method
    Hamper Level 1 Level 1 (0 points)

    Well I was first alerted to it a few days ago and I've been using Lion for a few months now, it worked then but only for that single time it seems.

  • 3. Re: Import PDF files via Dock icon drop method
    Hamper Level 1 Level 1 (0 points)

    Any ideas? I tried updating to 3.4.1 but nothing's changed, I still don't get that import window.

  • 4. Re: Import PDF files via Dock icon drop method
    léonie Level 9 Level 9 (51,720 points)

    Try the following - this works for me with AP 3.4.1 - a variation of Frank's smart trick:

     

    • Select your pdf in the Finder,
    • ctrl-click it,
    • select "Open with" from the pop-up menu
    • select "other, all applications"
    • then navigate to "Aperture" in the file chooser window

     

    Regards

    Léonie

    openwith.png

  • 5. Re: Import PDF files via Dock icon drop method
    Hamper Level 1 Level 1 (0 points)

    Nope, it just imports it.

     

    It must be some setting in Aperture or something.

     

    Nice try.

  • 6. Re: Import PDF files via Dock icon drop method
    Frank Caggiano Level 7 Level 7 (23,830 points)

    Just to make sure I retried this again and no matter how many times I do  dropping a multi page PDF on the Aperture icon opens the import PDF window. It even worked if Aperture was open ( which I didn't expect).

     

    The only time I did not get the window is if the PDF is a single page, then the first  (and only page) is rendered as an image.

     

    You might try moving Aperture preference file out to the desktop and see if that makes a difference but I doubt it will.

     

    Sorry I don;t have more,

     

    regards

  • 7. Re: Import PDF files via Dock icon drop method
    léonie Level 9 Level 9 (51,720 points)

    I tried this now on both my MBPs Intel Core i7 - both AP 3.4.1, both MacOS X 10.8.2.

     

    On the older one, late 2011, I could get the open-dialog only by ctrl-click and "open with" when importing pdfs; on the newer one every pdf-import by dragging onto the Aperture icon brings up the import dialog, even for pdfs with only one page, no matter, if Aperture is running or not.

    I cannot see any differences in the Aperture settings on both machines - very puzzling.

  • 8. Re: Import PDF files via Dock icon drop method
    léonie Level 9 Level 9 (51,720 points)

    Added:

    After rebooting my older MBP because of network problems both MBPs now show the same behaviour - any pdf I drag to the Aperture Dock icon will make the Import dialog window pop up - for all pdf files no matter what the number of pages is or if Aperture is running or not.

     

  • 9. Re: Import PDF files via Dock icon drop method
    Hamper Level 1 Level 1 (0 points)

    It's okay, I figured it out, the problem way my end. I thought that if it wasn't a problem with Aperture then it must be a problem with the file(s), it was. I was using some old software which came with my CanoScan scanner (v5.0.1.4) and found that it didn't create PDFs as Aperture would like, not sure how the spec might have changed between 1998-2009 (when the software was produced) but something must have.

     

    Anyway, I found this out by opening the PDF in Preview and making a "Duplicate" of it (OS X "Lion" here) and then importing that (via dropping the PDF file on Aperture's Dock icon) and it worked, so it was the fault of the scanning software all along.

     

    Thanks for everybody's help, I have reported this to Apple.