Previous 1 2 Next 29 Replies Latest reply: Jan 6, 2013 9:46 AM by Old Toad
Frank Bendrick Level 1 (5 points)

The App Store says I have an upgrade to iPhoto. When I attempt to upgrade via the App Store, I am told I must upgrade via "other accounts." When I attempt to apply upgrades via the iPhoto upgrade download page, I am told that I must upgrade via the App Store.


In light of the seemingly contradictory messages, how do I upgrade my iPhoto software?  What am I missing?


Thanks in advance for your help.



iMac (27-inch Mid 2011), Mac OS X (10.7.4), iPod4G, iPad2, MacPro,MacBookPro
  • mende1 Level 10 (92,176 points)

    iPhoto is registered to another Apple ID. Login with this Apple ID and update the app

  • Frank Bendrick Level 1 (5 points)

    Thanks. However, I have never had nor used an Apple ID other than the one I am using now. If it means anything, I purchased iLife '11 and loaded iPhoto from the iLife '11 disk.

  • mende1 Level 10 (92,176 points)

    Insert the iLife DVD and reinstall iPhoto. Then, open  > Software Update and install the latest iPhoto version: 9.4.1

  • Frank Bendrick Level 1 (5 points)

    I have reinstalled all the iLife '11 apps (iMovie, GarageBand, and iPhoto) from the iLife '11 DVD. When I go to Software Update and attempt to upgrade any of the three apps, I end up on the App Store which says I have updates available. When I attempt to update I get the same message: "You have updates available for other accounts. To update this application, sign in to the account you used to purchase it."


    I still cannot update the iLife '11 apps from the App Store. I have no idea what the "other accounts" might be. What should I try next?


    Thanks again for the help.

  • Old Toad Level 10 (135,388 points)

    If you insatalled iPhoto 9 from the  iLife 11 disk then use the updaters from the Apple Downloads page to update to the version you need. You may get to a point where you will need to get the final version, 9.4.1, from the App Store.



  • Frank Bendrick Level 1 (5 points)

    When I attempt to update these apps using the update download on the Support Downloads page, I get the message: "The version of iPhoto installed on this Mac must be updated through the Mac App Store. Check the Mac App Store to see if an update is available."


    This is a giant run-around. The Apps Store refers me to "other accounts." The Support Downloads refers me to the App Store.


    There must be a solution. What can it be?



  • Old Toad Level 10 (135,388 points)

    What version of iPhoto at you at now?

  • Frank Bendrick Level 1 (5 points)

    I am at iPhoto 9.2. The App Store says I have an update to 9.4.1 available. When I attempt to download it, the download fails and I am directed to "other accounts." 


    I have downloaded the 9.2.1 update from the Support Downloads page. When I attempt to update from that download, the update fails and I receive a message saying the this app must be updated via the App Store.


    The App Store directs me to "other accounts." Update downloads from the Support Download page (the only "other account" I can find) directs me to the App Store. I am like a ping-pong ball bouncing back and forth across the table.


    What is the resolution? Any ideas?



  • Old Toad Level 10 (135,388 points)

    Contact the App Store for some direction.

  • Evan McM Level 1 (0 points)

    I am having the exact same problem.  I don't know what to do, I'm using 9.4.1 right now.  I have the 9.4.2 update but it won't run because it also directs me to the app store.  When the app store tries to update, it says I have to log in to other accounts.  There are no other accounts, this is a fresh install of ML.  There seems to be no way around this.

  • Old Toad Level 10 (135,388 points)

    I got the same message and thought that I had only one Apple App Store account.  I was wrong.  At one time I accessed the account from our laptop or my iPhone and had used a difference acct ID there. Luckily I had a list of account/password info in a encoded file that I keep up to date very carefully and found the other ID there.


    Good luck.

  • Frank Bendrick Level 1 (5 points)

    I finally solved my problem...


    I had previously transfered my files and apps from my old Mac Pro to my new iMac using the iPhoto was the only app that I migrated to my iMac that seemed to pose a problem in that I could not update it. My old Mac Pro was still on my LAN. Out of desparation and with a total lack of ideas on what to do next to solve my iPhoto problem, I copied the iPhoto app on my Mac Pro to my iMac. To my surprise, the copied iPhoto app updated with no problem.


    I have no idea why the copied app worked properly while the migrated app didn't. But it did. So.... problem solved.


    If anyone else has had a problem with an app after migrating it from one machine to another, I suggest you try copying it over your LAN to your new machine.


    Thanks for all the ideas and help all of you provided.

  • LarryHN Level 9 (76,951 points)

    Had you bothered to mentioned that this was a new system and  how you migrated to it the answer would have been very simple -

    Migration assistance does not handle the iPhoto library well sometimes - the best way is to drag the bad iphoto library from the pictures folder on the new system to the desktop, connect the two systems together (network, firewire target mode, etc) and drag the iPhoto library intact as a single entity from the old system to the pictures folder of the new system and launch iPhoto on the new system - it will open and convert the iPhoto library as necessary and you will be fine - once you test the iPhoto library you can delete the one on the desktop


    Remember we can not see your machine and only know what you tell us




  • ApexLongimanus Level 1 (0 points)

    My problem is slightly different. I am getting the same messages (my Mac tells me that updates are available but under another account ...which I don't have). However, I "migrated" to another system when my hard drive failed. I recovered data from a backup onto the new hard drive. No migration assistance. I finally dragged my originals from the "old library" to iPhoto 11. While that worked, I am still stuck with a non-upgradeable iPhoto 11 version.

    Any suggestions?

Previous 1 2 Next