5 Replies Latest reply: Apr 26, 2013 9:18 PM by dStarman
MarkPic Level 1 (0 points)

After upgrading to IOS 6, the Airplay icon was missing and couldn't use my home Pioneer receiver.  After talking to tech support, the Airplay devices simply advertise themselves over the network.  Traced it to my Verizon FIOS MI424WR router.  Airplay started working again when you disable "IPMG Proxy" which is enabled by default.  Login to the router, Advanced -> Yes -> IPMG Proxy - Set IGMP Proxy (Enable/Disable): to Disable and save.  Hopefully this saves someone a headache.


iPhone 5, iOS 6
  • revho13 Level 1 (0 points)

    Thanks, I was having the same problem and this fix worked for me. You sir are a gentleman and a scholar.

  • MarkPic Level 1 (0 points)

    You are welcome!  I was stressing this week over this but we both owe a poster in the Verizon forums that I discovered this morning, worked first time, thanks!

  • Paul Mindolovich Level 1 (0 points)

    OMG - This was driving me nuts. I even told my son to watch out when you upgrade software, sometimes it makes things that worked before - NOT work anymore, especially Apple software - and I'm an Apple fan...

     

    This fix WORKED for me, thank gawd... Too bad Apple doesn't clue us in to the fact that an upgrade might have issues... we have to go scouring the web to find answers. It took me 4 different search strings in Google to finally arrive here.

     

    Imagine if I weren't a 'techie'. I work as an IT SysAdmin. What if my wife, mother, or Grandpa had this issue?

     

    Apple, wake up.

  • roadsider Level 1 (0 points)

    I'm seeing this solution all over the place, but unfortunately it isn't working for me. My IGMP settings were already disabled.

     

    I have a MI424WR-GEN2 F model, and I also can't get the airplay icon to appear on any of my devices, Mac OS or iOS, wired or wireless. I can, however, get iTunes sharing to work just fine.

     

    On this router, I can't set the wireless to be G only, because it's also an N router as well. There's no option.

     

    All the macs are at least running 10.7.5 and all the ios devices are version 6.

  • dStarman Level 1 (0 points)

    Thanks, worked like a charm, wish I found this post a few days ago, I just had to string together the right bits of info and find the culprit. Had a feeling it was the new router. Thanks agin.