13 Replies Latest reply: Nov 3, 2012 3:51 PM by Neville Hillyer
Markie76 Level 1 Level 1

Hi Guys,


I wonder if you can help.


I have recently bought a G5 Imac (ppc) with10.5.8 on it which I have reinstalled with a single user setup as an admin.


At home I have DSL broadband with a Belkin F5D8636-4 N wireless router. My windows laptop and Android phone connect to it fine and internet works fine with the current settings.


On the Imac Airport connects absolutely fine to the router and the internet works as expected.

On the ethernet connection in the NETWORK screen in settings, I get a green circle by Ethernet but status within the 'Automatic' location states 'Not Connected'.


I have tried various variations of the setup; Using DHCP/DHCP with manual address/Manually - by typing in an IP address within the address range set in my router, typing in the router address, changing the subnet mask to match the router, nothing seems to work.


What I have tried;


If I set "configure" to 'Using DHCP' and click APPLY - the circle turns yellow then green after 5 seconds and it shows IP: SubnetMask BUT the status says "Connected. Ethernet has a self-assigned IP address and may not be able to connect."


If I set "configure" to 'Manually', then for IP I enter subnetmask I leave as (I changed the LAN setting in my router to match this) router I enter and click apply - the circle turns yellow then green and the status says "Connected. Ethernet is currently active and has the IP address". But when I launch Safari it says 'You are not connected to the internet'. When I log into my router and check the DHCP client list there is no entry for IP


I then click on 'Network Diagnostics' button in Safari, in the Network Diagnostics window on the left;

Ethernet has a red circle and under it states 'Failed' &

Network Settings has a green circle with nothing beneath it &

ISP has a red circle and under it states 'Failed' &

Internet has a red circle and under it states 'Failed' &

Server has a red circle and under it states 'Failed.


I then select Ethernet in the main window and click CONTINUE - The title says 'Not connected to Ethernet' and under it tells me 'This computer does not seem to be connected to a DSL or cable modem, or to an Ethernet network' - I click CONTINUE  - title changes to 'Unable to connect to the internet' and under it tells me 'Network Diagnostics cannot fix the current networking problems' - I click on QUIT.


I have tried both a 'straight through' and 'crossover' network cable and same behaviour with both.


Please help as my initial Imac satisfaction is diminishing quickly.





iMac, Mac OS X (10.5.8)
  • BDAqua Level 10 Level 10

    Hello Mark,


    Sadly it sounds like defective Ethernet Port, both are dead on my G5 Quad.


    One possibility that can cause Ethernet problems, possibly this also...


    Might be time to replace the PRAM Battery, 4 years is close to their lifespan, far less if ever without AC power, & can cause strange startup problems...


    See which one your G5 has...





  • Markie76 Level 1 Level 1

    Thanks for your reply.


    Since my post I have managed tp borrow the hard drive from another Imac of the same age which is loaded with OSX 10.4 and this machine was part of a work network (tries to access server foe email & files).


    With this hd in my Imac the ethernet port works fine - WIFI switched off and the Imac connects ok to my broadband router and once connected it shows up in the DHCP client list as expected.


    So the ethernet port seems to work ok and my problem is with the OS / network setup.


    What should I do now?

    * Try setting it up again/run some help apps?

    * Try to reload OSX 10.5




  • BDAqua Level 10 Level 10

    Ah, that's pretty good news!


    I guess I'd try a 10.5 re-install.

  • Markie76 Level 1 Level 1

    Reinstalled 10.5.



    On first startup where it goes into the network setup prompt it couldn't connect to the router - either using DHCP and auto or manual (typing in the router IP address). It then went to black screen and after 20 seconds the fans went into turbo loud mode.


    After restarting and going into the network setup - same as before - ethernet gets a self assigned IP as it can't connect to anything (green dot next to ethernet icon)


    So the ethernet works with 10.4 but not with 10.5 - is this a known bug or has Apple decided ethernet isn't trendy enough anymore?


    I think I'm just going to stick with Windows....it works

  • BDAqua Level 10 Level 10

    I wonder if the Ethernet Kext from 10.4 would work in 10.5, mine is...?


    /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleBCM5701 Ethernet.kext

  • Markie76 Level 1 Level 1

    Sorry, I don't understand?


    As far as I understand and have been told by other Mac users "All OSX systems should just work - the hardware is a standard format which can't be changed like in a Windows system and you end up with 1001 permutations".


    I agree - if it was windows and I had installed an old ethernet card from a tiny Taiwanese manufacturer into the latest mobo & cpu combination - I'd be accepting of problems.


    But I haven't done that. I have an Imac which is fixed hardware spec (apart from RAM).

    Ethernet works in 10.4 but doesn't want to know in 10.5 - the next release.


    Something is not right and I don't expect to have to start taking drivers from the old version and insert them into the new.This is Apple's responsibility prior to telling us how fantastic (yeah right!) all their products are and everyone on the globe should be in their clan...

  • BDAqua Level 10 Level 10

    Well, since Apple is not going to fix it, I'm just trying to suggest a possible workaround, no idea if it'll work since my 10.5 setup was stolen a few months back.

  • Markie76 Level 1 Level 1



    I typed a proper reply but it got lost as OSX in its wisdom somehow decided that although I logged onto the forum via Airport when I pressed the POST button I would want to transmit it by Ethernet which was not connected.


    So despite having an Imac for 3 weeks, I've had enough and going to give it a new home in the bin then I'm going to buy a Sony Vaio... :)

  • Neville Hillyer Level 4 Level 4

    Well done with your testing and disk swap.


    In my experience there is nothing about the Leopard install which makes wired ethernet unreliable.


    There is a kext problem caused by one of the upgrades which was never fixed by Apple but that does no more than put regular messages in the log - it does not affect reliability - for cleaner logs replace it with the earlier kext.


    Here are my network settings:


    Picture 1.png


    Try yours with the same. If your router fails to provide a DNS Server set it to


    Hit Advanced and turn off IPv6 - it is not going to work properly for most people for several years.


    Set your router to DHCP with as few limitations as possible. If practical change its DNS server to


    Turn off all wireless (at router and the problem Mac) until wired ethernet is working.


    Remove all ethernet connections to Mac and router except those being tested.


    Turn off all firewall restrictions and virus software.


    Try all ethernet cable and socket combinations. No need to play with cross-over cables as all Macs have auto-detected for many years.


    Reset router - see instructions - some just need power removing for 10 minutes. Shutdown and restart Mac a few times. If necessary repair Mac disk and permissions - I use AppleJack with the following instruction:


    applejack AUTO shutdown


    Good luck.

  • Markie76 Level 1 Level 1

    Hi Neville,


    Thank you for taking the time to write such a detailled reply.


    I have followed and tried your suggestions; DNS, IPv6 off, DHCP & manual(again), all WIFI off, just Imac going into router, tried all router ports/diff cables, with firewall off, no virus software installed, router/imac reset/left off for extended periods, even tried my old Netgear G router (old faithful) and tried running Applejack = no difference, ethernet green dot but no internet connection and in diagnostics just say failed but WIFI works fine.


    Then I plugged my Win7 laptop into the router, which connected straight away and opened up a DOS window and did some IP trace routes (I think thats what you call them) and various pings.

    Interestingly enough I started getting replys or rather hits from an IP address starting with 169.254.... with a constant 32ms responce time. I checked the Imac network ethernet settings and it was showing 169.254..... it was similar but the last digits were different to the 'self-assigned' IP (it was set to automatic and DHCP) on the screen. My router IP is and my Win7 laptop is with no other devices connected.

    So looks like the Imac is responding to network ping requests/commands but not managing to connect to the router/DHCP.


    I have a netgear 10/100/1000 8 port hub - is it worth getting it out and setting up some network monitoring application to trace every device on the network OR is that only worth doing if you have a managed hub/switch with software in it?





  • Neville Hillyer Level 4 Level 4

    When you installed Leopard did you import anything or was it a clean install with all preferences etc entered from the keyboard? If not perhaps you could try this. Backup everything to an external disk. Erase internal disk. Install Leopard without importing anything. Update via Software Update.

  • Markie76 Level 1 Level 1

    Thanks for your reply.


    Always a clean install. I ran the install DVD and got it to do the quick format (mac journaled file system).

    During the install process I skipped the network setup bits.

    I tried the ethernet setup after the install and 1 reboot - same behaviour, ethernet not working WIFI ok.

    I then did the 700mb (or so) software update to 10.5.8 and after rebooting tried again - you can probably guess what happened



  • Neville Hillyer Level 4 Level 4

    Sorry - unable to think of anything else except to try another install.


    I will  recap for others who may wish to help:


    1. G5 / Leopard wired ethernet not working on either socket - wireless works OK.
    2. Wired ethernet works with Tiger on alternative hard disk.