9 Replies Latest reply: Jan 16, 2013 12:08 PM by bmcdade00
KlausBG Level 1 Level 1 (0 points)

Hi all


I hope someone can help me out here as I am very new with Apple stuff


I have installed server tools on Mountain Lion and trying to get my mail server running and I had it running for a short period and received a couple of mails but then I did not receive more mails


I get these entries in the SMTP log when starting the Mail service:


Oct 14 05:53:09 otrimac.ontherun.dk postfix/postfix-script[88002]: fatal: the Postfix mail system is not running

Oct 14 05:53:20 otrimac.ontherun.dk postfix/postfix-script[88554]: warning: not owned by root: /etc/postfix/main.cf copy

Oct 14 05:53:20 otrimac.ontherun.dk postfix/postfix-script[88557]: warning: not owned by _postfix: /Library/Server/Mail/Data/mta/./guid_device_maps.plist


I have tried the following in Terminal


sudo chown root /etc/postfix/main.cf

sudo chown _postfix /library/server/mail/data/mta/./guid_device_maps.plist


I still get the same log entries when starting the mail service


Can anyone please give me a solution for this?




iMac, OS X Mountain Lion (10.8.2), OS X Server utilities
  • Mark23 Level 3 Level 3 (975 points)

    Restart the machine.

  • Mark23 Level 3 Level 3 (975 points)

    Have you upgraded mountain lion to 10.8.2 and server to 2.1.1?


    Some while ago this hint helped me as well:



    smtpd_client_restrictions = hash:/etc/postfix/smtpdreject cidr:/etc/postfix/smtpdreject.cidr permit_mynetworks


    smtpd_client_restrictions = hash:/Library/Server/Mail/Config/postfix/smtpdreject cidr:/Library/Server/Mail/Config/postfix/smtpdreject.cidr permit_mynetworks



    alias_maps = hash:/etc/postfix/aliases


    alias_maps = hash:/Library/Server/Mail/Config/postfix/aliases


    remove (because there's no such file):

    virtual_alias_maps = $virtual_map


    virtual_alias_domains = hash:/Library/Server/Mail/Config/postfix/virtual_domains

  • COWegner Level 1 Level 1 (0 points)

    As Mark23 said: upgrade mountain lion to 10.8.2 and server to 2.1.1 first.


    Restart the server.


    The two warnings are not the reason for postfix not starting. There must be other things - sadly the log level isn't adequate for trouble shooting.


    Check the presence of an MX record in your DNS (and that your server is using this very DNS). If you've configured SSL, check the certificate, private key and that postfix can use them. IMHO these are two top reasons for postfix not starting.


    If it doesn't help: increase the log level.

  • KlausBG Level 1 Level 1 (0 points)

    The iMac was first upgraded to mountain lion and upgraded to 10.8.2 and was not a server at that point. Then server tools was installed wich directly is version 2.1.1.


    The server was restartet


    I actually found that none of your lines was in the main.cf file so your suggestions has been added and I still got no mails and could send mails.


    The MX record seems to be in place and I also originally did receive a few mails and then suddenly no mails at all.


    I then made changes in Filtering Settings - disabled virus filtering og disabled junk mail filtering and together with your lines I now receive some mails again.


    If I enable virus filtering and junk mail filtering mail flow stops - any suggestions?


    Does the server tools wizard not make the main.cf file changes? Is there a best practise for the main.cf?


    Maybe my main.cf file is a mess


    I get lines like this in the smtp log


    Oct 16 18:55:01 otrimac.ontherun.dk postfix/qmgr[84575]: warning: connect to transport private/smtp-amavis: Connection refused


    Thanks Mark23 for your support :-)

  • COWegner Level 1 Level 1 (0 points)

    There is a /Library/Server/Mail/Config/postfix/main.cf.default in the same folder where main.cf resides.

  • wschaff Level 1 Level 1 (0 points)

    ....If I enable virus filtering and junk mail filtering mail flow stops - any suggestions?....


    Thank you. Thank you


    I have the same problem, but now mail server works using just server config tools (no manual .cf file editing), blacklist enabled, junk filter disabled, filtering disabled.

  • COWegner Level 1 Level 1 (0 points)

    Hello wschaff,


    I recommend to open a new discussion on your problem and give more detailed information (e.g. log exerpts).


    Kind regards


  • Jos@apple Level 1 Level 1 (0 points)

    ....If I enable virus filtering and junk mail filtering mail flow stops - any suggestions?....

    have same issue.....


    when i analyse the smtp log file, found also the next error

    ..... relay=none, delay=141119, delays=141119/0.04/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to[]:10024: Connection refused)


    the workaround to get email working:


    Server.app : set email filtering off , junkmail filtering off and only blacklist enabled.



    i think this is a serious problem and hope apple can help here asap



    OS X 10.8.2


    Message was edited by: Jos@apple

  • bmcdade00 Level 1 Level 1 (0 points)