Previous 1 2 3 Next 86 Replies Latest reply: Apr 18, 2016 9:36 AM by Erlingq
d.a.u.1 Level 1 Level 1

Hi, I wonder if anyone can help me. My airport express keeps dropping off my network. I use it for AirPlay. Every time I want to use it I have to disconnect it from the power. The light on the side is green. If anyone has a solution I would appreciate it.

Airport express, iOS 6
  • CRMDVM Level 4 Level 4

    Hi - you will probably have to do a factory reset but before that, please post back with some info about your system - which Express do you have? - how ole is it? - is is your primary router? - if not what other router or Airports do you have and how are they connected?


  • d.a.u.1 Level 1 Level 1



    Thanks for your quick reply. I have a BT router as my primary router hard wired to my Apple TV and main pc. The airport express is not being used to extend my network but just as an airplay receiver into the kitchen stereo and is doing that wirelessly. The airport express is the older variety and was bought about 6 months before the update. I hope this gives you enough info. Cheers

  • CRMDVM Level 4 Level 4

    OK - check out this info the link to the Airplay setup - you will have substitute your devices but the concepts are the same - you will set up the Express as a wireless access point - -


    Older Express.JPG

    To reset it to factory defaults, disconnect any devices from the Express - unplug it and press in and hold the reset button and plug it back in - when the light flashes, release the reset button - wait until the light flashes slowly indicating that the device is reset - then using the above info as a guide, re-configure the Express to join your existing network as a wireless access point using the Airport Utility - if it still doesn't work, then it is just not happy with your particular setup - this sometimes occurs in some non- Apple networks - of course I am biased and would suggest you repalce your BT router with a new Express or Extreme - but this is my opinion and the choice is yours - I hope this helps.



  • d.a.u.1 Level 1 Level 1



    Thanks for reply. I have reset the AE as you suggested and still no joy. To add to puzzle I have since bought a new second gen AE and still the same happens. I can only surmise the problem is with my router and possibly the firewall within the router. I will play around a bit more with its firewall and port forwarding to see if I can solve the problem otherwise it's a new AirPort Extreme for me!

  • CRMDVM Level 4 Level 4

    I like your last idea - get a new Extreme and everything should play nice - note the keyword "should".

  • eicio Level 1 Level 1

    I have the same issue.  My AE (2012) is in "client mode", connecting wirelessly to an Airport Extreme base station.  I use the AE for AirPlay only.   The AE works for a few hours, then the front light goes to amber and the device is no longer visible to the network (via AirPlay or the Airport Utility).  I have to unplug and replug the power to get it working again.


    I also have a prior generation AE configured the same way.  It works without issue.

  • d.a.u.1 Level 1 Level 1

    It does sound like we're all missing something in the black art of wireless connectivity! Just to add a like more info to the discussion both my Ae's are always showing a green light but nonetheless still drop off my airplay list, only a hard reset sorts them out. What happened to 'it just works'!




  • PeterS Level 1 Level 1

    Exactly this problem too. With a BT router. Elsewhere someone has suggested disabling DHCP, but no idea how to do this... Any help appreciated. Thanks.

  • d.a.u.1 Level 1 Level 1

    Sounds exactly like my issue. Is there anyone out in the ether that can help?

  • Joachim Blunck1 Level 1 Level 1

    I run my iTunes music over the following network:


    MacMini wireless to...

    Main AirPort Extreme with a wired (old) and wireless AirPort Express (old).

    wireless to

    Remote Extreme with a wired AppleTV (new), wireless AppleTV (old), and a wireless Express (old).


    All was fine until the last weeks or so, which I think may have corresponded with an iTunes or other software update. I've also been noticing persistent difficulty keeping a connection with i-Devices running the Remote app.


    I'm seeing much the same thing many of the posters are: an unexplained simultaneous drop of all the Expresses after a few minutes of play.  The only remedy is to turn off the WiFi on the host MacMini, and turn it back on.  The connections reestablish, only to drop again.  Do nothing and the connection will mysteriously reappear after a spell, only to drop again.


    I've tried all the remedies here, including setting all the devices to static addresses, disabling IPv6, using AirFoil, saying voodoo chants, etc, etc.


    There would appear to be some basic incompatibility between the AEX's and the MacMini, particularly apparent when being used in iTunes.


    Hopefully this will be addressed in some fix along the way.  Very frustrating.

  • CRMDVM Level 4 Level 4

    If the light is turning to solid amber it could mean that the Extreme is experiencing an internal electronic issue such as overheating - if re-setting it helps, that is good, but you might want to be prepared for a complete failure in the future - if it is blinking, it just means an error condition such as a dropped connection is occuring and your Extreme is ok as far as electronics are concerned.

  • Joachim Blunck1 Level 1 Level 1

    Amber light is a different problem to the pervasive one that keeps showing up.  The thread start alluded to a repeatable problem with AirPlay in the latest configuration.


    No blinking here, no AEX connectivity issues -- they all show up in AirPort Utility.


    If you keep your Multiple Speakers dialogue in iTunes open, along with AirPort utility, you can watch it happen again and again.  All wireless devices are fine, they just come and go from iTunes.


    I think it important that we get cut through all the clutter of people flailing around, particularly those new to the technology.  The note I wrote above documents a very particular issue: a simultaneous disconnect and reconnect of AEX base stations from iTunes AirPlay that is not remedied by the usual means. It affects both Macs and PCs apparently.


    This is not an AEX hardware failure.  It is not an interference issue. It is not a Firewall issue.  It is not an IPv6 issue.  It is not a TCP/IP isssue. Using ping doesn't fix it.  We need to stop with all the guesswork and confirm the basic, repeatable conditions of when this failure happens.


    The issue is almost exclusively reported in connection to iTunes AirPlay -- note the start of this latest of many thread. The problem cropped up in spades during the upgrade to iTunes 10, if you examine the discussions here and elsewhere.


    Apple is in their usual public display of denial, which if they act according to form, will be fixed by some update along the way.  The best thing is to document the particular, specific problem and report it over and over and over.

  • CRMDVM Level 4 Level 4

    We are all volunteer users just like you - we only are trying to help - sometimes we know the answer and sometimes we make suggestions that might help and will open a dialogue that may lead to a solution - we have no affiliation with Apple nor do we know why Apple does what they do - I review unresolved posts to see if I missed something or to see if I can learn something new that can be passed on to other users - and according to forum guru King Penguin  - "these are user-to-user forums, they are not monitored by Apple - there are too many forums/threads/messages for that to happen" - so I suggest that if you think you have something that Apple should know, contact Apple directly at -

  • Joachim Blunck1 Level 1 Level 1

    Already did.  Yes, we're here to help.  But I've also seen over the years that volume influences the fixers.  More hammering on careful documentation of a specific issue eventually gets results. I posted my observation get help coalesce posts on this specific issue -- Google searches eventually bring the frustrated together.


    That being said...  The AEX drop issue has become more vexing.


    Earlier today I noted that my AppleTV asked for account verfication.  Another thing that haappens more often since Apple's tightening of security.  Updated the account by re-entering pertinent, once there now gone credit card info like the expire date and security code.  Since that little maneuver a couple hours ago the AEX connection has been stable. Furthermore, the account update was made via a computer that doesn't feed the AEXs.


    So... next time it drops I'm going to see if the casue and effect is repeatable.  Wouldn't that be weird?

Previous 1 2 3 Next