Previous 1 2 3 4 5 6 Next 88 Replies Latest reply: May 1, 2016 11:42 PM by Michael Hall5 Go to original post
  • macrophotog Level 1 Level 1

    I have been struggling with the same issue since installing a new Netgear wireless router (WNDR4000 N750 Dual Band Ggabit). I have two older AE's (one is the original and the other is the first version of the "n"). They work flawlessly when connected via the LAN, but when connected wirelessly, they disappear, reappear, sometimes work, sometimes not.


    Recently they disappeared for weeks and I set out to fix the issue. After finding this thread, I decided to look into the wireless settings on my router. I decided to change the settings on the wireless SSID they were connecting to (SSID is 2.4 Ghz b/g/n). The only change I made was to the "mode." It had been set to "up to 300 Mbps" and I changed it to "up to 54 Mbps." After this change, the AE's are functioning flawlessly on the wireless and have for several days. I have never had this long of a run with flawless wireless operation since installing the new router. So I believe this is a fix for me. . .

  • gerryhoban Level 1 Level 1

    This worked for me. Thank you. Everything else (ip6 change, Wifi Channel Change etc) did nothing. I think it has to do with how long the 'lease' lasts on various levels of security. After about an hour of inactivity, my old 6.3 AE disappeared from the airplay list, yet the green light stayed on.


  • JWS27 Level 1 Level 1

    Thanks Matt.  You solved a very frustrating problem.  I had a problem with  signal drop-out after setting up the Airport Express.  I tried relocating the unit to improve signal strength, changing channels on the router(Lynksys E2500) and disabling other wireless devices on the network.  None of these worked.  Finally, I found your posting. The soloution was simply to change the security setting to WPA2/Personal.

  • Grant Warkentin Level 1 Level 1

    My ap express (generation1 I believe) was dropping constantly.

    This thing was solid as a rock when i first got it.


    Problem seemed to start after upgrading to the 7.6.x firmware.


    Did two changes to the unit today.

    1. downgraded to 7.5.2 firmware -- so far no issues anymore.

    2. Joined my existing wireless network (wndr3700 router)


    Don't think number 2 was the soln as the AirP was working very well when it was just connected via ethernet thru a western didital powerline network doo-dad. Plus the other three devices connected to the powerline box have had zero issues.



    Used the instructions in this thead to downgrade:



    You would manually upgrade or downgrade firmware for an AirPort right from AirPort Utility:


    Screen Shot 2013-02-16 at 4.47.17 PM.png


    The "trick" is to hold down the option key on your Mac while you click on the current version number. Then, other avaiable versions will display. Simply click the one you want.

  • Loyo! Level 1 Level 1

    Hello Everybody:



    I used to have the same issues.



    I have and Airport Extreme conected wiresly to and Airport Express, that I use ONLY for Airplay (join network).



    This can sound a bit ironic, but the problems began when I change the chanel of the airport extreme, that was one of the solutions mentioned here. I did that because I wasn't recieving the Internet Speed in the second floor, and for that work excelent, but the AExpress began to drop every 10 to 12 hours daily. I Did a hard reset, downgrade the firmware an so on and nothings happend.



    This solution only applies to the people who have:





    I change in the Airport Express the protocol... instead of DHCP, I change it to "Static"



    If you use the Airport Express only as a speaker, you dont need internet on it, you just need that device in your network, so if the DNS message apperar, just ignore it, and go ahead... we need the Airport Express just as a speaker, not to extend the network.



    NOW, I have a Bose SoundDock10, that doesnt requiere internet connection (Internet radio and so on), so, if you have a system that WILL require internet, this solution is not for you. The mention above have worked out for me for about a month ago flawlessly



    I repeat: If you use your Airport Express to extend your network, maybe this will not be a solution.



    BUT if you use it as an AirPlay Speaker, I'm pretty sure this will work it out.






  • yendoggy Level 1 Level 1

    thanks Loyo.. I'm going to try this.. so freaking annoying.. dropping every day.. twice a day.. dont need it to extend.. just for music streaming so i'll try this...

  • rudolfm Level 1 Level 1

    I tried that, didn't help. Worked whole evening and when I woke up today, it was disconnected again.


    It seems like there is plenty of solutions for this issue, each of them working for different users. I kind of find that annoying, really.

  • PMG526 Level 1 Level 1

    I am having the same problems and it is more than annoying!!  I have the newest model AirPort Extreme thinking that it would be best for my home networking but it has been doing nothing but dropping its signal constantly.  I had been blaming my service provider for this issue until I finally looked this problem up to see if anyone else was having this issue and sure enough.  Is there an answer to this problem?

  • olaf-the-hairy Level 1 Level 1

    I am utterly bafflled. My setup has a 2nd Gen Airport Express used exclusively for Airplay and connected to my BT HomeHub. None of the steps I I have tried thus far have had any effect.


    As with others, the connection appears to drop out at random intervals when Idle, usually around 5-10 minutes, but I have recently noticed that whilst Airport Utility for OSX reports a lost connection; Airport Utility for iOS reports a healthy connection. This makes no sense as the issue lies between the BTHH and AE. At least that's what I thought. Can anybody comment on this?


    Additionally, I am interested to know if those expereince problems are a minority or if the combination of AE + BTHH (or any other router) is problematic in all cases.

  • Chris Wigness Level 1 Level 1

    Hi all.  Here is an update on my problem, with some possible good news.  The solution that I referenced above (including changing the channel to "static" and channel 8) worked for a couple of months, but then the dropping problem came back with a vengeance.  I started experiencing regular drop-offs on a daily basis. 

    I spent some time on the phone with an Apple tech rep, whose conclusion was that I was getting interference from something in my house and he suggested that I should purchase a new express so that I can put one very close to the main base station.  I got pretty annoyed because (a) the express is currently only 25 feet away from the main base with just one wall between them and (b) we shouldn't have to spend that kind of money so that we have devices every few feet!  But I gave in and tried an experiment - I plugged in the express right next to the base station.  Well, that actually worked for a while and I was feeling rather embarrassed for completely discounting the guy's diagnosis.


    But ... yes the story continues ...  after another month or so, the express started dropping again even though it was right next to the base station.  At that point I was ready to give up.  I moved the express back to the location where I wanted it, plugged it in and then casually clicked on the software update notice that I was getting.  The notice included an Airport software update.


    It has only been about 10 days since I ran the update but so far so good!  I'm running version 7.6.4 now.


    I'm curious to hear if anyone else has tried the update with or without success.

  • Thinkpadius Level 1 Level 1

    Just purchased and started using the 2nd generation airport express (2012).


    Within hours of setting up the system I was getting dropped connections to the internet.


    I attempted hard resets, I attempted altering the DCHP/NAT setup to bypass the modem, all of it.


    The simple solution, so far, has been the firmware update. 7.6.4 is working out well right now and I'll come back to report how things go.  7.6.3 was a really bad firmware version - it even made my airport extreme (3rd gen) drop its connection.


    here's my connection info for comparison:


    Comcast ---> Linksys CM100 Cable Modem ---> Airport Express ==extended by== Airport Extreme ---> 10-20 computers/ipads/phones at any given time.


    I handled all the management of the Airport Express from a Windows PC. 

  • Thinkpadius Level 1 Level 1



    While typing the post above, the Aiport Express dropped my internet connection.  I restored my connection to the internet simply by disconnecting from the wireless network and then reconnecting.  It instantly restored the connection.


    This leads me to the thought that it's related to a lack of throughput.  If the AE doesn't receive any back and forth to stay awake, it just drops your internet connection.

  • pogacsa Level 1 Level 1

    my setup is very much the same. Since some time having dropouts on express port (old, 2.4G only).

    ISP Pirelli router+modem ===> Apple Extreme Base (dual band 5G+2.4G) ---- AirPortExpress (old, 2.4G only) speakers on, and eth used for my printer.


    ISP Pirelli is DHCP, WLAN OFF

    ExtremeBase: Bridgemode only, Local-link, 5G: ch100, 2.4G: ch auto (used to have 10), 5G+2.4G(b/g/n) - NAS (LAN100) on it, and iMac (5G)

    ExpressPort: printer LAN, hifi speakers on jack via Wifi.


    both apple router is the same room, no distance issue should come up. Firmware 7.6.4


    any idea what I am doing wrong?



  • WilsonSmillie Level 1 Level 1

    I'm experiencing the same problem and have been for the best part of a year. I have 2nd Gen AirPort Express using firmware 7.6.4 currently, but the problem existed in prior firmware releases too. I have a BT HomeHub 4 as part of a BT Infinty setup. The Hub is the DHCP server and the DHCP lease is set to renew every 10 days.


    I think the problem is definitely to do with the Airport and is absolutely visible when using AirPlay because the music stops, then starts again.


    Check your logs on the device. Start the Airport Utility, choose Manual Setup, then Advanced. Click the Logging and Statistics tab, then the Logging and Statistics button on that page.


    Each entry is date & time stamped. I'm experiencing a 'Disconnected from network' message every 10 minutes. After 5 seconds it reconnects and renews the DHCP lease. Here's an extract from the log over a period of 45 minutes.


    It disconnects 5 times, mostly for 5 seconds. The last disconnect is longer, nearly 14 seconds, this time it re-syncs with timeserver.


    Nov 18 14:15:345Disconnected from network.
    Nov 18 14:15:375Joined BSS 2c:39:96:cb:c3:9b
    Nov 18 14:15:385Installed unicast CCMP key for authenticator 2c:39:96:cb:c3:9b
    Nov 18 14:15:395Internet configuration leased [IPv4] -- host <> gateway <> dns <> wins <> lease <86400> domain <home>
    Nov 18 14:16:435Internet configuration leased [IPv4] -- host <> gateway <> dns <> wins <> lease <86400> domain <home>
    Nov 18 14:25:345Disconnected from network.
    Nov 18 14:25:375Joined BSS 2c:39:96:cb:c3:9b
    Nov 18 14:25:375Installed unicast CCMP key for authenticator 2c:39:96:cb:c3:9b
    Nov 18 14:25:405Internet configuration leased [IPv4] -- host <> gateway <> dns <> wins <> lease <86400> domain <home>
    Nov 18 14:29:474AirTunes stream from started.
    Nov 18 14:32:355Connection accepted from [fe80::9163:e647:3395:b207%bridge0]:51456.
    Nov 18 14:32:365Connection accepted from [fe80::9163:e647:3395:b207%bridge0]:51457.
    Nov 18 14:32:575Connection accepted from [fe80::9163:e647:3395:b207%bridge0]:51458.
    Nov 18 14:35:345Disconnected from network.
    Nov 18 14:35:375Joined BSS 2c:39:96:cb:c3:9b
    Nov 18 14:35:375Installed unicast CCMP key for authenticator 2c:39:96:cb:c3:9b
    Nov 18 14:35:395Internet configuration leased [IPv4] -- host <> gateway <> dns <> wins <> lease <86400> domain <home>
    Nov 18 14:36:025Connection accepted from [fe80::9163:e647:3395:b207%bridge0]:51468.
    Nov 18 14:36:055Connection accepted from [fe80::9163:e647:3395:b207%bridge0]:51469.
    Nov 18 14:36:155Connection accepted from [fe80::9163:e647:3395:b207%bridge0]:51472.
    Nov 18 14:40:345Connection accepted from [fe80::9163:e647:3395:b207%bridge0]:51570.
    Nov 18 14:41:355Connection accepted from [fe80::9163:e647:3395:b207%bridge0]:51575.
    Nov 18 14:45:345Disconnected from network.
    Nov 18 14:45:375Joined BSS 2c:39:96:cb:c3:9b
    Nov 18 14:45:375Installed unicast CCMP key for authenticator 2c:39:96:cb:c3:9b
    Nov 18 14:45:395Internet configuration leased [IPv4] -- host <> gateway <> dns <> wins <> lease <86400> domain <home>
    Nov 18 14:46:595Connection accepted from [fe80::9163:e647:3395:b207%bridge0]:51659.
    Nov 18 14:47:005Connection accepted from [fe80::9163:e647:3395:b207%bridge0]:51660.
    Nov 18 14:48:335Connection accepted from [fe80::9163:e647:3395:b207%bridge0]:51664.
    Nov 18 14:55:345Disconnected from network.
    Nov 18 14:55:475Joined BSS 2c:39:96:cb:c3:9b
    Nov 18 14:55:475Installed unicast CCMP key for authenticator 2c:39:96:cb:c3:9b
    Nov 18 14:55:505Internet configuration leased [IPv4] -- host <> gateway <> dns <> wins <> lease <86400> domain <home>
    Nov 18 14:56:395Clock synchronized to network time server (adjusted -1 seconds).
    Nov 18 14:57:485Connection accepted from [fe80::9163:e647:3395:b207%bridge0]:51680.
    Nov 18 14:57:505Connection accepted from [fe80::9163:e647:3395:b207%bridge0]:51681.
    Nov 18 14:57:565Connection accepted from [fe80::9163:e647:3395:b207%bridge0]:51684.


    This needs fixing by Apple, they're the only ones who can do something about it.



  • WilsonSmillie Level 1 Level 1

    More information on this after speaking to the Apple Support team and doing some more research.


    If your configuration is one wireless router/hub and one Airport Express, the Airport Express MUST be connected to the router by Ethernet cable to use AirPlay with iTunes. The Airport must be connected in Bridge mode.


    Subsequent Airports can be added wirelessly, creating a 'serial chain' if you have multiple speaker systems throughout the home, but the must chain off the first bridged Airport.

  How to setup and configure Airport Express for AirPlay and iTunes


    The last of the four use cases described contains the statement, "Due to the overhead required for this configuration, you may expect AirPlay drop-outs such as intermittent loss of audio."


    This statement, IMHO, confirms that Apple have a problem that their Airport documentation (2012) doesn't explain as it suggests this configuration should be the default one.

  Setting up and configuring an Extended Wireless Network (802.11n)


    These two articles explain all the options for configuring Airports to Apple requirements.


    Personally, I'm pretty hacked off having to use a cable to connect a wireless device to make it work! But that's Apple for you.