Previous 1 2 3 4 5 6 Next 82 Replies Latest reply: Feb 21, 2015 6:11 AM by maxrobert Go to original post
  • JimmyBear Level 1 Level 1 (0 points)

    Thank you Wilson, I'm having the same dropped music connection problems (which I never had before).  I'm working off a 1st gen Express and can't believe that Apple has resorted to a cable connection solution either.  After playing with different firmware versions, I am finding that 7.6.1 is holding up fairly well.  No cable. 

  • Niels-SA Level 1 Level 1 (0 points)

    I experienced similar dropped connections with both my Airport Express (used for music streaming) and my Airport Time Capsule. Unplugging and plugging in again only solved the issue for a couple of minutes. Downgrading the firmware of only the Airport Express to 7.6.1 did it for me. Now both the Express and Time Capsule remain part of the network without having changed anything to the settings of the modem.

  • Aladdinsdad Level 1 Level 1 (0 points)

    After reading through this great set of posts I fixed my own problem - now working for several days. I changed the channel on my router, and it was either that or the simple fact that I reset my router afterwards which did the trick. Suggest people try resetting their router/modem first.

  • bjja Level 1 Level 1 (10 points)

    Just dropping in to share my experience with my 2nd generation airport express. So, starting with the network setup where problems occured:

     

    The internet connection is dsl via vodaphone using the EasyBox 803, which is an all-in-one box with dsl modem and wireless router. Since i already had a router and wifi the airport should just connect to the existing network to allow music playback. However, no matter if i connected it wireless, or through ethernet to the EasyBox, no matter WPA/WPA2 settings, no matter b/g/n settings, the airplay droped out constantly, even if it reponded to pings.

     

    The problems occured with my Macbook Pro, my gf's Macbook Pro Retina and our iPhones. (4s and 5) The phones rarely detected the airplay option, and using the computers it usually dropped after a couple of minutes, requiring a restart of the airport.

     

    Tested different firmwares as well, without effect.

     

    The solution for me ended up being ditching the wifi in the easybox, replacing it with the wifi from the airport. So, now the airplay is connected via ethernet to the EasyBox in bridge-mode. The wireless part of the EasyBox is completely turned of, since the airport now is used as a wireless access-point.

     

    Result for me: Works flawless with the computers and phones mentioned, using the 7.6.4 firmware. As a bonus, I now also have a 5 GHz wifi as well, which was not available in the EasyBox.

  • Dudley Curtis1 Level 1 Level 1 (5 points)

    I have managed to solve a similar problem to others on this thread.  Thought I would share what worked for me, as the various responses helped me get the solution.

     

    Briefly.  I have a cable wireless router as my main wireless gateway.  It supports Wifi 11b/g/n.  I wanted to add a 2004 airport express (v6.3) to the existing network simply to use the audio out to an old JBL iPod dock (AirPlay).

     

    As others reported, the AirPlay option would appear and disappear at random, and drop out often even when it was connected.  Very annoying, and basically useless.

     

    The setup that now seems to work is setting the router to WPA-PSK [TKIP] + WPA2-PSK [AES] security.  144Mbps option.  Channel-auto.  The AirPort Express needs to have the security setting as WPA2 Personal. 

     

    Key point here for me, the AirPort Express has two options which sounds similar: WPA/WPA2 Personal  and WPA2 Personal.  It needs to be the latter, WPA2 Personal.  Making this simple change, then resetting the modem and the AirPort seems to have fixed the problem.

     

    No need to connect the AirPort Express via a cable in my particular case, and as others have reported.  Rather defeats the object - and wouldn't have been a solution for me because of router location.

     

    Incidentally, a related problem was installing the AirPort Utility 5.6.1 on my ageing MacBook with Lion.  The software refused to install, as others trying to install on Mavericks have found.  There is a fix available online involving downloading a special launcher file which adds support to a missing library file that is needed by the old AirPort Utility.  That worked for me on Lion, and enabled me to run the utility.  Without it, my AirPort would be junk.  As it is, I'm chuffed to still be able to make use of this 10 year old box to stream spotify from my iPhone to an old dock!  I won't link to it, because others have reported Apple deleting references to that solution. 

  • stualden Level 1 Level 1 (0 points)

    I just wanted to add that making sure all Air Port Express boxes were set to WPA2 Personal, and the routers/access points are also set the same (there it might be called WPA2-PSK [AES]) solved my problem too, although I'm not totally sure why.  Thanks to all the previous posters who took the time to research this!

     

    My issue was that the list of AirPlay devices on the iPhone would randomly change - devices would come and go, whether they were currently being used or not.  This included wireless AEX, wired AEX, and PCs running Shairport4w.  Getting the wireless settings all consistent at WPA2 Personal solved the issue.  I'm not sure why this would have anything to do with the wired devices, but it did.

  • martley Level 1 Level 1 (0 points)

    Hello all, I just want to say thanks so much for this thread.  I moved hosue got a new router and couldn't get my Airport Express to stay on the network once I'd set it up.  It just kept disconnecting after about five minutes and wouldn't recognise.  The exact same thing as was happening to others on this thread.  I tried for almost seven hours trrying lots of different forum advice to sort it out and was on the verge of buying a new Airport.  Then I found this thread and changed the security to WPA 2 Personal from the other setting and it solved the problem.  Thanks again it's much appreciated I can now stream all my music from my MacBook, iPhone and iPad. 

  • Nipo dude Level 1 Level 1 (0 points)

    I finally got my airport express (AE) to stop dropping the signal. It took me so long to finally getting it to work so I would like to share what i have done.


    Apartment size is aprox 100 squared meters, the AE is set up in the middle of the apartment.


    I got it the AE so I could have all of my network devices running in dual band running at 5Ghz (faster connection) and one iphone 4 at 2.4GhZ.

    I have an Apple MC414Z/A AirPort Express Basisstation 802.11a/b/g/n running  firmware version 7.6.4


    Gateway set up

    My set up includes a Gateway (router-modem combination) by my internet provider running on 192.168.0.1 with both WIFI and the DHCP disabled. The internet company uses a rotating IPV6 protocol. I have opened all the ports on the gateway that Itunes and airplay require to work on both UDP and TCP which detail. 1119, 6113, 1120, 80, 3724,443 and 8689. In addition I have allowed access to all the MAC addresses of all the devices that i have on my network, including the AE.


    AE set up

    An ethernet cable is connected to the first LAN port from the gateway to the AE's WAN port. The AE is set up to create a wireless network with no hidden network. The extra 5Ghz network though is also active so it broadcasts two ssids.  The AE is configured to a static IP address 102.168.0.2, the router address is set to 192.168.0.1 subnet mask 255.255.255.0 The DNS server hasn't been a problem but i am currently using 42.182.18.228 DHCP only is enabled starting the DCHP range at 192.168.0.20 to 192.168.0.200 with a 1 day lease allowed. Radio mode is automatic and channel 1 and 36 are used for 5ghz and 2.4Ghz correspondingly.

     

    Individual device set up

    Every device in the network is set up with a static or manual IP address starting from 192.168.0.3 until 192.168.0.10 with the router on 192.168.0.1

    IpV6 protocol is disabled in all of the devices. For more information on how to disable IpV6 on mavericks (http://help.unc.edu/help/how-do-i-disable-ipv6-on-mac-os-x/) The devices such as laptops and Mac mini and apple TVs  are set up only to recognise the 5Ghz network, while the iphone 5s recognises both 5Ghz and 2.4 and an Iphone 4 only the 2.4ghz

     

    Extra set up

    I have connected an FM transmitter on the sound output of the AE (http://www.czhfm.com/index.php?main_page=product_info&products_id=16) using an analog cable. The range of the FM transmitter is such that it covers all the apartment and so i saved money on buying wifi speakers such as sons. The FM transmitter is set up at an empty frequency on 82Mhz.

    Apple tv is set up with digital audio out put to a samsung sound bar. The samsung TV is not connected to the internet. I don't deem it necessary and I have read about problems with bandwidth hogging from the samsung tvs.

     

    In conclusion this setup has allowed me to have music from my itunes library all over the house using the remote app on the iphone 5s, with good interconnectivity among all the devices (like it is intended) but it took me three months to figure it out. I believe the problem was the dhcp handling by the gateway and the IPv6 enabling. The AE handles DHCP now but its not really being used since all devices are set up manually and there are no clashes. The guest network is disabled since it has been reported to produce drops in signal as well.

     

    i hope this helps

  • Mattijs Level 1 Level 1 (0 points)

    My Airport Express was experiencing audio drop outs, which looked like network disconnects because now and then the Airport Utility also lost connection with the Airport. My Airport Express is in 'Join a network' mode.

     

    After almost a full day of trying and searching for solutions I solved the issue by doing a channel scan on the wireless router/modem. The channel was set to 11 initially, after scanning it found 3. I also selected the '802.11g only' mode (see screenshot). Not sure which of the two did the trick, but I'm not touching it anymore since it works now

     

    Screen Shot 2014-11-02 at 02.49.39.png

     

    Hope that helps someone!

     

    Also I hope that Apple realizes one day that their suggestion that an Airport Express 'just works' is not realistic.

     

    Mattijs

  • Mattijs Level 1 Level 1 (0 points)

    Also, right now I am listening to audio streamed via Airplay but still I am looking at the screen below in Airport Utility This is really not the quality I have come to expect from Apple..

     

    Screen Shot 2014-11-02 at 02.54.46.png

  • dfletter Level 1 Level 1 (0 points)

    I too have had this issue for years. I have done extensive tests and I am willing to discuss this with anyone who thinks they have a solution. I have a rather complex network and many devices on that network. But still no matter how stripped down I make the network I get erratic performance. Sometimes it remain connected for days at a time. Other times only about 15 minutes. Now at least I only need to deselect the airplay device in iTunes and reconnect it. But I frequently get core dumps from ITunes that show a stack overflow from some recursive process that causes it to crash. ITunes is clearly very sensitive to any network issues and it appears this dropping issue is related.

  • Mint Level 1 Level 1 (50 points)

    None of these solutions seem to help me, and I think it must be the particular Airport Express I have.  I bought three at the same time, that work through a Time Machine.  Two work perfectly, the other drops out continually (and I have tried changing them around to confirm it is the unit, not the location).  I have done all the resting recommendations. 

     

    If I take it to a Genius Bar will they be able to help, or should I just accept I have a faulty unit (not out of warranty) and buy a new one?

  • lewisfromberkhamsted Level 1 Level 1 (0 points)

    Ok, I have the same problem and am fit to throw my AE out the window. 

     

    I bought an older AE to use to connect to my HiFi so I can stream music to it.  So I plugged it in, and set it up as an additional item on the network.  I have been able to find it using my iphone and ipad,and successfully stream music through it, but after a few minutes of playing it drops off the Network every time, then Airplay disappears as an option on the phone/iPad.  The only thing that works is to hard reset the AE then go through the whole set up process again.  It works for a while, then drops off the network again, its crap!  After a short bout of Spotify it seems to drop off again it's driving me mad the POS!  My WiFi is set up on a WPA2 password already, I can't hard wire the AE as it's too far from a phone socket (besides it should work wirelessly as that's what its purported to be able to do).

     

    Any ideas??

  • Dudley Curtis1 Level 1 Level 1 (5 points)

    There are two WPA 2 options in the setup.

     

    WPA/WPA2 Personal or WPA2 Personal


    You must select the latter (i.e. WPA2 Personal)


    That worked for me.


    In the end, my old airport express is now sitting in a drawer.  I bought cheap bluetooth receivers on ebay. One with an old iPod dock connector for an old JBL dock, and one which is battery powered for a Tivoli Radio in my kitchen.  There is no noticeable difference in sound quality out of these speakers.  If you are linking up to a top of the line hifi - then maybe AirPlay is still best. 

  • lewisfromberkhamsted Level 1 Level 1 (0 points)

    I am pretty sure it's set to that already, but just to confirm, I would adjust these settings for the router by clicking on the network preferences on my laptop right?  And how do you set that on the AE, using Airport Utility?

     

    I am thinking of binning it in favour of a Bluetooth Audio Transmitter too, would be so much easier and at least the **** thing would just work.  Disappointed in Apples performance on this product I must say