11 Replies Latest reply: Mar 14, 2014 1:06 PM by Ralph Johns (UK)
Han Solo 5 Level 1 (0 points)

I understand that iMessage replaces iChat in Mountain Lion.


I am using a macbook pro with OS X 10.8.2 and an iPhone with OS 6


I really liked that it appeared that imessages sent from my computer imessage app showed up and synced on my iphone messaging.  Very cool.


However, I am noticing that this ability does not seem to be 100% even when it's clear that the messages are all being sent using iMessage (ie from phone and from computer). 


In particular if the computer is off and someone sends me an iMessage it never seems to show up on the computer iMessage app.   The same applies when I originate an iMessage from my own iPhone.  I have the impression that perfect syncing requires that the computer be on and logged in.


Is that true? 


Is there some other setting or something I can do to make sure that messages sync between both platforms. 


I think, but am not sure that all messages from the computer eventually show up on the iphone.  However, will this still happen if the iPhone is off.


Is there someone out there who can enlighten us. 


Also I understand that iChat allowed video chatting, but that iMessage doesn't seem to permit this or it's not obvious how this is done.







iPhone 4S, iOS 6, Same problem applies on the web
  • Ralph Johns (UK) Level 9 (71,094 points)



    It does seem to be that iMessages sent when one device or another is Off for some reason that syncing is not as good as it could be.


    Some people are reporting that odd iMessages seem to sync days later.


    There does not seem to be any way to improve this.

    (It also seems worse in iOS 6 and OS X 10.8.2 but this could be due to the amount of traffic that is involved now.)


    It is not clear how long the iMessages server "push" messages that it thinks need syncing


    Messages can do everything iChat can do PLUS the iMessages bit.


    If you have other accounts set up in Messages (other than the iMessages one) then the Window Menu will list "Buddies" and the CMD + 1 Keystrokes to view the Buddy list.

    At this point the list is combined (Se the General Section to Unlink them)

    The Green Video icons or highlighting the Buddy and then using the icons at the bottom of the Buddy List still work.


    For a Contact (A person you are  iMessages the Video camera icon top Right in the Messages window starts up FaceTime.

    Of course this also need to your to "register" an Apple ID

    Most people use the same one as they do in Messages but technically it can be different (Just more difficult to explain to Contacts why your contact info changes).




    10:13 PM      Wednesday; October 17, 2012

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"


      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 (71,094 points)

    For the points Helpful Star




    7:05 PM      Thursday; October 18, 2012

    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"


      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • aaaaaaakkkkkk Level 1 (0 points)

    why doesn't some idiot at Apple read these posts and fix this? Apple used to be user friendly. Now it's worse than Microsoft ever was. get with the program

  • StigBull Level 1 (10 points)

    Here's how I fixed syncing:


    I have two Macs (2011 Mini and Retina MBP), an iPhone 5 and a iPad 3. All running OSX 10.8.2/iOS 6.1.


    At first I turned off iMessages on every device and reactivated it again.

    I then notices that on my MBP and on the iPhone, iMessages was set to use my phone number to receive and send messages. This option was grey so I was unable to untick it.


    My Mini and iPad did not have the phone number option.


    I then deactivated iMessages on the Mini and upon reactivation the phone number showed up. Same on the iPad.


    After this, all my devices started receiving iMessages again.

  • Jmpin1 Level 1 (0 points)

    i just did what you said with a MBP and a iphone 4... worked well.


    thanks for that!

  • appleflyer_1990 Level 1 (0 points)

    So I don't feel like this addresses the problem. Rather than there not being a fix, I feel that Apple needs to make it their priority to MAKE A FIX. Its ridiculous that people spend hundreds of dollars on an iPad an iPhone and the things don't even sync up.


    Quite frankely I'm ****** off because I will send a message on my iPhone to another iMessage user (iPhone) and I will only get a reply on my iPad (happens with every iMessage I receive). This just started today. I have not applied any updates today or yesterday, so no idea why its happening. But Apple, don't you dare say there isn't a fix. Before releasing an update for anything or making any alterations to software or programs you need to have your crap together and make sure no SEVERE bugs like these occur. If I am flying and fail to receive an iMessage that could have a critical impact on my flight, you'll be responsible.

  • Ralph Johns (UK) Level 9 (71,094 points)



    Lets be clear.

    Apple run the boards in terms of it is their Server space  and they employ the Hosts as they are called.

    Other than that they have no input here at all.


    The people posting replies are just other users like yourself that have the same Apple Software and products you do.


    Anybody employed by Apple has to ask permission to Post here and their Accounts used to be marked with a white Apple icon rather than any of the other choices.

    I have not seen one for some while now.


    So it is not Apple who are saying there is no fix.  It is the regular posters who have not found one yet.


    The issue is further complicated as people report slightly different issues with the Sync process.

    This make it it unclear if there is one issue with different presentation or several similar issues that may or may not be linked.

    On top of that I can't replicate the issue myself.  The closest I can get it is the Mac is off (Shut Down) and I send an iMessages from my iPhone the iMessage it self and any replies don't always appear on the Mac and the Messages app when I open the app.


    Whilst very unApple-like Stigbull seems to have had some luck with his reset which jmpin1 supports.


    When you know the app is not working as you expect then there is no point in relying on it in critical situations.

    Having posted you know this trying to make anyone feel presurised in action about it is not going to stand up anywhere if something does happen.




    8:07 PM      Monday; March 11, 2013


      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously


    Message was edited by: Ralph Johns (UK)  8:10 PM

  • lulu_93 Level 1 (0 points)

    Same problem, and I solve it with these steps! Now iMessage is syncronized! thanks!

  • bobdog69 Level 1 (0 points)



    On one side of the coin I agree whole heartedly with your point(s). On the other hand though, I have been where some of the posters have been as far as frustration and anger, and when all seems lost, you turn to the only place you can yell and scream, and that is a board like this. It is unlikely that you could contact anyone at Apple or any other said company (ergo Microsoft) that would actually give a ****. So, again you're left to these boards to vent your anger and frustration, due to some seemingly moronic "dude" or "chic" who gets paid way too much for what he's (she's) worth at said company, and should've figured out the problem BEFORE they sent out the software (or fixed it later with the all too famous "update"). And so I see it both ways. Every so often you need to vent and even, as you say, it's not really Apple or said company, it doesn't matter. Someone out there feels your pain and if that's the only "fix" (no pun intended) you can get then so be it. More power to you. However, as you also point out, good luck getting your problem solved. One should always look before one leaps.

  • Nev_Ra Level 1 (0 points)

    Same issue, iMessage not syncing between my iPhone and Macbook Air.

  • Ralph Johns (UK) Level 9 (71,094 points)



    Have you followed the same fix ?


    Remove the Apple ID on the iOS devices.

    Place in Airplane Mode fro a few mins (break with server)

    The re-add the Apple ID after confirming the iPhone Number is ticked and Enabled on the iPhone.


    Restart the Mac app. Accept the pop ups about the iPhone.

    Re-add the Apple ID to other iOS device and accept the pops there about the iPhone and Mac.


    8:06 pm      Friday; March 14, 2014


      iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad