2 Replies Latest reply: Dec 14, 2012 10:37 AM by dalstott
Aaron Cottrell Level 1 Level 1 (10 points)

Hey peeps,

Seems ive got a bit of a problem getting Aiport to work properly on my G4 Cube running 9.2.2...

When i got the machine it didn't have an Airport card in, so i thought id remedy that situation and now that i have i cannot seem to get the wireless working.

The card works fine, it can see my router and can, apparently, connect to it. However the opening IE just doesn't load any pages.  Whenever i go into the TCP/IP settings it states that the router's address is the same as the address for the machine. Obviously this isn't right since the router address should be 192.168.1.1 (for my home network anyway).

I also have a PowerMac G4 that i have run OS9 and OSX on. On this machine the Airport and wireless has always worked straight away with no problems, so naturally im quite stumped.

 

Does anyone know what going on or can suggest anything that might help?

Cheers

  • 1. Re: Aiport on G4 Cube running OS9
    stuartj257 Level 2 Level 2 (225 points)

    Your machine is supposed to have an IP address that is not already taken on the network. In this case, it appears your Cube has the same IP address as the router, so it in fact does not know where to send the network data.

     

    If you open the TCP/IP control panel on the PowerMac G4 in Mac OS 9, what IP address does that Mac have? Also, are you using DHCP or statically assigned addresses on both machines?

  • 2. Re: Aiport on G4 Cube running OS9
    dalstott Level 4 Level 4 (2,530 points)

    The G4 cube like the early iBooks and Powerbooks had  AirPort card (802.11b). With newer routers 802.11g/n is necessary and it will not work even though it appears to connect. I solved this problem on mu 1999iBook with a Newer Tech USB adapter.

     

    See this thread for the source and a successful outcome.

     

    https://discussions.apple.com/message/20553127#20553127