1 2 Previous Next 23 Replies Latest reply: Aug 18, 2013 10:01 AM by Maximilian13
tryoungem Level 1 Level 1 (0 points)

I have a second generation Apple TV.  I have never had a problem with it.  Until today.

I've read through a.l the forums and looked through the net.

I just came in today and the only icons on the screen were computer and settings.

Have tried to restart, reset, and powered everything off and reset my router.

I've check the IP address and it is correct.

I tried the solution of pressing the remote menu button and the back arrow to get the broken chain - - it gave me the broken chain and I pushed the forward button and got the connected chain.  - no difference.

If I try to restart or reset it gets to the activation screen and just spins and spins, then goes to set date and time and spins and spins.  It will never go anywhere (left it while we went to Wal-Mart.  If you hit menu on the remote it "skips" it.  You can't troubleshoot or anything because it tells you that it cannot connect to the internet, or the itunes store, or to your computer, until you have set date and time.

 

I would appreciate any fixes anyone has for this.  I have set up a $19.00 phone call with Apple for tomorrow night at 7 pm.  Would love to have it fixed before I have to call them.

 

Thanks in advance.


AppleTV 2, iOS 6
  • 1. Re: Won't set date/time - still....
    Segelflygaren Level 1 Level 1 (0 points)

    I'll second that.... frustrating!

     

    Got ATV3.

  • 2. Re: Won't set date/time - still....
    ajdata80 Level 1 Level 1 (0 points)

    Did you get a solution to this problem?  Mine just started doing the same thing today?

  • 3. Re: Won't set date/time - still....
    tryoungem Level 1 Level 1 (0 points)

    Well, I spent the $29 to talk to Apple and have further phone help for a year.  Probably a good thing.  Their fix did not work and I have another call scheduled tomorrow at 7:30 pm.

     

    This is what they told me.  They blamed it on my router.  I have Centurylink (yes, I live out in the country) and use the router/modem provided by them.  But I have had this modem since day one of my Apple TV.  Nevertheless I followed Apple's advice.  They had me check and it was set to WPA - -so I had to call Centurylink and have them reset me to WPA2 (advised by Apple).  I have done so, created a new network and reset all my devices to the new network.  The Apple TV can see the new network and allowed me to log onto it.

     

    I still can't get past the date/time.  It does the exact same thing it did before.  So, news from call # 2 to Apple tomorow night. If I keep the TV on very long I am liable to throw something through the wall...lol.

     

    Although my router did need to be changed to the WPA2, I find it hard to believe it is the router as it has been the same since day one.  Apple is the one who has changed iOS.  We shall see.

  • 4. Re: Won't set date/time - still....
    fenna10 Level 1 Level 1 (0 points)

    Any luck? I've reset my router.  I've never had this problem before. It recognizes my wifi network, but won't set the time and date.

  • 5. Re: Won't set date/time - still....
    Rstang99 Level 1 Level 1 (0 points)

    Add me to the list. ATV3 started acting flaky so I rebooted and now it will not set the date and time. I just get a spinning wheel. All my other streaming devices are working fine.

  • 6. Re: Won't set date/time - still....
    tuffrog Level 1 Level 1 (0 points)

    It's Apples issue. Something on their end. Nothing on my end changed and I'm having the same issue. Had the newest gen ATV since it came out and just tonight after renting a movie and before watching it I started having the issue.

  • 7. Re: Won't set date/time - still....
    Rstang99 Level 1 Level 1 (0 points)

    Okay, thanks. Pretty much the same here.

  • 8. Re: Won't set date/time - still....
    Rstang99 Level 1 Level 1 (0 points)

    tryoungem, I'm hard wired ethernet and run a Cisco 881 and the issue cropped up tonight. I seriously doubt the problem is your router. My ATV3 has been running fine since I bought it. I think it's the latest iOS update.

  • 9. Re: Won't set date/time - still....
    munrai Level 1 Level 1 (0 points)

    Has anyone come up with a solution to this problem?  It started doing it on my Apple TV today.  If tried unplugging Apple TV, holding menu button and left arrow simultaneously, but nothing has happened.

     

    (This is the second issue I've had since I uinstalled the latest update.)

  • 10. Re: Won't set date/time - still....
    Rstang99 Level 1 Level 1 (0 points)

    For the third time today I reset my network then it started working. Can't really say why.

  • 11. Re: Won't set date/time - still....
    tuffrog Level 1 Level 1 (0 points)

    I tried changing the DNS to 8.8.8.8 like others have mentioned and also changing playback to SD then back to HD, but none of those helped. The only thing that seemingly has resolved this for now is resetting the ATV to factory settings. I am now able to play all purchased and rental content.

  • 12. Re: Won't set date/time - still....
    cjs77 Level 1 Level 1 (0 points)

    I had the same issue. Seemed the apple tv broke.

     

    The answer is the apple TV update to 5.1 messed it up. Here's the solution:

     

    1. Download the previous version of your apple TV software here depending on your model:

     

    Apple TV 2:

    http://appldnld.apple.com/AppleTV/041-4362.20120605.t8i4U/AppleTV2,1_5.0.2_9B830 _Restore.ipsw

     

    Apple TV 3:

    http://appldnld.apple.com/AppleTV/041-4361.20120605.grjot/AppleTV3,1_5.0.2_9B830 _Restore.ipsw

     

    2. When I downloaded it, it came as a compressed ZIP file. You need to change its extension to IPSW. (just replace zip by ipsw, no need to uncompress its contents)

     

    3. You will need a MicroUSB to USB cable, in order to connect your Apple TV to your PC in diagnostics mode. Once you get it connected, open iTunes.

     

    4. Wait til you see Apple TV on devices. Once you see it click on it.

     

    5. Press and Hold the "Shift" key (PC) and hit the button "Restore". That way, instead of searching Apple's servers, you'll select the local file you just downloaded.

     

    6. Wait til is restored and a message pops telling you to unplug the USB cable, then do so. In my case The Apple TV kept blinking a while and couldn't power it off with the remote. Just unplug the power cord and replug it after 10 secs.

     

    7. Turn on Apple TV, select language. It'll try activate it. In my case it couldn't connect through Ethernet to the server. I unplugged ethernet cable and went to Network settings and set the Wifi password of my network. Then Restarted on Settings->General.

     

    8. After Restarting it activated itself and everything is working as before. Hope it works for everyone affected. Cheers!

    Like (0) Reply

  • 13. Re: Won't set date/time - still....
    tryoungem Level 1 Level 1 (0 points)

    Well, after the initial phone call to Apple who assured me it was my router/isp security settings I changed my WPA to WPA-2.  I then did all of the appropriate reboots, resets, restarts, router resets,etc... and then called Apple again.  This time they said that I had done all I could do and told me to send it in (I am one month away from out of warrantly, thank goodness).  So, they set up a shipping from UPS and I sent it in.

     

    I just got an email that they have "repaired" it and it has been shipped back.  The turn around was less than 3 days.  So, now I am just waiting around to see if it is a new one or if it is "repaired" or what.

     

    BTW.. of those of you who have the fix of plugging it intothe computer through the USB, I read that on one of the forums as well.  When speaking to Apple support I brought up that I had NOT done that yet, and they  (he) told me don't worry about that, just send it to them.

     

    So, I don't know what to tell you about that fix.  It seems as if it working for a few of you. 

     

    I hope mine comes back fixed.

     

    Thank you,

  • 14. Re: Won't set date/time - still....
    rvm2 Level 1 Level 1 (5 points)

    Here's what finally worked for me with Apple TV 3rd generation. Out of the box, when setup with wi-fi, it breezed through without any issue. As soon as I powered down and connected it to another tv (same wi-fi network), it got stuck at setting date/time. The remote would help in getting out of it, but the home would only have "Computers" and "Settings" and pretty much useless except for AirPlay. Here's what I did to resolve this:

     

    1. On your main router, temporarily disable the firewall or set it to the lowest setting allowable (a reboot of the router maybe required).

    2. Restart apple tv via the "restart" option in the "General" option in the main settings menu.

    3. It should breeze through and not show the "Setting date/time" screen.

    4. Once it loads up properly, turn on your fire wall as before  (a reboot of the router maybe required).

     

    I think it worked for me out of the box, but auto-update to the latest software introduced this bug. So, everytime apple tv tries to synch with the time server, this issue will come back. To disable this, I turned off the "auto time synch" option in Settings -> General.

     

    I am fairly confident that I'd be able to use steps 1 through 4 anytime this recurs. Possible scenarios causing recurrence of this issue:

     

    1. Unplugging the power to apple tv or power failures.

    2. OS updates.

    3. Restoring apple tv using "Restore" or via micro-usb and iTunes to the lastest OS.

     

    Hope this helps. Please post if this works for you.

1 2 Previous Next