1 Reply Latest reply: Oct 17, 2012 5:27 PM by BioRich
BioRich Level 1 Level 1 (65 points)

Hi folks.

 

For some reason, a new virtualhost I have isn't loading right.  It's somehow bringing up the default domain.  Here is my apache entry:

 

<VirtualHost *:80>

          ServerName myexample

          ServerAdmin me@example2.com

          DocumentRoot "/Library/WebServer/Documents/myexample"

          DirectoryIndex index.html index.lasso

          CustomLog "/var/log/apache2/myexample_log" "%h %l %u %t \"%r\" %>s %b"

          ErrorLog '|/usr/sbin/rotatelogs "/var/log/apache2/myexample_error_log" 604800 -240'

          ErrorDocument 404 /error.html

          <IfModule mod_ssl.c>

                    SSLEngine Off

                    SSLCertificateFile "/etc/certificates/Default.crt"

                    SSLCertificateKeyFile "/etc/certificates/Default.key"

                    SSLCipherSuite "ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:+LOW:!SSLv2:+EXP:+eNULL"

          </IfModule>

          <IfModule mod_dav.c>

                    DAVLockDB "/var/run/davlocks/.davlock100"

                    DAVMinTimeout 600

          </IfModule>

          <IfModule mod_mem_cache.c>

                    CacheEnable mem /

                    MCacheSize 4096

          </IfModule>

          <Directory "/Library/WebServer/Documents/myexample">

                    AllowOverride None

                    <IfModule mod_dav.c>

                              DAV Off

                    </IfModule>

                    Options All +Includes -ExecCGI +MultiViews -Indexes

          </Directory>

          <IfModule mod_rewrite.c>

                    RewriteEngine On

                    RewriteCond %{REQUEST_METHOD} ^TRACE

                    RewriteRule .* - [F]

          </IfModule>

          <IfModule mod_proxy_balancer.c>

#                    ProxyPass / balancer://balancer-group/

#                    ProxyPassReverse / balancer://balancer-group/

                    <Proxy "balancer://balancer-group">

                    </Proxy>

          </IfModule>

          <IfModule mod_alias.c>

                    Alias "/collaboration" "/usr/share/collaboration"

                    Alias "/icons/" "/usr/share/httpd/icons/"

                    Alias "/error/" "/usr/share/httpd/error/"

          </IfModule>

#          Include /etc/apache2/httpd_users.conf

#          Include /etc/apache2/httpd_directory.conf

#          Include /etc/apache2/httpd_groups.conf

#          Include /etc/apache2/httpd_teams_required.conf

          LogLevel notice

</VirtualHost>

 

The apache conf file name is 0004_any_80_myexample.conf inside the apache2/sites/ directory. 

 

There's a lot of junk in there, but they're all conditionals and nothing that really deals with the home directory, other than DocumentRoot and DirectoryIndex, both of which are set. 

 

My box is indeed getting the request, as my default domain is being served up, and I see the requests only in the default domain log, not the new domain log, which is properly set.  The error log for the new domain is empty.  Nothing in the default domain's error log with respect to requests being shunted. 

 

Internal DNS is for myexample.ca. to go to 192.168.1.5, just like the other domains.  So apache is next in line, and it's only showing up on the default domain. 

 

Any help appreciated.  I would have manually set this virtualdomain, whose .conf file entry resides beside other VirtualHost domains that work just fine.  I want to stick to the Server Admin application, as I don't want to break anything, but upon this inspection, I don't see anything wrong.  I've restarted the box, and it's been 3 days since I moved on this.  Things should be working.

 

Any advice appreciated.  I can't see anything wrong. 

 

Cheers


iMac, Mac OS X (10.5.8)