Skip navigation

Mac Mini with OS X 10.7 Lion not obtaining router and DNS server info via DHCP.

216 Views 2 Replies Latest reply: Nov 13, 2012 6:47 PM by John with a G4 RSS
John with a G4 Calculating status...
Currently Being Moderated
Oct 15, 2012 8:45 PM

This question concerns a Mac Mini running OS X 10.7 Lion.  In an attempt to connect that Mac Mini to the Internet for the first time, I plugged in an ethernet cable that is connected to a router.  In System Preferences, for the Ethernet settings, the option “Configure IPv4” is set to “Using DHCP”, which is the default setting.  I checked another Mac running OS X 10.6 Snow Leopard, and that latter machine has the same “Configure IPv4” setting. 

 

The Mac Mini is unable to connect to the Internet, and while an IP address is assigned to it, the Ethernet Network System Preferences has blank spaces to the right of “Router:” and “DNS Server:”.  In contrast, the Snow Leopard machine’s Ethernet Network System Preferences has IP address information to the right of “Router:” and “DNS Server:”. 

 

For testing purposes, I unplugged the ethernet cable that was pugged into the Snow Leopard machine, and I plugged that cable into the Lion machine.  Similarly, I unplugged the cable that had been plugged into the Lion machine, and I plugged it into the Snow Leopard machine.  After the cable switch, the Snow Leopard machine again displayed Router and DNS Server server information in the Ethernet Network System Preferences, while the Lion machine continued to not do so.

 

Before contacting my Internet service provider, I thought that I’d check in here in case there was something that I had failed to do with regard to the configuration of the Lion machine.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.