7 Replies Latest reply: Oct 17, 2012 1:35 PM by LaPastenague
rjsimpson133 Level 1 Level 1

I attached NAS to my iMac and left backup to run overnight as apparently the first one is really slow....it really was slow!


This morning there were error messages stating backup has failed - something to do with loss of connection to server.


Tried backup from TimeMachine again and eventually got the above message.

iMac, OS X Mountain Lion (10.8.2)
  • LaPastenague Level 9 Level 9

    See C12.. this is the most common issue in Mountain Lion.. there must be a bug with the networking to the TC.



  • rjsimpson133 Level 1 Level 1

    Thank you very much for your reply - I'm not sure I explained my setup properly because I still have the same problem.


    My iMac is attached to a Qnap TS-219PII Turbo 4TB NAS (2x2TB drives) and the NAS is attached to my BT router via a network cable - I haven't tried to attach the NAS wirelessly yet. I am not using TimeCapsule.


    After my first backup failure I went into TimeMachine Preferences and clicked on "stop using this disc" (TMBackup - iMACSERVER). I then clicked on the disc again and it let me start a new backup.

    The prevoius backup had come up with approx 140Gb to back up - this time is was about 87Gb!??

    It took over 10 hours for this backup to run and yet again it failed with the message: TimeMachine couldn't complete the backup to iMACSERVER - the backup disk image

    "/Volumes/TMBackup/Russell'siMac.sparsebundle" is already in use.

    I then tried to look at the disk - message "connecting to backup volume" took ages and then "an unexpected error occurred (error code - 6584)

  • LaPastenague Level 9 Level 9

    Ok,, very interesting.. you are getting exactly the same error as the TC gets.. which is interesting.. basically the OS on the Mac has lost track of where the disk is..


    There is a long thread about the error -6584.. but it doesn't seem to have a clear resolution.


    I will look up the thread.. this forum has the worst search... ever.


    Did you mount the sparse bundle and verfiy it??


    See A5 in pondini troubleshooting.




    Is the Mountain Lion a clean install?


    Can you ping the NAS by name when the disk is lost?


    Do you enable the server with username and password in finder? I am not sure of the specific instructions for setting up the QNAP with TM.


    I would encourage you to use another backup software.. CCC, SuperDuper, Chonosync are the typically quoted ones. TM gives more trouble than its worth sometimes.


    You can get a check of the sparsebundle by using the option click on the TM icon.


    Anyway this is the thread.



  • rjsimpson133 Level 1 Level 1

    Thanks again for your reply - need to go through more of your suggestions and see what happens! Will get back to you

  • Jan C Level 1 Level 1

    Hello Russell


    OS X uses AFP (Apple Filing Protocol, which started life as AppleTalk (a proprietary network solution)) for Time Machine (TM); like the Apple Time Capsule (TC), the QNAP NAS has that protocol installed and, therefore, it appears as a destination when you open the TM preferences. As a rule (although there are, of course, ways of using exceptions!!), no other protocol (including NFS) should be used for TM backups in order for the various elements to work well together. The setup of any NAS that can be used for TM is identical to the setup for TC.


    Did the iMac go to sleep overnight while the first backup was taking place? It might be that there was some corruption on the NAS if that happened. When attempting to start a second backup, did you ensure that the iMac stayed awake all night? The first backup is crucial and must be successfully completed in order for subsequent incremental backups to occur correctly. The reduced assessment of size of backup might have occurred because TM had worked out that the difference had already been backed up (See http://support.apple.com/kb/HT1427, http://support.apple.com/kb/HT1175 and http://support.apple.com/kb/HT1176#). Don't forget, TM is an application that is capable of fully managing backups on internal, external (directly-connected) or networked drives (offering AFP). If the backup disk (sic) is directly connected, the backups are located in folders in a manner similar to the way they appear on the Mac's HDD; that external drive normally remains mounted by the system. On the NAS, however, TM must first mount the network drive (/Volumes/TMBackup) before generating a special type of disk image (sparsebundle) that can then be mounted to the system; only then can TM start backing up to that sparsebundle. There are, therefore, a number of places where things can go wrong, so I suggest that an 'expert' have a quick look at your system and give a more informed response. I'll be round tomorrow!!



  • rjsimpson133 Level 1 Level 1

    Hi Jan,


    Yes the iMac did go to sleep when the first backup was taking place and probably the second time as well....they just took a lot longer than expected and I don't know how to ensure that the iMac stays awake....I assumed it (obviously wrongly!) did if it was doing something....I'll leave it to the expert!

  • LaPastenague Level 9 Level 9

    The sleep issues was supposedly fixed on Mountain Lion..


    As often the case with Apple nowadays .. a new idea is introduced without a huge lot of testing.




    Simply set the sleep off in system preference power saving.