Previous 1 2 Next 15 Replies Latest reply: Oct 25, 2012 1:23 AM by lauhk
rolfvg Level 1 (5 points)

I have Aperture 3.4.1. Before the ugrade to 3.4.1 I used photo stream about 4 times. It worked and installed a series of photos on the cloud. Now after upgrade to 341 it seems I can no longer upload to photo stream. I select a series of photo's. Than select share photo stream. I want to share this so I had the emailaddresses entered. Then the photo selection is moved to the web photo stream. It shows as a new album in photo stream with the given name, but it doesn't show the shared names. Only shared by me. And no photo's are uploaded even after waiting 15 minutes nothing has happened. Checked all the setting in Preferences. Automated up and downloaded is selected, photo stream sharing is selected. So what am I missing?

  • léonie Level 10 (85,145 points)

    You did not mention your MacOS X version - for a shared Photo stream OS X Mountain Lion v10.8.2 is required.

    Also, you only mention you checked the Aperture PhotoStream settings - did you also check your iCloud settings in System Preferences, and enable Photo Stream there, also in the "options"?


    iCloud: Using and troubleshooting Shared Photo Streams




  • rolfvg Level 1 (5 points)

    OK, you are right. I use OS X 10.8.2 Mountain Lion. Yes, I checked the iCloud settings, both upstream and sownstream are activiated. Also in the options.



  • léonie Level 10 (85,145 points)


    I checked the iCloud settings, both upstream and sownstream are activiated.

    just to be sure we are talking about the same thing - I meant this panel in System Preferences - there is nothing about "upload" and "download":



    One more thing you might want to check:


    When you upload to Photo Stream, the images are copied to a folder in your User Library -

         ~/Library/Application Support/iLifeAssetManagement/assets/

    to folder "sub" and "sub" shared.

    Check, if Aperture really is writing there, or if there are wrong permission settings, preventing the update of these folders.

    If Aperture is not writing esporting to these folders, then correct the permissions. Do you know, how to change permissions?


    The user Library is hidden in Mt. Lion.

    You can reveal it from the Finder's "Go" menu in the main menu bar:


    Finder > Go

    Then hold down to options-key ⌥, until Library appears in the drop-down menu. Select it and open the Library.


    Then select the Application Support folder and inside it the iLifeAssetManagement folder and the assets.

  • léonie Level 10 (85,145 points)

    Two more things that might be causing problems:

    1. If you do not see the uploaded images on  your devices, check the batteries on the devices. The IOS devices do not download from the Photo Stream, if the battery is low.
    2. Also it could help to reset the Photo Stream on your devices, see: iCloud: Photo Stream FAQ  andnd Is there a way to reset my Photo Stream?
  • rolfvg Level 1 (5 points)

    Hi Leonie,

    Thanks for the support. Indeed, the iCloud settings are what you show both My Photostream and Shared Photo Streams are checked. I searched the user library and found the folders sub and sub-shared. Sub was filled with pictures that were visible in Aperture My Photostream. However the sub-shared was empty. With respect to your "two more things": Checked battery life of the MBA and that was 100%. I decided to reset the PhotoStream in accordance with the instructions.

    Than started all over again with Photo Stream. When I share a series of photo's to My Photostream it uploads the photos. It is visible on the iMac and the MBA. However when I want to share a selection of pictures with others by selecting "new Photostream" and insert the emailaddresses, not much happens. I do get an empty folder with the name I have given, but it shows 0 photos and it is only shared by Me. No indication of that being shared with the email addresses. photostream.jpg Checking the iLifeAssetManagement/Assets folder I find that the sub folder is there, but no sub-shared.

    Checked the Photo Stream settings for Aperture and all are "on". Checked the settings on iCLoud for Photostream and all, incl options are "on".

    What's next, please.

  • rolfvg Level 1 (5 points)

    I just uploaded an additional series of photos to My Photo Stream and that works. Seems that the shared Photostream does have a hick up somewhere. Yesterday I found the Sub-shared folder. Today nothing appears, while all the settings are to share Photo Stream.

    Any clue?



  • rolfvg Level 1 (5 points)

    I am sorry, forgot to mention I executed repair disk permissions.

  • léonie Level 10 (85,145 points)


    The Shared PhotoStream is still buggy. For some posters it helped to switch User Accounts.

    • Disable Photo Steam in your account.
    • Restart the system
    • Create a new user account from the System Preferences > Users & Groups
    • Log into the new account, Enable the Photo Stream in this account and in a new Aperture Library, import some images from the PhotoStream into the Aperture Library.
    • Sign out of PhotoStream; quit Aperture; log off
    • Then log into your regular account and enable PhotoStream again.
    • Do the Shared PhotoStreams show?


    I do not see, what else to try. Browse the iCloud forum and send a bug report to Apple (from Aperture's main "Aperture" menu).







  • léonie Level 10 (85,145 points)

    One more thought: have you any applications installed, that might block the network access, like Little Snitch?

  • Oliver1967 Level 1 (0 points)

    I seem to have the same problem.

    I created a shared Photostream on my iPhone and added photos which showed up on all my mobile devices and in Aperture.

    When I tried to add photos to the same shared Photostream in Aperture the photos did not get added to the shared Photostream.

    I then created a new shared Photostream in Aperture and added photos to it in Aperture. These photos showed up. I then tried to add photos to the first shared Photostream from Aperture and now the photos would show up.

    There appears to be a bug in Aperture, not sure what it is.


    To confirm my findings I deleted the second shared Photostream, attempted to add photos from Aperture to the first shared Photostream, but nothing happened.

    Created a new shared Photostream in Aperture and now I can again add photos to all shared Photostreams and they show up.


    Sorry for being so long winded.

  • lauhk Level 1 (5 points)

    I have similar problems with shared photo stream, too,


    1) Aperture 3.4.1 crashed after upgrade. And I have to reinstall Aperture.

    2) Initially, shared photo stream was working fine.

    3) Then I noticed photos uploaded to a shared photo stream FROM my wife's iphoto 4s were not showing up on Aperture.

    Screen Shot 2012-10-24 at 10.31.56 PM.png

    4) Also, cannot upload photos to shared photo stream in Aperture.

    Screen Shot 2012-10-24 at 10.32.09 PM.png

  • Aye Es Oh Level 2 (330 points)

    lauhk – To clarify, you can't upload photos to your own shared photo streams?


    Also, have you tried Leonie's troubleshooting steps above? Do photo streams work inside a different account when you create a new user account?

  • lauhk Level 1 (5 points)



    The shared photo stream ("2012", in the above post) was created by aperture, not iphone. I was able to add photo to Aperture created shared photo streams before.


    1) I have tried repaired disk permission. Doesn't fix the problem.

    2) There is no sub-shared folder in my library.

    3) On my wife's user account, on the same imac, her aperture library have photo stream issues that are kind of mirror my aperture's problem. Namely: i) On her Aperture, she can added photo to shared photo stream. ii) But, she cannot add photo to her own photo stream!!!!

  • rolfvg Level 1 (5 points)

    No other applications installed like Little Snitch.

Previous 1 2 Next