5 Replies Latest reply: Oct 17, 2012 3:10 PM by Vern Dempster
Vern Dempster Level 1 Level 1 (20 points)

In server App the users all need to be selected to turn on the required services. However at the moment on both master and replica I can only see users up to end of D The first 500 users. However in WGM I can see all 1981 users. Strange.


Also anyway to use command-line commands to set the required services for all users


Urgent help needed. Students now back for 2 days with new server and major issues with logins etc


Many thanks for your help


Vern Dempster


MacBook Pro, OS X Mountain Lion (10.8.2), Using pages
  • 1. Re: Server App only displays first 500 users- need to see all
    Mark23 Level 3 Level 3 (975 points)

    I'd just make one or more groups and give that group all the access your users need - you can do this in the Server app - and next use WGM 10.8 to make all users a member of that group...

  • 2. Re: Server App only displays first 500 users- need to see all
    Vern Dempster Level 1 Level 1 (20 points)

    Hi Thanks for the quick response

     

    All students are in the the student group and the student group has all the services ticked. or were in 10.6.8 but something seems to have goine screwy with the import of users and groups from 10.6.8 to ML. I tried migration  and all my 1981 users could be seen in serverapp(so I know I should be able to), but couldn't create a replica so I had to go back to a clean install and import users and groups. WGM has them in the student group but serverapp doesnt show the student group iin the groups panel for all the users, only some. Very confusing. And it doesnt appear to be an issue for users k-Z stored on the replica server.

     

    Thanks

  • 3. Re: Server App only displays first 500 users- need to see all
    Mark23 Level 3 Level 3 (975 points)

    Maybe your OD has gotten corrupted (I assume we are talking about the Master here).

     

    Since you have a working replica you could promote that one to master, destroy the old Master, set the old master up as a replica of the new master, let it do the replication, promote the old master to master and set up the old replica that is now a master to be a replica once more.

  • 4. Re: Server App only displays first 500 users- need to see all
    Vern Dempster Level 1 Level 1 (20 points)

    Thanks

    If the issue keeps happening I will try that in the weekend.... after making a full backup of both boot drives of course.

  • 5. Re: Server App only displays first 500 users- need to see all
    Vern Dempster Level 1 Level 1 (20 points)

    Hi all

     

    I made a backup of both boot drives. promoted server 3 to master and that auto setup server 1 to replica. This did not fix the issue. After experimenting, I went back to the backups. However now all machines have to be setup in directory access to start with Server 2(the last 10.6.8 setup). This can correctly get students to access their shares on Server 1 (A-J) and Server 3 (K-Z)

     

    Yesterday I found.

    1. Shares now have to allow access to the group students which includes all our students whereas before access to everyone was enough.

    2. The 4 shares needed to be set to home directories -(which I thought I did on setup)

    3. Client directory access set to server 1 was yesterady correctly logging (A-J) students in to their shares but it didnt seem to allow them to access their data if it was on the 2 shares on Server 3. After last nights efforts Directory access needs to be set to Server2 as neither server 1 or 3 will now allow logins.

     

    Is there no way to sort out the LDAP data without setting up again ( I am now at the end of the 2nd attempt)

     

    So I am stuck in btween a rock and a hard place, even though I have spent weeks presetting this up and ensuring it worked, as soon as it went into production using all the users, I now have a incapicated system working slowly and erratically again as for every opther upgrade I have done.

     

    PS the webDav access which was the reason for the upgrade is working great from the ipads. Just my legacy 10.5.8 emacs and 10.6.8 imacs etc are in trouble.

     

    Cheers

    Vern